Network Issues - Can Reach Observer, but Not Home Assistant

Looks like the Home Assistant Core did not start, should have 2023.9.1 or similar if it had started. So I think that points to a bad image burned.

Beware of false, harmful software claiming to be balenaEtcher

It has come to our attention that there is a false and harmful version of our software, balenaEtcher, being promoted online. This post is an examination of the discovery, and a reminder to only download balenaEtcher from our official sources: the website, or GitHub repository.

Basically, the version at is spyware.

That answer might be to simple. The official etcher github is full of users complaining about ads, tracking and privacy issues in the official version :point_down:

So it might be the issue linked by @francisp (that thread also posts a solution btw.) :page_with_curl:

As both projects are open source you have everything you need evaluate it. The simple fact that etcher shows ads that can’t be disabled and has a option to restrict tracking (which conveniently can only disabled after data leakage) might be some clue already. Missing ads and missing settings for tracking in usbimager on the other hand is something to investigate further. :male_detective:

I have been using Etcher for a few years and I have never seen an ad. I downloaded my copy directly from Etcher.

probably you run a stone old version then (which also doesn’t suffer failed flashes and maybe messes with DNS).

People already asked over four years ago for an option to remove/hide the ads in balena etcher :point_down:

“Over four years ago”…

Windows 98 had “phone home” spyware, does that make every version of Windows spyware?

I am using Balena Etcher 1.18.11 downloaded from If there is a newer version then it was released in the past ten hours. Last night I flashed the X-86 binary of Home Assistant to a USB drive. The ONLY ads presented during the flash operation was for Etcherpro.

Please stop spamming us with old conspiracy theories.

…wait for it…

Now you have seen one :raised_hands:

Wasn’t Windows 98 one of the last few OSes without telemetry actually? Maybe you are confused with Windows 10/11 which only allows turning off most of the “home calls” in the enterprise edition :point_down:

Microsoft themselves recently demonstrated why it is a bad idea in the very beginning to trust this entity :wink:

A quick (and simplified) summary of the report:
Microsoft found:

  • Iinadequate controls around sensitive information and processes involved in handling sensitive information.
  • Inadequate detection controls for account compromise for developer accounts.
  • Poor documentation and library configuration allowed an insecure configuration to be pushed to production (Exchange Online).

Microsoft Finally Reveals how they Believe a Consumer Signing Key was Stollen

Your phone OS most likely also has a “phone home” function - all for your best and protection obviously :warning:

Abstract— […] We find that even when minimally configured and the handset is idle both iOS and Google Android share data with Apple/Google on average every 4.5 mins. The phone
IMEI, hardware serial number, SIM serial number and IMSI, handset phone number etc are shared with Apple and Google. Both iOS and Google Android transmit telemetry, despite the user explicitly opting out of this. When a SIM is inserted both iOS and Google Android send details to Apple/Google. iOS sends the MAC addresses of nearby devices, e.g. other handsets and the home gateway, to Apple together with their GPS location. […]

Mobile Handset Privacy: Measuring The Data iOS and Android Send to Apple And Google

Wow. Imagine the audacity of Balena who makes Etcher for free to advertise their professional version while you are using their free software. Who would ever tolerate that? Certainly not Home Assistant with the subtle links to Nabu Casa.

All that discussion whether Balena Etcher is spyware or not does not help with OP’s problem.

1 Like

Well, I finally got around to trying to re-image the NUC. I used usbimager this time and got the same exact results (can reach the NUC at http://homeassistant.local:4357/ but not at http://homeassistant.local:8123/). I think we can put the topic of Balena Etcher vs. usbimager to bed for now and perhaps try to understand why, as @lordwizzard said:

Any suggestions?

Before we start down another rabbit hole, lets recap.
Your monitor connected to the NUC does not show an ipV4, but it does show an ipV6?
Is this the binary that you flashed to the NUC M.2 SSD?
I don’t recall if I asked, but what do you get when you run from a cmd window:
ping homeassistant.local /4
Does the NUC have Internet? (Ethernet, not WiFi).

Do you have another M.2 SSD? Can you flash the binary for Ubuntu and run Ubuntu? With IPV4? (t should be the same regardless of the OS since DHCP assigns IP addresses to the MAC address).

That is what it looks like to me. Yes.
I have no idea why it’s not getting an IPv4 address.

Yes. That’s the one. haos_generic-x86-64-10.5.img.xz

Small modification because I only have Mac computers, but ping homeassistant.local returns
ping: cannot resolve homeassistant.local: Unknown host

Yes. Wired via ethernet.

I don’t have another SSD, but this installation of HAOS isn’t doing me any good, anyway, so I re-flashed with Ubuntu. I see only IPv6 addresses getting assigned for Ubuntu, as well. What the heck?

Your system cannot see a DHCP server. Check your DHCP server if it is functioning or even if it is connected to the LAN.

AHA! It’s not Balena or Home Assistant. You have a hardware problem.

Do you see anything from an IP scan for that mac address?

Does this NUC have WiFI?

Didn’t you say that you had Windows running on it with IPV4?

Hello friends my first post here
I have the exactly same problems here at my house
And I believe it’s the starlink router…
I should try in another house with fiber optic internet to make sure…

Had the same problem. Just executed ‘ha supervisor update’ and the service at 8123 started responding as expected.

Had the same problem: observer loaded, but the homepage not.
I was playing around in the CLI, tried out the mentioned ‘ha supervisor update’ command, got error that already the latest. Made the supervisor restart couple of times (supervisor restart) and bamm, it started to load in the browser.
I am not exactly sure what made it load, just happened.
Probably worth to mention that the PC running the VirtualBox is quite slow: i5-6. series, 4 gb ram.

Hi everyone! This looks to me like problem I had some time ago. I solved it by using a different imager.