New Add-on for HomeMatic/homematicIP support - Action Required

Now I get it!
My irritation comes from the fact that there are also integrations that are installed separately, e.g. 1-Wire.
And those are what I come across first when I search for integrations. But these are the Home Assistant community driven integrations, right?
Homematic is built-in, right?
Thanks for the explanation!

Have a nice Sunday!
RT

… and you have also answered my other question. Who can read …and also reads further down, is really at an advantage.
Here is the empty program explained by you that I requested in my first post: https://github.com/danielperna84/custom_homematic#events-for-homematic-ip-devices
Thanks for that too! Now it really goes on.
Have a nice Sunday!
RT

And of course I will install custom-homematic. At the moment I’m running everything in empty space and experimentation gets you further, doesn’t it?

Hi Daniel,
I have tried to read everything twice and more than that to make sure that I have not made any configuration mistakes but still cannot figure out what I am doing wrong.

I have RaspberryMatic installed and have added 4 HomematiIP radtiotor valves successfully. I can control them from the GUI and the GUI picks up changes on the hardware. So far so good and all smooth.

I also went into the configuration.yaml to add the necessary lines for the INTEGRATION.

It looks like this:


homematic:
  interfaces:
    rf:
      host: de838cd8-raspberrymatic
      port: 2001
      resolvenames: json
      username: "Admin"
      password: "1234"
    wired:
      host: de838cd8-raspberrymatic
      port: 2000
      resolvenames: json
      username: "Admin"
      password: "1234"
    wireless:  
      host: de838cd8-raspberrymatic
      port: 2001
      resolvenames: json
      username: "Admin"
      password: "1234"
    hmip:
      host: de838cd8-raspberrymatic
      port: 2010
      resolvenames: json
      username: "Admin"
      password: "1234"
    groups:
      host: de838cd8-raspberrymatic
      port: 9292
      resolvenames: json
      username: "Admin"
      password: "1234"
      path: /groups
  hosts:
    raspberrymatic:
      host: de838cd8-raspberrymatic
      username: "Admin"
      password: "1234"

Any idea why it is not working?
I have also added the IP of my Home Assistant instance to the “ip addresses for restricted access” list. For now have opened the ports although I would like to change that again.

So I am running a bit out of ideas and would appreciate your help.

When I tried the new Homematic(IP) local integration it did not proceed after I had entered the host (as shown above). It just showed “unknown error”.

Thanks,

Merc

Without seeing the logs it’s impossible to give any advice. But: you say you only have HmIP thermostats. Then why do you have 2 entries for port 2001 and one for 2000 if you don’t have that device category in your setup?

Hi Daniel,
thanks for the quick reply.
When I set up the integration I first just copied over all the entries from the example, not knowing what might be important or not. But now I have removed parts so that only rf, hmip and groups is left. Is that ok?

Regarding the log, which log would you prefer? The error logs on startup or the full home-assistant.log?

The full log is too long.
So I start with the error logs, please let me know if you need something else.



Logger: homeassistant.setup
Source: components/homematic/__init__.py:255
First occurred: 07:30:56 (1 occurrences)
Last logged: 07:30:56
Error during setup of component homematic

Traceback (most recent call last):
  File "/usr/local/lib/python3.9/site-packages/pyhomematic/connection.py", line 76, in start
    self._server.start()
AttributeError: 'HMConnection' object has no attribute '_server'

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/setup.py", line 235, in _async_setup_component
    result = await task
  File "/usr/local/lib/python3.9/concurrent/futures/thread.py", line 58, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/usr/src/homeassistant/homeassistant/components/homematic/__init__.py", line 255, in setup
    homematic.start()
  File "/usr/local/lib/python3.9/site-packages/pyhomematic/connection.py", line 82, in start
    self._server.stop()
AttributeError: 'HMConnection' object has no attribute '_server'

Logger: hahomematic.central_unit
Source: /usr/local/lib/python3.9/site-packages/hahomematic/central_unit.py:822
First occurred: 07:30:41 (66 occurrences)
Last logged: 08:03:12

check_connection: No clients exist. Trying to create clients for server Homematic
Logger: hahomematic.xml_rpc_proxy
Source: /usr/local/lib/python3.9/site-packages/hahomematic/xml_rpc_proxy.py:68
First occurred: 07:30:39 (67 occurrences)
Last logged: 08:03:12

(111, 'Connection refused')

One more remark. In the RaspberryMatic settings I had changed the host name to (homematic-raspi) for a while and had also tried to use this in the configuration file. What surprised me was that in the browser url bar the link never changed and it always looked like this:

http://192.168.1.12:8123/de838cd8_raspberrymatic/dashboard

So I assume the “de838cd8_raspberrymatic” is the actual host, correct?
I have now changed the host in the RasberryMatic setting to de838cd8_raspberrymatic.

Thankf for your help with this.

Regards,

Merc

So there is some sort of progress…but then not.

I have changed the configuratio.yaml again to this:

homematic:
  interfaces:
    #rf:
    #  host: de838cd8_raspberrymatic
    #  port: 2001
    #  resolvenames: json
    #  username: guest
    #  password: test
    hmip:
      host: 192.168.1.12
      port: 2010
      resolvenames: json
      username: Admin
      password: 1234
    #groups:
    #  host: de838cd8_raspberrymatic
    #  port: 9292
    #  resolvenames: json
    #  username: guest
    #  password: test
    #  path: /groups

  hosts:
    raspberrymatic:
      host: 192.168.1.12
      username: Admin
      password: 1234

and I have used these settings in the new Homematic(IP) local integration as well.
Now, there is no more error message on startup of Home Assistant…but still I cannot find the devives.

I have renamed them to Radiator - [Room] so I was searching for Entities/Devices with the name Radiator but they do not show up.

So what now?

Thanks,
Merc

Success.
I can find the devices. But they do not get their clear name. I can only find them by their serial number. Is this intended or what would I have to do in order for the clear name to show up?

Thanks,

Merc

The username and password are relevant for the names to work. I assume 1234 is not your real password. Sadly the integration does not allow fancy passwords. So if yours has any special characters, change it to something with only a-z and 0-9.

Actually 1234 is the password at the moment. But still the names did not get picked up.

As many others had similar problems with resolving names, please use the search-function to find further topics that cover that problem. I’m fairly sure you’ll find answers there that will help you. Configuration-support is out of scope for a topic that actually announced changes in a very different part of Home Assistant.

Understood. Sorry for the off topic question and thanks for the help and of course for the great integration.

Hello Daniel, I’ve been following your developments for many weeks and I’m already looking forward to a release. You are really busy.
What bothers me about the current integration is that I can’t control devices with “Servicemeldungen” messages" (Plz see Fixing Homematic Servicemeldungen?)

Is that solved differently with your integration?

Your opinion is important for me.

Danke. :grinning_face_with_smiling_eyes:

I don’t encounter that problem that often, so I can’t give a reliable answer to your question. I suggest to just give the new integration a try. It’s possible to have it running in parallel. Here are the instructions for installation.

Thank you, I just did it and installed your integration. I am now waiting for the next HM error message.

Unfortunately, I was able to test it directly when all my blinds went down.
The behavior is identical. The entities are grayed out.

When I start the device in RaspberryMatic, the messages always disappear. For this reason, I hoped that the devices could simply be triggered again through HA.

I’ve used BidCos-Homematic in FHEM for years and haven’t had any problems. There I used different HM-MOD-UART.

Now I am using just real eq3-Gateways:

  • Flashed CCU2GW0001 so that i can use it like a HomeMatic RF-LAN Gateway.
  • Real HomeMatic RF-LAN Gateway

Just as a side note: I already have a delay between all commands to avoid radio collisions.

Sorry for offtopic.

But how should a integration switch a device, which is not switchable in CCU because of whatever reasons. I have this as well, with my shutters, one here one there sometimes, but then it is not switchable in CCU either.

Then open an issue in New integration. Perhaps there is a chance of improvements or root cause analysis.

Hi @danielperna84,
great to see that the new add-on has reached a stable v1 and is now going to be migrated to Home Assistant, at some point.
Do you have an idea at this point how this is going to interact with the existing inbuilt HomeMatic integration?
At this moment I am still running my TRVs with the old integration, although I have your new one installed, but disabled right now.
Would you recommend to leave everything as it is or install your new one and then move all the entities from the “old” one to your new one?

Or will this switch happen at some point when the new one gets fully integrated?

Thanks for the great work!

Cheers,

Merc

There actually has been some debate on how this should be handled. The process I initially thought of seems not to be practical / acceptable from the perspective of other users. So right now I literally have no idea on what to recommend. You can follow the discussion here: Planung für Integration im HA Core · Discussion #381 · danielperna84/hahomematic · GitHub

Thanks Daniel,
I had a look and I see that this might be turning into quite a big issue for some people. Luckily I am not that far down the route with my TRVs and reconfiguring them and some templates will be pretty straight forward.

I have one additional comment and observation.

After installing your new HACS addon again (and previously deleting everything in the custom folder) I managed to install the integration and connect it to RaspberryMatic. However it did not show any entities so I thought that I had done something wrong again. I checked my configuration.yaml, all the firewall settings, everything I could think of that might have an impact and could not find any mistakes. So I decided to just let it sit since everything is still working with the core-based HomeMatic integration. After maybe 5 to 10 minutes suddenly the entities appeared with their clear names. Maybe it would be good to mention somewhere that this can take some considerable time, or is there a method to trigger this a bit quicker. It can be pretty misleading I found.

And one more question: I think, when I had used the climate cards in Lovelace before, based on the HAHM addon, I could see 3 buttons for the presets. In the old HM integration they are not visible and it seems that in the new HMIP integration they are not there either. Is this correct?

Thanks again and regards,
Merc