New Roborock S5 Max Vacuum Cleaner

Hey guys,

Is it possible to add the new S5 Max to HomeAssistant? This is the newest vacuum cleaner from Xiaomi.
I tried a lot, but somehow im just not able to retrieve the token of this thing…

Would appreciate any help.


For those who still need this. I was able to add the Cleaner via the Xiaomi Mi Robot Vacuum Implementaion:

I used this guide to retrieve the token:


Thank you for the guide how to get the token - I obtained 32 digits and added code in HA (S5max has static IP adress) and… it still doesn’t see vacuum - I have the entity but Roborock says it’s inaccessible.
In MiHome it works but can’t integrate it to HA - have you done something more to run it?

1 Like

I did nothing else… can you show me your configuration.yaml? What did you write ?

Sure - here is my code in configuration.yaml:

  - platform: xiaomi_miio

Tried to write token with different types of quotes: ’ , " and without nothing but the result is always the same.

Here’s how look the entity:

I updated the vacuum to the newest, orignal firmware from Roborock app.

Here is also my logs:

Strange thing - I double checked the token and it changed from the last time . I edited it again and viola!
It works in HA :slight_smile: Thank you for all help and info :slight_smile:

Merry Christmas :slight_smile:

It changes everytime when you change the app. But since it’s working now, it doesn’t matter.

Merry Christmas!

Test if the S5 Max could work with this software:

It can, why?

If so, there is a problem with the HA vacuum implementation, rather than being a different and unknown device.

Open an issue on Github reporting this.

Hi, I’ve received today a s5 max and I am reading how to integrate it into the home assistant. Could you explain that to me? Token change? when? If I change or update the application?
Can I use roborock app and home assistant simultaneously?

Thanks in advance

Yes you can, but you can’t use the roborock app and the Mi-Home App. I use the Mi-Home App, since I was able to get the token from there. A few post earlier I have written how I did this.

Thanks, yes, i’m using mi home app too. I’ve try to get coordinates from flolevac app but the map that this app gets is bugged. Only show a mess of lines…

Then I saw the posibility to send to clean directly to room number. I’ts ok but using this metod I think that is not posibble to specify number of repeats.

There are any other way to get coordinates?

I really don’t know. You mean for the Vacuum Map implementation, right ? I also struggle with getting good coordinates for this … that’s why I still don’t use it.

BTW: How did you add your S5 Max do Flolevac? I am on the German server, and always getting the error “No roboters found”, doesn’t mater wich server I choose in flolevac…

Edit: I was able to add it with the manual configuration, but no satisfying results :smiley:

Yes, manual configuration allows to control, but to get data from server you need to put your login data. anyway… the map obtained is unusable.

Ok so no other way to get zones in s5 max so far?

I’m observing a bug with vacuum.return_to_base service and s5max. When I call this service, s5max pause cleaning but don’t return to base. When it’s paused and call service again, s5max return correctly. Other bots return with first call.

It’s normal? or it’s a bug?

I have no problems with is… Its returning home without problems.

i had a roborock s50 and it is easy to see the token from the mi home app.
now i bought the roborock s5 max, but i can’t find the token. does anyone know where i can find the token to integrate the roborock s5 max on home assistant?

Read my 2nd post of this thread.