NEW Wunderground API for "Personal Weather Stations"

Hey all,

it would be fantastic if the Wunderground Sensors get updated to the new API:

Here the link from the Wunderground Forum for the new API:

Best regards

What would this offer over something like dark sky or yr.no?

Most of the personal weather stations are using WU for uploading the data and it would be great to get the data from WU into HomeAssistant for other automations (water sprinkler, …)

Thanks that makes sense, I guess you can get more accuracy if you have a home run weather station nearby or own one yourself.

yep this is why I would love this back… I get more accurate data from my own weather station

I have an own weather station… this is uploading my data to Wundeground and Metoffice… but the API from Metoffice is not allowing to download the data, so the home assistant met office sensor is not working … So the alternative is Wunderground, but its necessary or would be fantastic that the Wunderground Sensor gets updated to the new api.

Found thru Reddit: Home-Assistant-wundergroundpws

1 Like

Thats it! :slight_smile: Thank you very much… I tried it, but there was an error with the custom component… I opened a issue at Github… But thanks for the link :slight_smile: I hope its getting in Home Assistant from out of the box!

Best regards
D

Yep is working well once I worked around the bug @e1nzelkind mentioned . A few conditions are returning “unknown” but I haven’t worked out if that is me, WU or the component. Great work for the dev getting this up and running for those that have a PWS.

The “unknown” status is normal…

I have this running to. The native weather forecast card requirement:

"This card works only with platforms that define a weather entity. "
weather.wundergroundpws

Could sensor.py be modified to conform to this requirement?

Any update on if this is still working? Just got an Ambient weather station set up and can’t get my config to validate with 0.94.3

I’m on 93.2 and it’s still working for me.

I did change the value of MIN_TIME_BETWEEN_UPDATES, in the sensor.py file, from 5 minutes to 15 minutes. My weather station only updates Weather Underground every 15 minutes and at the end of the day HA didn’t seem to get updated. I think updating every 5 minutes may end up going over the threshold by the end of the day.

Hey there,

Late to the party. Im installing on 98.1 (rpi). Im placing the wundergroundpws custom component into config\custom_components\wundergroundpws and the www folder into config\www (also tried config\custom_components\www). However as soon as I check config the circle just spins forever. Below is the sensor.yaml entry im using:

- platform: wundergroundpws
  api_key: xxx
  pws_id: yyy
  monitored_conditions:
  - stationID

Any ideas?

Here’s mine:

- platform: wundergroundpws
  api_key: !secret wu_key
  pws_id: !secret wu_pws
  latitude: 32.296755
  longitude: -106.602996
  monitored_conditions:
    - humidity
    - temp
    - dewpt
    - heatIndex
    - windChill
    - precipRate
    - precipTotal
    - pressure
    - windGust
    - windSpeed
    - weather_1d
    - weather_1n
    - weather_2d
    - weather_2n
    - weather_3d
    - weather_3n
    - weather_4d
    - weather_4n
    - weather_5d
    - weather_5n
    - temp_high_1d
    - temp_low_1d
    - wind_1d
    - precip_1d
    - precip_chance_1d
    - winddir
    - neighborhood
    - obsTimeLocal
    - stationID
    - elev
    - today_summary

Been working without error. At HA 98.0 now.

Cheers,

I might just bite the bullet and restart without checking config. If you never hear from me again you know why! :wink:

Nope, wont even restart with that config.
Error executing service <ServiceCall homeassistant.restart (c:d3f4022763e64e5583b63f1611fdcf9f)>
And the culprit is this:

File "/config/custom_components/wundergroundpws/sensor.py", line 45, in <module>
    load_config = config.load_yaml_config_file(conf_file)

which is;

44: conf_file = config.get_default_config_dir() + '/configuration.yaml'
45: load_config = config.load_yaml_config_file(conf_file)

Obviously I have a configuration file!

Are you running on rpi? Most of the documentation references a “.homeassistant” directory which doesnt exist on rpi so Im thinking this could be the reason. Also, I have a split config so my sensor config is in sensor.yaml (im sure this is fine though)

Any help appreciated.

Found it! An error was reported on githib. It seems the “get default config file location” command isnt that great.
https://github.com/cytech/Home-Assistant-wundergroundpws/issues/1

This is what I have for a Hass.io install on a NUC:

conf_file = config.get_default_config_dir() + '/configuration.yaml'
load_config = config.load_yaml_config_file('/config/configuration.yaml')

Thanks for posting this. My Hass.io is installed in Docker on a NUC and my configuration.yaml is located in /usr/share/hassio/homeassistant, and I tried entering that as the path in load_config, but HA wouldn’t load. Using your configuration /config/configuration.yaml worked perfectly for me.