New Z-Wave device not updating to frontend

I just added a new z wave water sensor device.

I paired it successfully, It shows up in the entity_registry, It shows up with all of the entities in the states page.

it shows up in the ozw config xml file.

i added the entities to the front end to display values but none of the values change when the water sensor is activated/deactivated.

pulling the OZW log shows that it is being seen by the controller correctly and it says it is sending the event notification.

there seems to be a disconnect between the OZW system and the events in HA that aren’t getting updated correctly. But it’s only for this new device, all of the other existing stuff works perfectly.

the new device is an Aeotec DSB45 water sensor connected using an Aeotec gen 5 Z-stick.

I have renamed the node in the OZW UI in HA, updated the entity_registry with the same values (just in case).

Everything seems to be working the way it is supposed to but I’m just not seeing the values update in HA

OZW Log:

2018-05-06 11:49:36.267 Detail, Node020,   Received: 0x01, 0x09, 0x00, 0x04, 0x00, 0x14, 0x03, 0x20, 0x01, 0xff, 0x3b
2018-05-06 11:49:36.267 Detail, 
2018-05-06 11:49:36.267 Info, Node020, Received Basic set from node 20: level=255.  Sending event notification.
2018-05-06 11:49:36.268 Detail, Node020, Notification: NodeEvent
2018-05-06 11:49:36.516 Detail, Node020,   Received: 0x01, 0x09, 0x00, 0x04, 0x00, 0x14, 0x03, 0x20, 0x01, 0x00, 0xc4
2018-05-06 11:49:37.044 Detail, 
2018-05-06 11:49:37.044 Info, Node020, Received Basic set from node 20: level=0.  Sending event notification.
2018-05-06 11:49:37.044 Detail, Node020, Notification: NodeEvent

from entity_registry:

  platform: zwave
  unique_id: 20-72057594378452992
  platform: zwave
  unique_id: 20-72057594379517953
  platform: zwave
  unique_id: 20-72057594379517969
  platform: zwave
  unique_id: 20-72057594379517985
  platform: zwave
  unique_id: 20-72057594379518081

from groups.yaml:

  view: yes
  name: Main
    - binary_sensor.water_sensor_main_basement_sensor
    - sensor.water_sensor_main_basement_alarm_type
    - sensor.water_sensor_main_basement_alarm_level
    - sensor.water_sensor_main_basement_sourcenodeid
    - sensor.water_sensor_main_basement_flood

the display always stays like this:


and never changes either here or in the states page.

i’ve restarted and rebooted and it’s still the same.

any ideas?

  1. Does the second half after the dash on the unique_id’s in the entity_registry match the sensor’s value_id?
  2. Have you looked into reporting type? Sometimes this needs to be adjusted depending on the device (for proper updates to hass).

1 yes they are identical
2. the report type is 256. according to the help text it is the default value and is the “basic set”. FWIW, this is the same value of report type as my two zwave motion sensors which worked correctly out of the box. I tried to change it to 4113 (0x1011) as the “OZW recommended” but even after waking it up it won’t take the changed value.

In basic, does binary_sensor.water_sensor_main_basement_sensor update? That’s the only one I would expect to update. The flood sensor may change in value too. And this may be a stupid question but, are you using water to trip the sensor?

yes…dipping it in water. :roll_eyes: :smile:

i would assume that the binary sensor should change but in my experience with the motion sensors only the alarm_level ever changes and i use templates to convert that signal to binary. i would expect this sensor to act the same.

in this case tho nothing changes at all. i can see it in the ozw log but the sensors never change. and i can’t get the config changes to take effect from HA.

And now to top it off for some reason all of the entities of the node are completely gone from OZW UI and states except the binary_sensor (which still doesn’t update). I have no idea what happened there. If I exclude the node and re-pair it they will come back for a little while but then they disappear again. no amount of restarting or rebooting makes them reappear until i re-add the node.

Hey finity,

I have the exact same issue, and I mean exactly: I’m using the same sensor, and other nodes/sensors work just fine.

This is my 5th attempt at adding and getting this water sensor on the network ( I actually has this working in another installation before I started over).

When I toggle the node, I get the following in OZW_Log.txt:

2018-08-27 20:20:45.130 Detail, Node021,   Received: 0x01, 0x09, 0x00, 0x04, 0x00, 0x15, 0x03, 0x20, 0x01, 
0xff, 0x3a
2018-08-27 20:20:45.130 Info, Node021, Received Basic set from node 21: level=255.  Sending event 
2018-08-27 20:20:45.130 Detail, Node021, Notification: NodeEvent

2018-08-27 20:20:45.829 Detail, Node021,   Received: 0x01, 0x09, 0x00, 0x04, 0x00, 0x15, 0x03, 0x20, 0x01, 
0x00, 0xc5
2018-08-27 20:20:45.829 Info, Node021, Received Basic set from node 21: level=0.  Sending event 
2018-08-27 20:20:45.830 Detail, Node021, Notification: NodeEvent

After a 36 hours of it being in the network, zwave.aeotec_dsb45_water_sensor_5 still shows as ‘initializing’. I ‘woke’ it a few times, but the zwave Management in HA ‘Node Info / Show’ doesn’t update.

Other things I have tried:

  • Deleting node entry in zwcfg_0xdd8a5d18.xml and rebooting
  • Deleting entire zwcfg_0xdd8a5d18.xml and letting HA rebulid
  • Removing and adding node in HA and Zentool Controller App

Did you ever or anyone else get this resolved? If so, please share your solution or suggestions. Again, the node change is reflected in log, but not in front end (e.g. Dev Tools / States / binary_sensor.aeotec_dsb45_water_sensor_sensor_5

Greatly Appreciated!

It doesn’t make any sense relative to the instructions but I finally got it figured out…

You need to set everything up ready to change the node info that you want to change. Then push the zwave button (the instructions say to push the wake button but that doesn’t work) then IMMEDIATELY click the save button on the z wave control panel. If your timing is right the node should be updated correctly. If it doesn’t take then just try a few more times. the timing pretty much has to be perfect.

Then finally to get it to send the proper signal on sensing water you need to change the “report type to send” to ‘4113’. Just do it the same way as above.

as far as the ‘initializing’ state that’s normal for battery powered devices.

gotta love zwave devices

1 Like

Thank you for the tip and speedy reply. I will give that a shot are report back.

I guess I need to install z wave control panel; I’ve been using the HA Z Wave Management or Zensys-Tool Zwave Controller until now. I hear you on the ‘initializing’ state for battery operated sensors. I just found it odd that 7 of my 8 working battery sensors are in ‘ready’ or a ‘sleeping’ state, and I was hoping the ‘initializing’ was a clue to an issue.

Again, I will try your suggestion with OWCP and report back today

@petro - Well, I did until this issue popped up. :slight_smile:

EDIT: see my next post. Looks like I misinterpreted the control panel used … geesh!

Well, after installing and trying OZWCP, I just realized I was using the right Control Panel, all along… geesh! I was using this: and thought, when I read “click the save button on the z wave control panel”, you were using OZWCP (e.g. New Add-on: Open ZWave Control Panel (OZWCP)) - MY MISTAKE.

So, I tried hitting the zwave button and various timings of clicking ‘Save Config’ in the Z-Wave Network Management section. No luck, so far. But, I will keep trying.

Yeah sorry about that I forget that OZWCP used to be a thing until they integrated it.

The bad part is that with the newest version they are starting to eliminate some of the functionality from that section that I use regularly on installing any new z wave devices. :frowning_face::angry:

Maybe if enough of us complain they’ll put it back in.

Or I’ll have to figure out a way to install OZWCP again that works with HA.

Sorry that it’s not working for you. I think you have just a few seconds from hitting the zwave button to clicking to save the config. I must have gotten really lucky. Both of mine took after the first or second try.


IT WORKED! Thank you.I’m not sure I would have thought of using the zwave button and ‘save config’ to fix this. The main reason for not considering it, was the other sensors worked — even this one in the past — without those extra steps.

Anyway, I followed your directions, and added the following to the process:

  • Executed 'tail -f OZW_Log.txt’
  • Pressed the sensor’s ‘zwave’ button
  • Waited for the node to finish updating in log
  • Then pressed ‘Save Config’ in Z-Wave Network Management

After a long list of Node022 updates in log, I got the following (tailed snip), which gave me hope:

2018-08-28 10:14:47.301 Info, Node022, Response RTT 4212 Average Response RTT 3645
2018-08-28 10:14:47.301 Info, Node022, Received Wakeup Interval report from node 22: Interval=0, Target Node=1
2018-08-28 10:14:47.301 Detail, Node022, Refreshed Value: old value=0, new value=0, type=int
2018-08-28 10:14:47.301 Detail, Node022, Changes to this value are not verified
2018-08-28 10:14:47.301 Detail, Node022, Notification: ValueChanged
2018-08-28 10:14:47.359 Detail, Node022,   Received: 0x01, 0x07, 0x00, 0x13, 0x8f, 0x01, 0x01, 0x9b, 0xff
2018-08-28 10:14:47.360 Detail, Node022,   ZW_SEND_DATA Request with callback ID 0x8f received (expected 0x8f)
2018-08-28 10:14:47.360 Info, Node022, WARNING: ZW_SEND_DATA failed. No ACK received - device may be asleep.
2018-08-28 10:14:47.374 Info, Node022,   Node 22 has been marked as asleep
2018-08-28 10:14:47.374 Info, Node022, Node not responding - moving message to Wake-Up queue: WakeUpCmd_IntervalGet (Node=22): 0x01, 0x09, 0x00, 0x13, 0x16, 0x02, 0x84, 0x05, 0x25, 0x8f, 0xda
2018-08-28 10:14:47.374 Info, Node022, Node not responding - moving QueryStageComplete command to Wake-Up queue
2018-08-28 10:14:47.375 Detail, Node022, Notification: Notification - Node Asleep
2018-08-28 10:14:47.424 Detail, Node022,   Received: 0x01, 0x0c, 0x00, 0x04, 0x00, 0x16, 0x06, 0x84, 0x06, 0x00, 0x00, 0x00, 0x01, 0x64
2018-08-28 10:14:47.424 Detail,
2018-08-28 10:14:47.424 Info, Node022, Received Wakeup Interval report from node 22: Interval=0, Target Node=1
2018-08-28 10:14:47.425 Detail, Node022, Refreshed Value: old value=0, new value=0, type=int
2018-08-28 10:14:47.425 Detail, Node022, Changes to this value are not verified
2018-08-28 10:14:47.425 Detail, Node022, Notification: ValueChanged

After the above stopped for 2 secs, I pressed ‘Save Config’ and got below:

2018-08-28 10:14:50.898 Info, mgr, Manager::WriteConfig completed for driver with home ID of 0xdd8a5d18

This was very promising and confirmed in the right direction when I saw entries, under Node 22 in my zwcfg_0xdd8a5d18.xml file.

I didn’t have to change the ‘Report Type to Send’ under Node config options; it seems the default worked.

Readers may notice the sensor is now Node 22 and not 21 from my previous post. I did start from beginning before attempting these steps. I wanted to avoid other variables. I also removed old entries in entity_registry.yaml to clean-up the incremental sensor name after each re-add.

The binary and alarm_levels now change immediately. I am very grateful for your assistance and I hope this thread continues to help, or better, soon becomes unnecessary :smiley:

I’m having the same issue and this didn’t work for me. The UI has changed a bit too. I’m having trouble with a basic motion sensor. z-wave log shows the burgler sensor turns to 8 but it doesn’t update the entity.

It depends on the device.

Sometimes the only thing that changes is the “burglar”. Sometimes it’s the “alarm_level”.

I don’t have your device but you might try to figure out if it’s possible to send a binary report. If not then you can create a binary sensor from the “burglar” entity changing state.

I actually got it to update the burglar sensor, but it’s not updating the binary sensor I created. I triple checked my code. Any thoughts on why this would be?

            value_template: "{{ is_state('sensor.sensor.vision_security_zp3102_pir_motion_sensor_burglar', '8') }}"
            friendly_name: "motion_lr_nw_zp3102"
            device_class: motion
            entity_id: sensor.vision_security_zp3102_pir_motion_sensor_burglar

Your template is wrong.

Your is_state has sensor.sensor.vision_security_zp3102_pir_motion_sensor_burglar change it to sensor.vision_security_zp3102_pir_motion_sensor_burglar but a binary_sensor should have been created for this device already. :man_shrugging:

I’m pretty sure I screwed that up trying to find a solution and copying and pasting over it too many times. If that was the issue, I might give up on life today.

edit: that was the issue. Thanks

I’ve done it once or twice myself lol no worries

1 Like

When you say that a binary_sensor should have already been created for this device, do you mean that there shouldn’t be a need to create a new binary sensor for tracking the motion? I have this exact device and can see a binary_sensor associated with it, but it only ever shows as “off” or “unavailable”.

You have to adjust the binary reporting or something to that effect, it’s a config option.