No entities for Zemismart Tubular roller blind Zigbee 3.0 - M2805EGBZTN

Hi there,
I’ve bought two of these:

They have RF as well as Zigbee.
When I add it with ZHA integration it finds and configures it within a few seconds. Once added however, there are no entities.

This is the device signature:

{
  "node_descriptor": "NodeDescriptor(byte1=2, byte2=64, mac_capability_flags=128, manufacturer_code=4098, maximum_buffer_size=82, maximum_incoming_transfer_size=82, server_mask=11264, maximum_outgoing_transfer_size=82, descriptor_capability_field=0, *allocate_address=True, *complex_descriptor_available=False, *is_alternate_pan_coordinator=False, *is_coordinator=False, *is_end_device=True, *is_full_function_device=False, *is_mains_powered=False, *is_receiver_on_when_idle=False, *is_router=False, *is_security_capable=False, *is_valid=True, *logical_type=<LogicalType.EndDevice: 2>, *user_descriptor_available=False)",
  "endpoints": {
    "1": {
      "profile_id": 260,
      "device_type": "0x0051",
      "in_clusters": [
        "0x0000",
        "0x0004",
        "0x0005",
        "0xef00"
      ],
      "out_clusters": [
        "0x000a",
        "0x0019"
      ]
    }
  },
  "manufacturer": "_TZE200_5sbebbzs",
  "model": "TS0601",
  "class": "zigpy.device.Device"
}

I read on a similar post: (Issues with Zemismart Chain Roller Shades Driver M515EGBZTN) a person with similar issue. It is however for a curtain motor, and not tubular motor used in roller blinds.

I have tried in configuration.yaml to specify the type of this device as “cover”, but it did not work.

Does anyone have an idea how this could be done?

Read https://www.home-assistant.io/integrations/zha/#zha-exception-and-deviation-handling

Summery; You need to write or fix a quirk for https://github.com/zigpy/zha-device-handlers

You can probably use this as a base https://github.com/zigpy/zha-device-handlers/issues/744 and/or https://github.com/zigpy/zha-device-handlers/pull/801

Quirk developers should also be aware of https://github.com/home-assistant/core/pull/49143

Raise an issue here, someone might add it for you to the exsiting Tuya quirk

Okay, thanks for the help all!

I’ll raise an issue as suggested by @Holdestmade. I am unfortunately not a developer myself.

Issue created:

I have recently bought 7 zm35e tube motors, and while they work, I couldn’t get it to connect to ZigBee2mqtt. The instructions say single button press to pair to tuya app, but since I’m using ZigBee2mqtt with conbee 2 I wonder if there is a different sequence of button presses that allow pairing mode. Any help would be appreciated, thanks in advance!

Hi Igor, for my motors, I had to hold in the pairing button for around 5 seconds. It would the beep, and I could pair it with home assistant using ZHA

does any one know how to invert the motor ? not seeing the options

@bam27beer yes, you can do it in the official app if you have a tuya bridge, or you can use the remote. (I’ve attached screenshot of the instructions)

Also I have now connected these rollerblinds directly to home assistant using conbee, and it works perfectly :slight_smile:


1 Like

cheers just what i’m looking for ,quite hard to find info on the remote other then pairing !
had them on the tuya app , but h/a in local and v2 integration couldn’t get them showing ,
so thought i’d go direct and now at least have them in scenes
only just seen that using the c key operates a set at once ! ,
i’ve got a slightly different remote with a lcd ,would like to turn a single channel in a 3 channel

Okay, my remote is 5 channel.

Before I had all my curtains on the tuya gateway and then with tuya integration to home assistant. I could then control them with scenes.

But recently these roller blinds have now gotten support directly in HA. So I’ve deleted my tuya integration, and repaired all the rollerblinds directly to HA using my Conbee 2 USB. It works great, and I’m very happy all my stuff no speaks directly with HA, so I don’t need ANY hubs / gateways except the Conbee USB.

hi! how did you managed to pair de physical remote with the motor without the official Tuya app??? I here have home assistant only. don’t have the Tuya hub.

I’ve been puzzling over this, the manufacturer’s documentation is obviously fairly limited, but some reading around combined with the supplied manual means the process to get it working fully is as follows:

  • Press Motor Set button (on the motor cap) 5x times to factory reset
  • Put ZHA in pairing mode and press it again 3x times to pair. The buttons in HA then work to move it up and down, however the position is not calibrated so it will show an incorrect value.

We need to use the 433Mhz remote to calibrate it: (if you about to buy one then it’s very important to get a remote even if you plan to automate it!)

  • To pair the remote, press the Motor Set 1x and then hold the up button and the motor should move a little bit. The remote can now be used to move it up and down manually.

To set the limits:

  • Move the blind to the position you want the limit, using the up/down/stop buttons.
  • Press the Set button on rear of remote 1x and then either the up, down or stop buttons to set the top bottom or middle limits as appropriate. The blind will move slightly to confirm.
  • I’m pretty sure that you need to set a top and bottom before a middle position. I don’t know if a “middle” position is important at all, but there’s no harm in setting it.

To delete a limit (eg. if you want to move it up or down a bit):

  • Press the set button (on rear of remote) 3x times and press either the up, down or stop buttons to delete the top bottom or middle limits as appropriate. As the instructions say, the middle limit is deleted if either the top or bottom limits are deleted.

After setting the limits, the current_position attribute shows correctly in in HA!

These are incredible devices for the money, I’m very impressed. I have a 2.5x2.5m lightweight blind and it moves it pretty well, although I don’t think it could cope with anything too much larger. The only negative point is that the power cable is only 1.5m, and when removing the end cover the cable disappears inside so it’s not going to be easy to replace, so using a junction box is the only real solution.

edit: The exact device I have is this one and it shows as " _TZE200_fzo2pocs TS0601" in ZHA,

6 Likes

Thanks!!!

Hi Everyone.
I have a similar issue here, slightly different blind from the same vendor but the same device signature.

In my case I am pairing an RF bridge to a blind motor rather than directly to the blind motor. The pairing works but I have no up/down/stop control (which I need to pair the RF part of the bridge to the blind motor).

My question for anyone who has this motor running is what entities do you get for the motor? Do you get an up/down/stop button?

I can say having it connected with zigbee directly to my conbee 2 stick, Home Assistant recognise it as a curtain, and I get entites up/down/stop. I can also set a position. I have my home assistant linked with Google Home, so if I ask Googel to set the curtain to 30%, it will. If I then says 40%, it extends 10%. So it knows the position of the curtain.

Did you previously set up the endstops? I’m curious how it knows where it is position-wise.

is it 433mhz?? would help if I read the controller commands using an Arduino?

Thanks but I am ok on the RF front.
I have captured the RF on a Broadlink and got that to work, but these dongles are a much cheaper alternative when you have many shades around the house. All the RF is very short range and does not travel through thick brick walls.

I have to discover the right zigbee command to the dongle to make it pair to the remote.
And I have to look at other ZHA implementations and see there is a config mechanism, the user needs a way to specify HA to send repeat RF signals for better reliability. On the Broadlink I send 4 times.

Yes, just using the RF remote I set the end stops and motor direction.
I don’t think intermediate points will work that well though, see my post below about needing to resent the RF signal to get good reliable open/close operation. I find this on these RF remotes, dongles and the broadlink.