None devices in the xiaomi cloud account

I have a problem with HA because today when I wake up all of xiaomi devices is unavailable in HA. All entities are gray.
When I look on integration with xiaomi and try recoonect with my account i have message “None devices in the xiaomi cloud account” but when I look on phone in xiaomi app all my devices are working.

Any suggest what happened and what I can do?



Same problem here (Spain). I’ve executed many times the token extractor script with no success (no cloud devices). I can send basic commands calling services to Roborock vacuum (clean zone, return to base, etc.), but there is no floorplan in Lovelace card (calibration error).

Hope this is a temporary problem.


I hope that is temporary problem.
I read that Xiaomi made update his application and many users have problem but with aplication.
My app Xiaomi Home on phone work good.
Only problem is with HA synchronization.

But thanks to You I know that is not only problem with my HA. I worried that I broke something in config although I haven’t changed anything in it recently.

But as this is a global problem, somehow few people write about it.

Does anyone else have this problem or is it just us?

1 Like

Just registered to say I have the same problem - my HUB integration stopped working, so i wanted to add it again, but it says “Uknown error occured”… so i tried to add it manually, but HA says “The Xiaomi Miio integration needs to re-authenticate your account in order to update the tokens or add missing cloud credentials.” - but when I do it fails again :frowning:

Me too! (Spain)

Hello. I also from Spain. I have my devices configured in CN (gateway and roborock vacuum). Working without problems and that I have had to connect the vacuum cleaner several times, since I changed the wifi today. The vacuum cleaner’s map extractor also works correctly. I have the latest version of HA and have configured the integrations in the UI (it is no longer recommended to use the yaml for this integration)

Do you use this? GitHub - PiotrMachowski/Xiaomi-cloud-tokens-extractor: This tool/script retrieves tokens for all devices connected to Xiaomi cloud and encryption keys for BLE devices.

I have problem with all xiaomi device in HA.
In integration xiaomi card I see 31 entities and 12 devices but all of this is unavalible. When I try recconect my xiaomi account I have message " None devices in the xiaomi cloud account". I use EU (Poland) xiaomi server. But in xiaomi app on phone everything is ok and work fine

same here, Xiaomi Miot Auto integration is broken now. :frowning:
EU server, Hungary.
“None devices in the xiaomi cloud account”

Hope it will be fixed soon. :crossed_fingers:

I think that it is problem only with EU cloud. I have one device on CN ,and when I change cloud to CN I had no problem to connect and I seen my one device.
But when I back to EU I had message “None devices in the xiaomi cloud account”.

I’m just wondering if it’s not the HA integration that’s to blame because the XiaomiHome app on my phone works fine and I can see my devices that are on the Eu server. The problem is only in HA

Here too (italy)

Here the same all in Greece. EU Servers

There are multiple issues about this on Github. It seems Xiaomi changed the authentication process for the EU server. I think we will have to wait for an update of the component.

1 Like

Tbh I remember that few days ago (maybe 2) the app showed me the “accept” button like a new installation… I don’t have pay attention to it.

I hope that it will be quickle resolve. Now my HA is useless :expressionless:

I installed HA few days ago xiaomi integration worked and then xiaomi stopped working and I thought that I had messed something. Glad to see that it’s global but… I still have domoticz running in parallel and slowly migrating everything to HA. For domoticz I’m using self made python scripts that uses miio module and they are still working with EU devices. (Air Purifier, Humidifier, Space Heater S…)

Same problem here, on EU (DE) server. When logging into Mi Cloud, it says no devices but the iOS app (Xiaomi / Mi Home) works fine with my Roborock Vacuum Cleaner. Installed HA yesterday, so can’t say how long this has lasted though.

Yesterday the token extractor for Xiaomi device was falling also to detect Mi Devices from Cloud. Today it is fixed so, fingers crossed, the issue on home assistant will be also solved soon I guess.

I hope that there will be magicians who will quickly fix this. I keep my fingers crossed for them.
For now there was an update to the extractor map vacuum cleaner and now Ican already see the map

Same thing here (Poland). Hope we can get a fix for this soon.

Same problem here (Netherland) hope there will be a solution soon