Nortek HUSBZB-1 Not being found at tty/USB0 and tty/USB1 . USB getting detected

Have the SmartThings integrated with HA 0.84.5 installed via HassIO, the available sensors are work using the SmartThings Bridge and MQTT Bridge.

Now trying to use Nortek HUSBZB-1 to control Zigbee and Zwave devices directly from HA.

When I plugged in the USB in a running instance of HA, I got the following messages, which apparently show the USB is detected correctly and TTY0 (Zwave) and TTY1(Zigbee) could be used.

Afterwards I tried updating the configruation.yaml as follows (which was incorrect), as it is for HA, not HassIO.

    usb_path: /dev/zwave

    usb_path: /dev/zigbee
    database_path: /home/homeassistant/.homeassistant/zigbee.db

When I restarted I got the error messages in logs , basically telling that zwave and zigbee devices dont exist.

So I unplugged and followed the correct procedure/guide to fix the error in confihguration as follows

 usb_path: /dev/ttyUSB0

 usb_path: /dev/ttyUSB1
 database_path: /config/zigbee.db

After the correction when I am restarting HA, I am still getting the following error messages in the log

2018-12-21 13:29:22 WARNING (Recorder) [homeassistant.components.recorder] Ended unfinished session (id=49 from 2018-12-21 10:25:15.834868)
2018-12-21 13:29:27 ERROR (MainThread) [homeassistant.config_entries] Error setting up entry Z-Wave (import from configuration.yaml) for zwave
Traceback (most recent call last):
  File "/usr/local/lib/python3.6/site-packages/openzwave/", line 78, in __init__
    raise ZWaveException(u"Can't find device %s : %s" % (device, traceback.format_exception(*sys.exc_info())))
openzwave.object.ZWaveException: "Zwave Generic Exception : Can't find device /dev/zwave : ['NoneType: None\\n']"

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/usr/local/lib/python3.6/site-packages/homeassistant/", line 249, in async_setup
    result = await component.async_setup_entry(hass, self)
  File "/usr/local/lib/python3.6/site-packages/homeassistant/components/zwave/", line 283, in async_setup_entry
  File "/usr/local/lib/python3.6/site-packages/openzwave/", line 81, in __init__
    raise ZWaveException(u"Error when retrieving device %s : %s" % (device, traceback.format_exception(*sys.exc_info())))
openzwave.object.ZWaveException: 'Zwave Generic Exception : Error when retrieving device /dev/zwave : [\'Traceback (most recent call last):\\n\', \'  File "/usr/local/lib/python3.6/site-packages/openzwave/", line 78, in __init__\\n    raise ZWaveException(u"Can\\\'t find device %s : %s" % (device, traceback.format_exception(*sys.exc_info())))\\n\', \'openzwave.object.ZWaveException: "Zwave Generic Exception : Can\\\'t find device /dev/zwave : [\\\'NoneType: None\\\\\\\\n\\\']"\\n\']'
2018-12-21 13:29:27 WARNING (MainThread) [homeassistant.loader] You are using a custom component for which has not been tested by Home Assistant. This component might cause stability problems, be sure to disable it if you do experience issues with Home Assistant.
2018-12-21 13:29:28 ERROR (MainThread) [homeassistant.config_entries] Error setting up entry /dev/zigbee for zha
Traceback (most recent call last):
  File "/usr/local/lib/python3.6/site-packages/serial/", line 244, in open
    self.fd =, os.O_RDWR | os.O_NOCTTY | os.O_NONBLOCK)
FileNotFoundError: [Errno 2] No such file or directory: '/dev/zigbee'

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/usr/local/lib/python3.6/site-packages/homeassistant/", line 249, in async_setup
    result = await component.async_setup_entry(hass, self)
  File "/usr/local/lib/python3.6/site-packages/homeassistant/components/zha/", line 126, in async_setup_entry
    await radio.connect(usb_path, baudrate)
  File "/usr/local/lib/python3.6/site-packages/bellows/", line 29, in connect
    self._gw = await uart.connect(device, baudrate, self)
  File "/usr/local/lib/python3.6/site-packages/bellows/", line 285, in connect
  File "/usr/local/lib/python3.6/asyncio/", line 212, in coro
    res = func(*args, **kw)
  File "/usr/local/lib/python3.6/site-packages/serial_asyncio/", line 410, in create_serial_connection
    ser = serial.serial_for_url(*args, **kwargs)
  File "/usr/local/lib/python3.6/site-packages/serial/", line 88, in serial_for_url
  File "/usr/local/lib/python3.6/site-packages/serial/", line 247, in open
    raise SerialException(msg.errno, "could not open port {}: {}".format(self._port, msg))
serial.serialutil.SerialException: [Errno 2] could not open port /dev/zigbee: [Errno 2] No such file or directory: '/dev/zigbee'

I tried unplugging and restarting the HA (also be clearing the log manually) however with each restart I am getting the same log messages, even if USB is not plugged in.

I am not able to access any Zwave or Zigbee functions as it seems like the devices dont even exist in /dev/tty* as follows (screenshot with correct config and USB plugged in). Although hw info shows it is getting detected.

Kinda gave up with my limited knowledge and experience with HA. Any help and guidance would be appreciated to set up the USB stick correctly and make it work,

Have got the following Nortek HUSBZB-1, if it can help narrowing down the issue


I think the entries you put in first somehow got stuck in the core.config_entries file located in the .storage folder.

Open that file in a text editor to see what it says there. If it still says “dev/zwave” & “dev/zigbee” then stop HA, rename that file to “core.config_entries.old” and restart HA.

Make sure you still have /dev/ttyUSB0 & /dev/ttyUSB1 in you configuration before you do that. The only problem will be knowing which device is which. Is USB0 zwave or zigbee?

I think you can also just leave the config blank ( just leaving zwave: & zha: ) and HA will take care of figuring out the correct device. I’m not sure of that tho since I don’t do it that way. I have my config like you do now.

1 Like

Thanks got it solved.

Now is there any guide how to add Zwave and Zigbee devices and get them displayed as sensors.

Thanks in advance

Found my answer here . Thanks to original poster.

+1 for a Zigbee guide as thorough that the ZWave docs here.

Could you all let me know if the devices shows offline after a a few hours ? Mine would go offline after about 20 hours and a full reboot is needed .

As of now my Visonic MCT340E, contact sensor shows ok and responds to changes in states (open/close) after about 10-12 hours,


It is not reading the temperature thought, which I am following in another thread.


so, what was the solution?

As you mentioned below.

Ok, thanks.

I was confused because you quoted yourself in the post that said you got it solved but selected the solved checkmark in a different one of your posts. :confused:

Corrected now. You are the saviour. :slight_smile:

1 Like

Could someone help clarify which file needs these statements? I tried to follow the thread and still not clear if it is homeassistant/.storage/core.config_entries or homeassistant/configuration.yaml – Tried the latter without any luck using the same stick. THANK YOU

 usb_path: /dev/ttyUSB0

 usb_path: /dev/ttyUSB1
 database_path: /config/zigbee.db

Those go in configuration.yaml

You should never* need to edit the .storage files.


Thank you for confirming – I’m able to see zwave devices now. Next to try zigbees. Thx!

1 Like

Bump (an old thread) is this still working well and with z-wave?
Leaving the Hubitat perpetual beta and want to reuse my Nortek stick?
How about zigbee with the Nortek? Or would you advise I get a conbee?

I’ve been using my Nortek stick for years now without any issues on either Zigbee or Z-Wave. Granted, the stick itself really isn’t going to be an issue; The stability and strength of your meshes are going to determine success or failure.

Plus, glad to see another Hubitat person coming over! If you want to continue using your Hubitat hub, there’s a fantastic custom integration that @jason0x43 wrote that allows you to keep all your devices on the HE but use HA to control/integrate them: Custom Component: Hubitat


Thank you. The integration looks great but hubitat is not stable, at least for me. I can’t tell you the hundreds of hours wasted on that system, all to find out my hub is dying. There’s great potential there but it seems very poorly done. Maybe in a few years they’ll get it right, but I can’t waste anymore time with a system that’s clunky and unreliable, where they seem to always blame the user when bugs come up.

PS- i recognized you from the car emoji :slight_smile:

1 Like

Trust me, I know full well. Mine is sitting on a shelf somewhere collecting dust. From what I’ve heard from some of the other HE regulars that are here now, JUST using it with the Maker API and it’s radios, it does a great job as Zigbee/Z-Wave coordinator.

Once I jumped over to HA fully, I decided to just use my Nortek stick and be done with HE. Like you said, maybe they will get their act together and make the product we all wanted them to make.

I get that a lot :wink: I remember your name as well. Welcome to HA! @stephack lurks around a lot too as do many of the others that were heavily active in the HE community.

1 Like


Good to see you over here as well @Rxich. Hey, we even had a cameo from Chuck. Not sure if he’s still lurking as well. :stuck_out_tongue_winking_eye: