NUC, HassOs, and emmc: Stuck on boot


I have tried to install HassOs on my NUC. I have followed the steps from here: My steps to success for on Intel NUC

  1. Boot from Ubuntu 20.04 live USB
  2. Download HassOs 4.12 from here:
  3. Unzip HassOs image
  4. Write HassOs image to disk with gnome-disks
  5. Reboot NUC

And then the NUC gets stuck at booting, at least no more output is written to screen after 2-3 seconds. The last lines are loading USB devices and Bluetooth or something like that. It is the same issue as My steps to success for on Intel NUC

My disk is a emmc, is that not supported by HassOs? Or should I follow a different procedure?


Did you have any partitions on the emmc prior? I tried an install when I’d previously had Promox on the drive and the restore partition method gave me similar results. Try erasing the emmc with gnome first and have another go.

No prior partitions. The entire emmc was unallocated. It is a brand new NUC and emmc.

So a emmc is supposed to work?

I believe so, yes. Try putting one NTFS partition on it first and have another go. After that, just leave it for 20~30 minutes and try to access the URL.

So I updated the BIOS to the latest version, disabled Bluetooth, and had another go. This time, I created a NTFS partition before I wrote the HassOs image to the emmc. I’m pretty sure this is not necessary because after I have written the HassOs image, I can see in “disk”, that the emmc now consists of several partitions of the type ext4 and FAT32.

Anyway, the result is the same. It is stuck after 3 seconds. See screenshot. After 966 seconds, I unplug mouse and keyboard and leaves the NUC for the night. After 48000 I plug-in the keyboard to verify that the NUC is still responding. I don’t know what to do from here, any help is apprciated.

After a few more reboots, I ended up in the same situation as described here: HassOS Image not working on NUC 2TB SSD

It seems that eMMC is not supported. Installing a m2 SSD solved all problems. Had HassOS up and running in no time.

I have HA running on NUC’s eMMC - see my post