Nuki Integration for MQTT

Hello all,

I don’t know if it is known or followed in the NUKI Developer Forum, currently there is a beta phase for the Nuki Smart Lock 3 Pro in which the MQTT communication is added locally via WIFI. This means that no bridge or ESP is needed for the communication anymore. I have already tested the whole thing and it works very well.

It is expected that the beta phase will be completed shortly and the function will be integrated into the official firmware. It would be nice if this is also considered for the official Nuki integration in HomeAssistant.

If you are intereste d in testing the feature before, you can join the beta development group.

The current MQTT API specification version 1.4 can be found in the closed group:

It would be nice if some HomeAssistant developers would join the group, as the Nuki developers are very keen on easy integration.

Any news/progress on that?

Nuki launched an app/firmware update for the 3.0 Pro a few weeks ago which added MQTT support.

I’ve been using it with HA since it was released and it has been working perfectly.

The lock device/entities were added automatically by the standard MQTT integration and status updates come through immediately and HA can lock/unlock the device.

1 Like

I’ve just replaced my ailing Danalock-based Ultion with new Nuki based one. Setup was a doddle, app waaaaay better, and MQTT integration was so easy.

how did you set it up?

1 Like

I haven’t done any automation with my 3 Nuki 3 Pro’s yet, but I just configured the MQTT server on the Nuki’s and then they showed up in HomeAssistant with all kinds of sensors and switches and the Locks react to state changes. Now with 2023.8 I get some warnings about names, but they are known and need to be fixed by Nuki.

1 Like

I’ve succesfully setup @CornelisNL

Open Nuki APP → configuration → MQTT
host: home assistant IP
username: home assistant username (not the MQTT broker user)
password: home assistant user password
Enable the two button below and press save, after some minute you will find in MQTT in home assistant the Nuki device

1 Like

Do you confirm that in this way it works only when connected into internal wifi?
From external networks it doesn’t work…

If I try to put the external address( ther MQTT configuration cannot be set

Do you confirm?

My mistake… it works with internal IP address also from outside…

There’s a downtime of the Nuki cloud today, and the Nuki 3.0 Pro sadly has an aggressive reconnection policy, that reconnect’s its Wifi when it looses the connection to it’s cloud (cloud outage, internet connection fails, …).

So the “local control” isn’t really local, as the MQTT connection also drops once the Nuki isn’t connected to the cloud anymore.
This also means no control from HA in case your internet is not working.

They are aware of the problem, but don’t prioritize the problem very high, as most of their customers aren’t using MQTT or local control.

See statement here:

So there’s a feature request running to give the problem more visibility:

Fell yourself invited to create an account and vote for the feature. :slight_smile:

Hi there!

Maybe you can guide me… I followed the steps exactly, got it to work, however it seems that I am getting far fewer sensors/options than you are… any ideas???

Found a workaround solution.

See post: Nuki Smart Lock and Matter (or mqtt) - Configuration - Home Assistant Community (