[On Hold] Deprecating Home Assistant Supervised on generic Linux

I think this would be beneficial, but it needs to be stickied to the top so everyone who visits the forums sees it, even when signed in.

Perhaps one of the mods who shall remain un-tagged could help out with this? The poll already created in this thread gives an interesting take on what a larger vote count could capture.


I would make one small change to this, you may not agree

  • Home Assistant using the Home Assistant OS disk-image on an SBC
  • Home Assistant using the Home Assistant OS disk-image in a VM

Good idea as the poll is buried in the middle of this one now…
I suspected 40% for Supervised installed - but that was just raw rank speculation by me…

1 Like

That’s fair. I don’t strongly disagree with mentioning the VM variation. However, all other installation methods can also be installed in a VM. The resulting list gets exceedingly long and detracts from the mission to identify which of the documented installation methods is most popular.

Wow what a thread :slight_smile: interesting range of emotions and personalities…

Running Home Assistant for over 3 years now had no idea that this many options even existed. Was always jealous of those HassIO folks due to the seamless add-ons — while I was running Core directly installed (via PIP) in Ubuntu. The big confusion for me was not even knowing the Supervised install is available (generic Linux with HassIO components installed/controlled/ran via Docker).

Two recommendations and ideals from this nerd:

  1. Make it really clear what installation options exist
  2. Please never get rid of supervised on generic Linux.

I already love and administer my Ubuntu VM for many years. I have the ELK stack running with nice dashboards, I have my own Node-Red, MariaDB used by HA, Grafana (no password), Portainer, SmartThings MQTT Bridge, custom scripts and components and whatever else I feel like. It would be awesome if HassIO supervised continued to get the heavy attention it deserves. I don’t need every little piece to be controlled by HassIO, just ones I choose. It beats administering multiple machines for the purpose of HA.

So for the last 2-3 days, I’ve spent a few hours each day migrating to Supervised install now that I know what it is and with the ability to revert back to my local Core installation any second. I cannot believe how amazing that Supervised installation actually is and I’m fully converted. I now have HassIO and all of my config pretty much 98% intact. Had some issues with file cleanup (ring & blink videos) that I did as a shell_command but now having to use Node-RED since not everything (root level tasks) will be available from within a Docker home-assistant container. Getting the remote video dump folder mapped was pretty frustrating, broke multiple HassIO installs with my CIFS/NFS/fstab/rc.local attempts, I should probably open an enhancement for it… Now I can map the NFS folder via HA startup automation using the mount command to attach to NAS thus at least WRITE to my video dump folder just not run the shell scripts to clean it up. For that I’m now using rest_command that calls Node-RED now… pretty much the only big hiccup I had.

Supervised HassIO with Samba share and VSCode is AMAZING! I gotta drop @balloob and @frenck some cash… been using (mostly) their work for a while now, time to properly appreciate them. However, I see it’s not so easy to donate to those guys per this thread: Donations? hoping to spot different info about donations. I may sign up to Cloud too for better SmartThings integration than MQTT. Hopefully both of those guys benefit from the member fees.

Please don’t let Supervised install die. I’m ecstatic that you guys may change your direction/decision about this deprecation. Core was slick enough for 3 years but now with this Ubuntu plus Supervised — what an incredible piece of work… Thank you!


Ok, I just created a new poll in the “installation” category.

Any Moderator feel free to move it, pin it or I guess even delete it :wink: as you see fit.

Here is the link: How did you install Home Assistant?

I really tried to make it as self-explanatory as possible. I even included a custom flow chart to help you figure out which selection to make. :slightly_smiling_face:

I gave it three days as well.


This is just my way of thinking about it, feel free to disagree though.

  • Home Assistant using the Home Assistant OS disk-image on an SBC
    This covers all SBC installs “As an image for your device” from here

  • Home Assistant using the Home Assistant OS disk-image in a VM
    This covers installs “As a virtual appliance” from here

  • Home Assistant Core in python virtual environment on generic OS.
    This covers Venv installs listed here and here on a generic OS, or in a VM.

  • Home Assistant Core in docker container on generic OS.
    This covers docker installs listed here on a generic OS, or in a VM.

  • Home Assistant Supervised on generic linux.
    This covers any type of generic install of Home Assistant Supervised, whether that be in a VM, or generic OS - no longer listed to link.

Obviously, there are community guides listed like FreeNAS and Synology, but they essentially use one of the five methods listed above as far as I can tell.


I agree with you. That covers the documented installation methods (the last one is in a state of limbo) and uses the official terminology.

“Anyone running this installation method today can continue running this.”
Thx! I didn’t now that it would be deprecated(now on hold ofcource). Wanted to help a friend with the installation but could not find the url. I hope it will be supported one one shape or form. I like just running clean raspbian and when hass.io would break I still have everything from my nodered to zigbee2mqtt.

Just don’t install apparmour.

I dont know what hussle you got :wink:
Just tried it with an pi3 I got laying around
(added universe for you)

sudo -i
add-apt-repository universe
apt-get update
apt-get install -y apparmor-utils apt-transport-https avahi-daemon ca-certificates curl dbus jq network-manager socat software-properties-common
curl -sSL https://get.docker.com | sh
systemctl disable ModemManager
apt-get purge modemmanager
curl -sL https://raw.githubusercontent.com/home-assistant/supervised-installer/c674830d8ddc6af9d618755a7995af939dd73fde/installer.sh | bash -s 

(I curl the older version of the supervisor script after the warning doesn’t add value :stuck_out_tongue: and i got a syntax error. Purpose? we ll never know! )
when you like to install it on an pi run
curl -sL https://raw.githubusercontent.com/home-assistant/supervised-installer/c674830d8ddc6af9d618755a7995af939dd73fde/installer.sh | bash -s -- -m raspberrypi3


Well, one advantage is, that absolutely everyone that comes to this forum has HA installed and running. So, you WILL get a lot of response with a poll, that’s for sure. :slight_smile:

1 Like

I gave up trying to read this entire thread after a while due to length and (as far as I got) no apparent resolution. I fear the following will not improve things.

I do not yet run HA but had been planning to switch to it, I was particularly interested in Floorplan. I am not clear if Floorplan would count as an addon or not but that is straying off-topic. I do have a reasonable amount of experience of running open source projects including via VENV, virtual machines, etc. although not yet docker.

It would seem that the most desirable outcome for the majority would be to run HA and addons. From the portion of this thread I waded through I get the impression this is strictly speaking only going to be possible with the full Hassio i.e. HA OS install and not via Docker or the to be deprecated HA Core+Supervisor approach since that is EoL. I also get the impression the VENV approach does not support addons.

However it sounds like HA in Docker allows addons to be installed as additional Docker images meaning yes you can sort of use addons but cannot install them in the ‘true’ addons manner.

It would therefore seem that the two routes that could become recommended would be

  1. Hassio aka HA OS - whether running in a VM or not
  2. HA in a Docker with addons as additional docker images

What bizarrely seems to be missing and a logical solution is for HA to automate the installation of additional Docker images for addons in order for it to appear to a user as if it was just like the old supervised addon manager. It could be then that ‘supervisor’ becomes a form of docker manager.

We would then have just two basic approaches with equivalent functionality i.e. addons but those wanting to share the host system with other apps and to have more intimate control could use the docker approach whilst users wanting the simplest deployment method could run the HA OS either natively or in a VM.

(Indeed hypothetically HA OS could become an OS running HA in a docker with addons also in docker images all hidden behind a user friendly GUI.)

I apologise if I have mistakenly described stuff above - as I said I do not yet run HA and as many, many comments here and elsewhere legitimately complain the HA documentation does not make the different HA options clear.

A hint to the devs. It would probably help hugely if your documentation had table comparisons of the various options. Whilst tables can be written that still express personal bias it can also greatly simplify things for your users.


Just want to mention here until Raspbian natively supports boot to usb for Raspberry Pi 4’s, I believe the only way to run a full Home Assistant (previously referred to as Hassio) install with the /root partition on an attached usb drive is to manually configure this set up in a Raspbian install, then install docker, and then install HA Supervised Install…

Otherwise RPi4 users are forced to do everything with an sd card.

So if the HA Supervised Install must be deprecated because of a lack of resources perhaps it may be worth considering offering an option within the native installer for RPi4 to minimize the usage of the sd card to initializing boot only and switch to usb attached drive?

(Unless the HassOS RPi4 installer already allows this moving of /root while keeping /boot on the sd card)

(I do hear that Ubuntu for RPi4 supports native usb boot in release 20.04, if that’s of any help)

Venv doesn’t support add-ons.

That’s exactly what you get when you install HassOS. Add-ons are just docker containers, that have been modified to integrate smoothly into Home Assistant.

No need to apologize but, yes, you have used terms to describe things that don’t exist.

I realize it is impractical to read this lengthy thread, so here’s the one that uses the correct terminology to describe the 5 different installation methods. Other than that, the key post is balloob’s announcement the deprecation has been suspended for the moment.

1 Like

So why don’t they automate this for a none HassOS but docker based setup to make it fully equivalent?

@123 They still plan to discontinue the Core+Supervisor approach so I feel my suggestion on making the docker approach a proper fully automated addon approach like HassOS is relevant and needed.

I didn’t comment on that aspect of your post. I only commented on the fact your post misused terminology which resulted in describing unusual or non-existent things like:

Hassio aka HA OS - whether running in a VM or not

The term hassio was replaced months ago by the term Home Assistant and it has never been “also known as” HA OS.

HA in a Docker with addons as additional docker images

Home Assistant Core is available as a docker container. Add-Ons are customized docker containers designed to work with the Supervisor docker container. Home Assistant is the combination of Home Assistant Core, Supervisor, and Add-Ons (all docker containers) running on HassOS. The variation that runs on generic linux, as opposed to HassOS, is called Home Assistant Supervised (and is slated for deprecation).

1 Like

Thanks for the effort!

But unfortunately the installer script no longer works.
Should give a warning but even in this script there is an error …

Even the script has been adjusted (incorrect piece with warning omitted) but even then you will not get there anymore …

It may still work on a pi, but unfortunately it is no longer possible on a mini pc or a desktop … I no longer succeed …
the last 5 installations were without problems, but unfortunately no longer. Cloning a hard disk and then restoring a backup from another location does work. but seems unnecessarily complicated to me.

Thats why I use an older commit :wink: