Pellet stove 'Duepi-evo'

Hi aceindy, just installed the repository and tried to get it to work.
I can connect locally with the app:

I put the following in the configuration.yml:

  - platform: duepi_evo
    name: pelletkachel
    host: 192.168.100.66
    port: 2000
    scan_interval: 60
    min_temp: 20
    max_temp: 30

logger:
  default: warn
  logs:
    custom_components.duepi_evo: debug



But in the logging I see

duepi_evo: Error on device update!
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/helpers/entity_platform.py", line 360, in _async_add_entity
    await entity.async_device_update(warning=False)
  File "/usr/src/homeassistant/homeassistant/helpers/entity.py", line 465, in async_device_update
    await task
  File "/config/custom_components/duepi_evo/climate.py", line 174, in async_update
    data = await self.get_data(self)
  File "/config/custom_components/duepi_evo/climate.py", line 129, in get_data
    current_state = int(dataFromServer, 16)
ValueError: invalid literal for int() with base 16: 'HELLO*'

Hello Marcel…

Hmpf, that is weird; according the log file your wifi-module replies with ‘HELLO*’ ??
This is what is requested:

                # Get Burner status
                sock.send(get_status.encode())
                dataFromServer = sock.recv(10).decode()
                dataFromServer = dataFromServer[1:9]
                current_state = int(dataFromServer, 16)

Is it possible to open a telnet window:
Telnet 192.168.100.66 2000
And see what is really replies ??
Mine does something like image

:slight_smile: mine is much more polite:

[email protected] ~ % Telnet 192.168.100.66 2000

Trying 192.168.100.66...
Connected to 192.168.100.66.
Escape character is '^]'.
*HELLO*

1 Like

Ow…hold on…I think I remember…
The ‘Hello’ is the welcome message the module gives during startup…
It should be save to ignore it…
(or start up HA after you started up the wifi module…)
(and you could still leave the telnet running for testing :P)

After the initial ’ HELLO’ does it show any other signs of communication?

Hi @Marcel_de_Jong did you sign up for the cloud service? So is you App working remote and local?
(I have some local issues… :wink: )

@Whatsek Its communicating at @Marcel_de_Jong in Local…
the unit is reporting itself with ‘HELLO’ during start up, which is not recognized by my integration, as it anticipates an esplink (and not the original wifi module).
But besides that error, it should still pick up communications again after that welcome message…(at least, it does for me😋)

Yes, I know that he has a workin local connection, I am figuring out why it does not work with me. So I wanted to know if he also uses the cloud connection, as I do. I emailed Duepi, but no response yet…

@Whatsek They will respond (as they did with me)…i asked them 2 questions, the pin layout of the connector (which i got) and an overview of the serial commands (which they refused, as it was company proprietary :thinking:)

Well it used to work both remote and local, but a few months ago I connected the device to my IOT wlan and it doesn’t work remote anymore. Have not tried to fix it yet.

It looks like my unit reports that during every new session, at least it does when using telnet.
The integration doesn’t do anything after the error message (or I am looking in the wrong place)

@Marcel_de_Jong I still have my unit here, if i have time i will try to hook it up again and see if i can fix it :wink:

I appreciate all the work you put in to this, thanks and let me know if I can help

Hallo @Marcel_de_Jong,

I’ve been trying to test again once, but still lack the time to do it.
So much to do, so little time :frowning:

And the USB2Wifi module I put to sale, so once I receive an offer, I do not have the possibility anymore to check.

What I did manage to observe is that the unit communicates very frequently when connected.
Have you tried to set the scan interval way lower (1 or 2 seconds)?
scan_interval: 1

having an issue with your intergration, i am trying to collect locally but its giving me this error in logs,pretty sure i am using the correct ip because i got an notification from my deco saying a new device connected to the network

,

Hmm
What about port number?

The ESPLink uses port 23 by default, but basically it is a telnet port (meaning you can monitor it using any telnet program😉
Should look something like this:


which is the same what the ESPLink uc shows:

problem i found is that it doesnt have any ports open, yet the app works using the ethernet. it talks to duepiwebserver3.com:3000 right now trying to figure out how they send the device code. so i can make an intergration using that weburl.

the ethernet module i am using got delivered with the pallete heater and ordered from karwei.

Ah…

I don’t think that’ll work…
This user also tried, and I never had the time to investigate it.
In the meanwhile, I sold the wifi module…so I can’t do any further tests…

I can only recommend to replace it with an ESP01 module…

I have provided some info in the first topic on what is needed for that :wink:
The costs for the ESP01, voltage adaptor and programmer is around €8,- so that is not too much :wink:

1 Like

could it also work by using the ESP programmer as a voltage regulator instead of the esp01-s adapter module? so from the programmer (with the esp01s connected) with a usb-female to the pellet stove pinout (gnd,5v,rx,rx)?

nope, programmer is not the same as a voltage regulator

Hi, I have the same problem as you, the port is closed (I was trying to set it up from the beginning of this thread) I cantacted Duepi, and they told me that all the new delivered modules, (since 1 year maybe?) do not have a local port open anymore. Really bad news. They also didnt have an alternative. So we have to build our own board. Unfortunately I not really good with soldering, but I will try to make some time this winter to try to make one. But for the people that cant get an a local connection, this is sadly the bad news…