Power Flow Card Plus 🚀

Any idea why after upgrade, gas rate is showing incorrectly on the power flow card?


I’m not seeing anything that could be causing this here in Code Editor either:

    - entity: sensor.gasmeter_rate_per_time_unit
      calculate_flow_rate: true
      inverted_animation: true
      decimals: 2
      icon: mdi:gas-burner
      use_metadata: false
      name: Gas
      unit_of_measurement: m³/h
      display_zero: true
      secondary_info:
        entity: sensor.gas_cost_daily
        decimals: 2
        display_zero: true
        unit_of_measurement: €
        unit_white_space: true
      display_zero_state: true
      show_direction: false
      unit_white_space: false
      color_value: false
      color_icon: false
      display_zero_tolerance: 0

Love the new update. Thank you guys.

Let me adress one whish of my inner design monk.

Can the secondary info get the same color like the circle? Or a dedcated color attribute? Should be similar to the battery circle, where the upper info is colored instead of being default color.

image

I pretty much like the PFC and also take advantage of the new feature for individual bubbles.

However I have a problem with secondary information of type text - it is not shown anymore or I am missing some configuration which needs to be done.

I tried to show in a minimal example - both “Home” and “Individual” have as secondary information a helper of type text defined, but it is shown only for “Home”.
image

type: custom:power-flow-card-plus
entities:
  battery: {}
  grid:
    entity: sensor.solax_battery_import_from_grid
  solar:
    display_zero_state: true
  individual:
    - entity: sensor.heatpump_total_active_power
      secondary_info:
        entity: input_text.test_text
  home:
    secondary_info:
      entity: input_text.test_text
clickable_entities: true
display_zero_lines: true
use_new_flow_rate_model: true
w_decimals: 0
kw_decimals: 1
min_flow_rate: 0.75
max_flow_rate: 6
max_expected_power: 2000
min_expected_power: 0.01
watt_threshold: 1000
transparency_zero_lines: 0

I have the same issue. No idea why.

Does the power card assume that battery discharge is always to the house? I am currently exporting solar and battery to the grid, but the card assumes solar going to grid, and battery to home which is incorrect. Having two separate entities doesn’t help as their are actually three routes for battery: solar/battery, battery/house, battery/grid. Any one help me where I am going wrong?

After the update, I reconfigured my PFCP, but unfortunately, the Grid Battery Charging isn’t displaying correctly. Only the grid ↔ Home line is visible.

Here’s my configuration:

type: custom:power-flow-card-plus
entities:
  battery:
    entity: sensor.ladeleistung_dashboard
    state_of_charge: sensor.state_of_charge_vorlaufig
    invert_state: true
  grid:
    entity: sensor.netzbezug_insgesamt
clickable_entities: true
display_zero_lines: true
use_new_flow_rate_model: true
w_decimals: 0
kw_decimals: 1
min_flow_rate: 0.75
max_flow_rate: 6
max_expected_power: 2000
min_expected_power: 0.01
watt_threshold: 1000
transparency_zero_lines: 0

And thats the Result:

image

Anyone has an idea?

I’ve been using the custom power flow card (not this one and also not the built-in one) from soon after the energy dashboard got introduced to HA. Recently, I decided to switch to this card, because there’s also the energy flow plus card to accompany it. This card also allows for the configuring of individual devices, which is nice. My power flow plus card is working fine – happy with that.

My problems are:

  1. I cannot find a forum thread related to the energy card. Am I just not finding it? I couldn’t even find any but one reference to it in this thread. While I see activity on the power card’s repo, it doesn’t seem like the energy card has been updated recently.
  2. This brings me to my real issue, which is that I cannot get the individual device config to work.
  3. I also cannot get a line between solar and grid, even though it works for my power flow card.

Due to the lack of options, I’ll post my config here in a best effort to get a response. The docs state an individual1 key and an individual2 key. It’s not clear why there are two keys, compared to the power flow card that has a single individual key with a list of devices (entities). Does this mean the energy card can have only 2 individual devices visualised?

Power on the left, energy on the right:

My energy flow config.
      - type: custom:energy-flow-card-plus
        energy_date_selection: true
        kwh_decimals: 1
        use_new_flow_rate_model: true
        clickable_entities: true
        display_zero_lines: true
        entities:
          grid:
            entity: sensor.daily_grid_energy_consumption
          battery:
            entity:
              production: sensor.battery_energy_out
              consumption: sensor.battery_energy_in
            state_of_charge: sensor.battery_state_of_charge
          solar:
            entity: sensor.daily_solar_energy_consumption
          home:
            entity: sensor.daily_home_energy_consumption
            override_state: true
          individual1:
            - entity: sensor.daily_geyser_energy_consumption
              name: Geyser
              icon: mdi:water-boiler
              display_zero: true
          individual2:
            - entity: sensor.outbuilding_power_meter_channel_1_energy
              name: Outbuilding
              icon: mdi:garage-variant
              display_zero: true
For reference, my power flow config.
      - type: custom:power-flow-card-plus
        use_new_flow_rate_model: true
        clickable_entities: true
        entities:
          grid:
            entity: sensor.grid_power
            power_outage:
              entity: binary_sensor.grid_feed
              state_alert: "off"
          battery:
            entity: sensor.battery_power
            state_of_charge: sensor.battery_state_of_charge
            invert_state: true
          solar:
            entity: sensor.pv_power
          home:
            entity: sensor.home_power
            override_state: true
          individual:
            - entity: sensor.geyser_power
              name: Geyser
              icon: mdi:water-boiler
              display_zero: true
              decimals: 1
            - entity: sensor.outbuilding_power_meter_channel_1_power
              name: Outbuilding
              icon: mdi:garage-variant
              display_zero: true
              decimals: 1
        watt_threshold: 1000
        dashboard_link: /energy

I made some progress:

  1. It seems like this is the place to get help. Still seems odd there’s so little on the forum here.
  2. The individual* keys take objects, not lists of objects (so I simply had to remove the dashes).
  3. Use the split sensor options.

Hi @parautenbach, can you tell me how do you add the Date-Switcher (on top at the right side in you scerrnshot) in your dashboard?

I’m using the built-in one, but there’s also the one by the author of these cards. I tried it briefly, but then stuck with the built-in one.

The built-in one:

type: energy-date-selection
1 Like