Problem with app , doesnt stop "initializing"

Been trying to get the app working.
i open the app and it finds my instance, when i choose it. it just moves to a “initializing” screen that never changes. if i manully enter my nabu casa address it does exactly the same.

do i need to do anything in my hassio apart from just downloading the app.

cheers

3 Likes

Just installed the app and having the same issue. I can connect via my PC browser to <ip>:8123 just fine, but when I use my phone app to connect to same instance, it’s just stuck “Initializing”…
Would love some feedback if anyone has had this issue before…

@Sabbathy and @avoloshin91 make sure to enter the full url that you would use in a browser. Make sure you don’t have to accept any certificate as that will not work. Also make sure that either mobile_app: or default_config: is found in your configuration.yaml .

More on initial setup can be found here as well as a troubleshooting section too: https://companion.home-assistant.io/docs/getting_started/getting-started/

cheers @dshokouhi annoyingly have followed all those pointers and still coming up a blank, annoyingly the app HA client works perfectly just cant get this to set up , im using the nabu casa link for both and drawing a blank. will keep plugging away

Hop on the HA discord and head over to #android channel, I am sure someone in there uses nabu casa remote and can help you out.

Same here - “Initializing” forever in Home Assistant companion app.
Same from mobile Chrome: http://192.168.1.49:8123
*Home Assistant 0.109.6 , HassOS 3.13, android 5.0.1

For HAClient, only long-lived token login option worked.

1 Like

Le x527 (android 6.0.1) stuck “Initializing”… Web version work fine.

check that android system webview is updated

3 Likes

Android System WebView - latest, 83.0.4103.83v

are you on a custom rom or a device without google play services?

stock firmware (eui 5.8) without root. play services - 20.18.17

Are you also using nabu casa? do you have the remote toggle enabled? What URL’s are you using to login?

No,Hass installed on rasppbery pi , using external URL, https . From other phone(Redmi note 8 pro) all work.

does this device normally have google play services installed or did you have to install it manually? its possible that its missing android system webview as an actual system app instead of just an app thats installed from the play store.

gapps exist in stock firmware, android system webview - sys app, i can update o remove update only.

are there any HA errors in the log?

Webview info app show me: android system webview real version is 40…I will update the firmware. Sorry :slight_smile:

Fixed my problem. Thankyou.

1 Like

Hello,

Seems that I’m having the same issue on a brand new install. Mobile device (Galaxy S20 Ultra 5G) is on stock firmware, webview is installed and updated (v96.0.4664.92). config does contain default_config:. Tried adding mobile_app: anyway, but to no effect. Can connect via browser on the mobile device (but not mobile_app:). Don’t know what “nabu casa” is, so don’t have it unless it’s a default install option. HA is on a HAOS VM, version core-2021-12-1.

Any recommendations welcome!

Hello! I have my tablet with android 4.2 and it had the error due to the webview. Install chrome and it didn’t fix it, I managed to fix it by installing Opera browser.