Progress indicator when Restoring from Backup

This function would be amazing, several times I have had to restore my HA and it is very bad not to know when it has been restored, or if it is really being restored or not.

My backup occupies about 2gb and it takes more than half an hour to restore, I had many failed attempts until once I left it for hours, and then I discovered that it was really being restored…

3 Likes

This is silly, I opened a feature request on this yesterday with how unbelievably frustrating this is - and it was closed in favor of this one that is over a year old!

NO ONE IS LOOKING AT THESE. HOW MANY VOTES ARE NEEDED TO ADD SOMETHING?

5 Likes

Honestly, 45 votes is not that much :frowning:

It is when it’s a 23MB file AND when there’s no indication of the status.

1 Like

I find it strange that this is not something that already came standard. The “may be it is finished or may be it is not” , is really frustrating. I don’t know if there is a problem with my system or it just isn’t finished updating. Right now I did a partial restore. no mention if it is done or anything. Same goes for installing add-ons, integrations, HACS, everything in this environment just leaves you guessing.

so am I supposed to wait till tomorrow to reboot and see if everything comes back up? What am I supposed to do?

I wish I knew more programing to actually do something about it… any suggestions as to where to start?

Here is something similar to what we want, but looks like it went no where.

Yes !, well, no, vote it up ! tell your friends ! get it to the top of the feature request list and we might get lucky !

1 Like

It will be very useful to have the ability to monitor the status from the haos as well. And Voting 1000%. Disaster recovery become stressful without progress.

2 Likes

maybe we can get a HA youtuber to cover it

2 Likes

Good plan !
Lewis from Everything Smart Home
Ed from Smart Home Junkie
Kiril from Automate Like Pro
To name but 3 !

1 Like

I guess our job now it to make enough noise in the comments section on those channels to get some recognition.

2 Likes

Currently looking at a rotating circle for 2 hours with a backup of 6gb. No clue how it is going. A status bar would be very welcome add my current stress rate. :sweat_smile:

2 Likes

I feel your pain ! I had to do a restore myself this week due to a faulty release of Node-Red. Set it going and used the Load Monitor of my Linux HA Server to try and guess if it was actually doing anything. Not ideal !!

Beyond a progress indicator do we know WHY it takes so long to restore?
I’m currently trying to move from a raspberry Pi to Proxmox on a NUC and run a test restore…
So far 2h50 in and nothing, if I look on proxmox the VM is doing pretty much squat of any sorts.

I’m wondering if it is the size of the home-assistant_v2.db file ? Mine used to be quite small, now it can hit 5Gb in just a couple of days (that’s another problem for another day) but 5Gb of anything is going to take a while to wade through? I might be wrong but it seems a decent theory !

Linking to my post:

I’ve only done one restore and one backup, so fwiw:
Restoring a 6.5MB backup to a new HA image on an RPi4, watching the chasing circle for ~45mins, I finally tried hitting refresh [F5] after reading that thread, and the page updated to the expected configuration.

It appears the chasing circle page didn’t update when done? So maybe it’s not “progress” we’re not seeing, but the page simply not updating?

Thanks to the community for their help for this newbie.

Or even just output of the processes…

2 Likes

This is desperately needed! I’m currently restoring a backup to a new system, but the never ending circle tells me nothing. When I refreshed the webpage it prompted me to restore again. Totally unhelpful!

4 Likes

i’ve waited for over 15 hours and nothing, it told me big backups could take up to 45 minutes but after reading this was bull and it could take 3 hours i decided to let it run over night, but after 15 hours i decided to give up. i restored backups before and those worked perfectly.

1 Like

6gb wow mine was 2 and it just wouldn’t do anything

1 Like