Pure HA+Thread, "Border Router required"

I’m starting from scratch with HomeAssistant in a KVM, with a SkyConnect USB passed-through. I have no Apple Homekit or any other network/border router. I’m trying to build a pure HomeAssistant + Matter/Thread system.
This is how my Thread looks:


I followed the official guides to get the ZigBee deactivated and Thread activated instead, and to set things up this far.

Now when I try to add my first Thread device (a new Eve smart plug) using the iOS app, it says I need a Thread Border Router in my network. Why does the iOS app not know about the border router I have? How can I make it know?

Any help is appreciated, and please remember I’m new to this, so if there is anything obvious that I might have overlooked, that’s totally a possibility.

1 Like

Matter+thread is currently a big mess, but there are some hints to problem solving in this video.

Oh.

This is what we want to achieve in the long run:

The ability to use the Home Assistant SkyConnect or Home Assistant Yellow as a Thread border router to connect to Thread-based Matter devices instead of using Apple or Google Border routers.

I guess this means my setup is just not yet supported at all :frowning:

The iOS HA Companion App has an issue (I think maybe in the Apple SDK) that doesn’t allow it to get/store/handle properly Thread dataset/credentials. Developers on Discord say a fix is coming soon, but hard to tell how long that will be.

Is this still a problem? I have the same error message when using pure Home Assistant OS + Sonoff ZBDongle-E. There seems to be a working thread network, but the iOS app is unable to find it. I am trying to connect Eve Energy (Matter).

Screenshot: Addon

Since I can use only one image per post, here is my thread screenshot:

Screenshot: Thread

Post a screenshot of your IPv6 settings instead.

I tried it with a Samsung phone and got the same error. These are my network settings (unfortunately in german):

Screenshot: Network

All the addresses are available via ping.

Those are the ones you configured.
Click the three dots you have in the bottom of your screenshot and choose IP information to get the “actual” ones. :slight_smile:

Ok thanks, those are the addresses and I can ping them too:

Screenshot: IP Information

As for using iOS HA Companion App to commission Matter/Thread, I’ve been told by one of the developers that there is a race condition so it may or may not work.

I found that when using a manual setting in IPv6 it would not work unless the fe80 address was the first one listed.
Try to set it to automatic and then restart the host (not just the core) to clear the present IPv6 settings.

Thanks, but reset to automatic doesn’t solve the problem. It still tells me that a border router is required.

I guess I need to buy a ready-to-use matter thread border router somewhere. Google Nest or Apple HomePod mini seem to be the cheapest even though I don’t really need them.

I use just a SkyConnect with HA as my only Thread Border Router, so it can work, but I commission devices through my Android 13 phone, which my be the important difference here.

Sounds good. However, I tried a Samsung A55 yesterday. It has the latest Android version. It didn’t work either. Should I try a SkyConnect stick or do you think it won’t make a difference?

Make sure you have the correct thread credentials on the Android.

On the Android Companion App open Settings → Companion App → Troubleshooting (I think that is what it is called in english, but it list logfiles and other tools to diagnostics as description of the item).
In this next window click the Sync Thread Login Credentials (Again it might not be named exactly that, but close to and there should not be that many options and it should be in the bottom)

It should say either something with “Added …” or “Already using the same credentials”.
The trick here is to run it again and make sure that it does not say “Added …” the second time.

If it does then you need to clear the Google Play Services Cache, which might clear a lot of other stuff, like login to services and credit card informations for Google Play and websites and so on, so make sure you know you informations before hand.

The way to clear the cache is Settings → Apps → See All Apps → Google Play Services → Storage and Cache → Manage Storage → Clear All Cache
Now repeat the syncing of the thread credentials above.

3 Likes

Thanks, it helps me add my matter device