QNAP + Docker = needs advise please :)


#21

I just install Home Assistant on QNAP, but I need some help to install my HUSBZB-1 please see below, I can not see “ttyACM0”


#22

#23

Hey all - just wanted to invite you to a couple resources being used by some fellow “Docker on QNAP” folks:

QNAP Unofficial Forum
QNAP Unofficial Chat

Thanks - Jerry


#24

Sorry to pick up on an old thread, but which container do you use for node-red? The default QNAP one that’s part of the QIoT appears limited and not able to manage palettes. Thanks!


#25

From docker hub. Will have to check when I get home.


#26

I have the same issue, cant figure out what node-red I need to run to connect it to the HA docker. I have hnicoliasen/home-assistant running on one container and eclipse-mosquitto running on another container. I have tried different versions of node-red and they all seem to fail when i have to setup the home assistant server settings. I get the message “flows are stopped due to error with - server”. Please help!!!


#27

nodered/node-red-docker

I use the node-red-contrib-home-assistant palette v0.2.0


#28

I use HomeAssistant/home-assistant


#30

Are you leaving the network mode in “NAT” or “Host”? I installed the contatiner using the “Host” option and added the node-red-contrib-home-assistant palette v 0.3.2 - this is the latest. How do you get the node-red connected to the home assistant. What server settings are you using?


#31

@Pisupati If node-red uses the same IP address as HA you should be able to access it using localhost:8123. Otherwise you have to put in the IP address of HA
In the evenig I can make some pictures of my setup. Right now I can’t access my QNAP NAS :wink:


#32

Yes, mine uses the same ip as ha, but uses the 1880 port. I tried using both, IP and localhost, still getting the errors.


#33

Got node red working - used vimagick/node-red:latest container and the Long-Lived Access Tokens. Now to try and figure out the husbzb-1.


Qnap Homematic (Hardware Layer)
#34

Hi,

I succesfully installed HA on my QNAP NAS and I can operate devices, etc…
But I would like to have:

  1. Alexa Integration
  2. Remote Access
    For this reason I need to have https://, thus using LetsEncrypt & DuckDNS.
    I am little bit lost on how to start integrating this.
    Anybody has any advice for me?

Thanks!


#35

Ok, here my love hate relationship with QNAP HA. Verdict - hate it. Sorry needed to vent and let out some steam.

  • Got HUSBZB-1 working with docker - this was like getting a colonoscopy. Got it working added my xiaomi sensors all good. Every time I reboot the device the Zigbee stick drops, have to start fresh - Do any of you have this figured out please help.

  • Restarting the NAS - everytime I restart the NAS the configuration is lost even thought the configuration.yaml file has all my custom code, the NAS fails to detect them and goes to the base configuration. can see only the sun and yr symbol. - Colonoscopy + root canal

  • We sometimes loose power - I simulated this by un-plugging the NAS and re-plugging it. HA does not start, why? - QNAP says- some containers will not start after a improper shut down. At this point just shoot me.

I feel that the $30.00 RPI is much better and reliable option than the $1000.00 piece of XXXXX.

If you know how to get around these issues please let me know. TIA


#36

I am in the process of switching from hass.io to hass/docker on my QNAP. I’m stumbling trying to find the mosquitto.conf to set a password. eclipse-mosquito is installed on it’s own container.

Advise? Link?

TIA


#37

You have to configure the MQTT server in the configuration.yaml. See:

https://www.home-assistant.io/components/mqtt/


#38

Thanks for the reply. Yes, configuration.yaml has been updated.

My problem is finding the mosquitto.conf file to set credentials. When creating the container I set the network from NAT to Host, added an existing shared folder (where I expected to find the files) and a mounting point location in the root.


#39

Are you using the “eclipse/mosquitto” container? I had problems using a shared folder outside the container. I got always an error message, saying that the container was not able to write the mosquitto.conf. I had to add -u 1000:1000 to the start command, then it worked fine. The numbers could be different at your system. You will find them using id <username> in the console.


#40

I am using eclipse/mosquitto. It is running without errors.

1234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890

1551562847: mosquitto version 1.5.8 starting
1551562847: Config loaded from /mosquitto/config/mosquitto.conf.
1551562847: Opening ipv4 listen socket on port 1883.
1551562847: Opening ipv6 listen socket on port 1883.
1551562873: New connection from 10.1.1.3 on port 1883.
1551562874: Socket error on client , disconnecting.
1551562874: New connection from 10.1.1.3 on port 1883.

It shows a file location where the .conf is located but I can’t get to it anyway that I know of. Nor do I know of any other way to set a user or password.


#41

You can access the conf file with docker exec -it <containername> /bin/bash then you should see a command prompt like [email protected]<containerid> now you can navigate to the directory where the conf file is loaded. And here is the documentation of the conf file. There is described how to set up a user and password.