Raspberry Pi 3 B+ not connecting

I am trying to get my RPi up and running. I downloaded hassos_rpi3-2.12.img and used balenaEtcher to flash the micro-SD.
I purchased this micro-SD since it is what popped up in Amazon when using the ‘recommended’ thread in the HASSio page.
The balenaEtcher program showed ~2.51GB being flashed.
I plugged the SD into the RPi, plugged in an ethernet cable, and then plugged in power.
I tried http://hassio.local:8123 with no luck.
I could not find any device on my router that could be the RPi.

I found this thread so I purchased a PNY P-SDU32GU185EDR-GE

I am still unable to connect, however, an Intel device now shows up on my list of router clients.
I tried http://hassio.local:8123 and http://{the intel device IP}:8123 with no luck.

When looking up a RPi on a router, how does it display? could ‘Vendor: Intel Corporation’ be the RPi?

if I SSH to the IP address, I get the following response
ssh: connect to host port 22: Connection refused

I am trying to install raspbian, but need a monitor and keyboard to see if I am getting anywhere.

Any thoughts?

You do know you need to wait at least 20 minutes before you han log into hassio?

sometimes hassio.local doesn’t work.

Did you try http://ip-address-of-device:8123 ?

Randomly ssh’ing isn’t going to help if ssh isn’t setup and you are confusing hass.io with raspbian. If you want raspbian, don’t install hass.io

When you install hass.io I think it will show in your router as hassio… not 100% sure. I did =just setup a test system yesterday but the Pi has other uses and I have edited the name of the device in my router so I can’t tell what it would be but pretty sure it will say hassio

When you install hass.io I think it will show in your router as hassio

Can confirm on this. Currently I have a problem where I can only access by IP, but on router it appears as Hassio.

It’s not a problem it’s your router not doing mDNS but it’s not a problem and the docs mention to use the IP address…

In my case its a problem, because my router is doing mdns. It was working fine.

I definitely waited 20 minutes. Much longer than that.

I tried both the mDNS address and the IP address. Neither seemed to work.

When HASSio did not seem to work, i thought I would try NOOB or Raspbian, hence the SSH effort. The only requirement to enable SSH is to add a file with no extension, name SSH. Also, on Raspbian, when putting the micro-SD back into my main computer, the name was changed to ‘recover’, so something was crunching.

I will try with a monitor to see if the RPi is booting at all.

I got Raspbian working on the RPi. This is using the sanDisk 64GB micro-SD.
However, it required a monitor and peripherals. The screen came up with ‘SSH is enabled and the default password for the ‘pi’ user has not been changed. …please…set a new password’.
I clicked ok and my LAN monitoring app found a new client on the router as follows: Both Hostname and mDNS Name = ‘raspberrypi’, vendor = ‘raspberry pi foundation’.
I set up wifi, and a second popped up on my LAN app.
I take this to mean I missed something in trying to set up a headless raspberry pi - no connection to LAN (which is needed for headless configuration).
I will try to boot with the PNY, then Hass.io next.

OK. that was fast. I put in the PNY which still had Hass.io on it and it booted up.
The LAN app showed a new client on the router as follows: Both Hostname and mDNS Name = ‘hassio’, vendor = ‘raspberry pi foundation’.

I tried http://hassio.local:8123 from my Mac computer, but that still did not work. On the RPi, the screen showed a rolling list of events. I could tap the enter key and get a ‘hassio >’ prompt. I forget what I did, but it prompted for a username and password. I searched the internet and found ‘root’ as the user name and no password. this brought up the ‘hass io’ DOS artwork. I went back to my Mac and tried http://hassio.local:8123 and it worked.
So the PNY works.
I suppose I will argue that the instructions from Hass.io Getting Started page is not correct. On mine, I was not able to open a browser and claim victory on ‘the hardest part of the install’. Not sure what went wrong there.

I think the only thing to say is that it was still loading the first time you tried. Logging in on the hassio console does nothing from that perspective.

Oh and is not DOS.

I know it is not DOS, just trying to communicates the interface type - not a GUI.

I gave it a good 1 hour wait after boot up. The hassio client is not showing up on my LAN app, though a raspberry pi device is showing up. I used the non-mDNS access method and get a login page - “You’re about to give http:/// access to your Home Assistant instance.”
I am probably being too cautious here, but am I giving that device access to my Hass instance or am I logging into Hass? I would have expected something like “log-in here”.
And trying to log in, I am getting “invalid username or password”. I set up an account, but that password did not work.

My problem now is that after some time the RPi is no longer showing on the network.

I re-wrote my micro-SD and started from scratch. It seems to be working and I have Hass.io has not lost connection.
I found the following thread that again pointed to SD cards and more.