Raspberry pi zero 2 w

I don’t have one, but I guess might be worth considering. Can you create a feature request?

If you look at what he posted, it never had any intentions of running the things you mentioned. Running code you copy and pasted form the interwebs isn’t the best option if you dont understand what it’s doing.

There’s plenty of reasons. Personally, I plan on using it to just handle my “infrastructure monitoring” which includes things like my battery and solar systems. It’s just going to gather data at those devices and push it into influx with most of the local services disabled.

I think it’s critical that people understand the limitations of using this hardware, but if you do, it’s a great edge node.

If it’s purely about data acquisition, then using a Pi Zero 2 with Home Assistant is the completely wrong approach, as far as I see it. It’s using the wrong tools for the wrong job.

Data gathering is a relatively simple task that is perfectly suited for microcontrollers. From an ESP, over an Adafruit Feather to the Arduino MKR or IoT families, just pick one. They will gather your data, possibly do some light weight preprocessing and send it over to your actual data processing system (typically HA around here) over something like MQTT, modbus, or whatever other protocol you choose. Telemetry protocols like MQTT have specifically been design to do exactly this. No need for a PiZero2 or a second (or third or 4th…) HA instance on a device that is purely dedicated to gathering data.

And if this is a remote area where you need some on location database processing and storage, then why would you use HA to do that ? Just push the data directly into influx.

That’s your opinion. There’s more than one way to architect a system. And for what I need and want it to do, it’s the perfect tool for the job.

I’m using the integrations within HA for my infrastructure devices because they’re already there and they work. There’s no value for me to try to reengineer the same things in the form of an ESP. I just want something that continues to collect the data if/when I’m working on my main instance of HA.

This instruction worked for me:

Starting from section 2. HA+Supervisor. Packege configuration for raspberry pi3

I’ve created a feature request for supporting this board: Support Raspberry Pi Zero 2 W
@agners I count on your vote :slight_smile:


So I did some tests on my brand new Pi Zero 2 W. It’s a very nice upgrade over the old Pi Zero W, but there are some serious drawbacks compared to a Pi3 or Pi4. Which obviously makes sense, considering the size difference. It’s still very impressive how they managed to put that much on a small single sided board.


  • Much better performance than the Pi Zero 1, but still lower than the Pi3 (same CPU, but lower clock speed).
  • Wifi is around 60% faster than the one of the Pi Zero 1 (but it’s still very slow, see below)
  • Inexpensive
  • Small


  • Wifi is very slow and drops very quickly with distance to the AP. I put the Pi Zero 2 into the same location and orientation than the Pi Zero 1, around 3m from the AP with a wooden floor inbetween. On the Pi Zero 1 I get around 30 Mbps, the Pi Zero 2 does 47 Mbps. Nice speedup, but in the end that’s still barely 6 MB/s. This makes everything involving the network really slow and laggy.

  • 512MB RAM is not much. Especially if you run overlayfs, so to make the SD card readonly and keep all logs in ram (which btw is super easy to do on the newer Raspberry Pi OS versions and makes SD card failures a thing of the past), then you’ll hit the limits pretty easily.

  • The thing heats up quite a bit under load. I stress tested it a little. After around 6 minutes the CPU was over 70°C and I stopped the test. A heatsink would be very much advised if you run some more heavy stuff on it.

All in all a very nice board. But as far as I see it, it isn’t really usable for a serious HA install, mainly due to the slow wifi and the limited memory. It may cope well with a very stripped down HA. But I’d suggest installing it as a bare bones venv to reduce memory use then.

The board has a lot of other great uses of course. For me it works great as a wifi connected USB mass storage device for media delivery (basically it presents itself as a USB drive, but maps all data to the NAS). Like the Pi Zero 1, it has OTG support on the USB port, something the Pi3 doesn’t have.


I’m new to home assistant, but I say everything works fine using zero 2w. I have about 10 tuya covers and lights that control using localtuya (from hacs). The raspberry don’t get hot. I have about 15 automations. I hope they make a image.


Hey! Which image did you use to flash Home Assistent OS on the Pi Zero 2W?

Ich had problems while adding Add-ons. I used the Image for the Pi 3 64bit…

1 Like

ok i thing i’ve got it running supervised on 2 zero, and docker, and prtainer, following this video : HomeAssistant Supervised on Docker - YouTube
now i must delete everything and try to make it again, because i cant figure it out how it happened.

64bit with 512 Mb ram ? Not advisable. Better use the 32bit image.

Not sure how to check sw version. the lack of hardware is pushing in to this. i do not have possibility to pay over 100 euros for raspi 4 that is the only one available on market.
so for testing and playing 2 zero.

I managed to successfully install Home Assistant OS on my Zero W2 using this link: Raspberry Pi - Home Assistant and selecting the Pi 3 32bit URL with balenaEtcher on a 32G SD card. It has by default supervisor installed. I managed to get HACS integrated and added some custom repositories, all worked well and I could not notice a difference in performance to HA I have running on a Pi3B.


Can you plz tell the steps to install manually and how to increase swap file.

Also how do I configure wifi before the first boot?

I use RPi3 image for docker and it work’s fine but not superspeed. It’s better to use HassOS instead of docker - did you maybe test this two options?

I install rp3 image on rpi zero 2w.

  1. I am not able to configure wifi.
  2. How to increase swap file?

How did you get it to work docker.

Since the rpi zero 2 are available again for a good a price, i gave it a try with HA.
First i tried the latest Zero 2 Image Index of /11.0.dev20230720
No output, does not start.
Than i tried the Rpi3 64 Image, that starts up to the IP Adress Message, and the Preparing … HTML Site.
But thats it, there are repeating Errors

Nxt i’ll try the Rpi 32bit Image

Wifi Config
Create directory in root of the SD , config\network
create a file here wifi-network


# Make sure to use a SSID of a 2.4GHz network