Remootio garage door automation - new product

following as getting same error via HACS too

what version of Core HA is this being aimed for

I noticed there was an update this morning so tried it.

Getting two different errors now


Config flow could not be loaded: 500 Internal Server Error Server got itself in trouble


homeassistant.requirements.RequirementsNotFound: Requirements for remootio not found: [‘aioremootio==1.0.0a13’].


Logger: homeassistant.util.package
Source: util/
First occurred: 6:45:46 AM (3 occurrences)
Last logged: 6:47:10 AM

Unable to install package aioremootio==1.0.0a13: ERROR: Cannot install aioremootio==1.0.0a13 because these package versions have conflicting dependencies. ERROR: ResolutionImpossible: for help visit Dependency Resolution - pip documentation v22.1.dev0

thanks for this. the install instructions aren’t too clear on the git page. What do i need to add to my config.yaml file once i’ve added the folder to my custom_components directory, or what do i need to do to get this working inside my home assistant setup. Any help would be appreciated.

Looks like there is some movement on the official integration request.

@jamesbj348 hope the requests are easy enough to address. There’s a number of us super keen! Thank you!

custom repo was removed as i have no idea wtf im doing :rofl: it worked on older versions but not on newer, we will all just have to wait for the creater and core team to implement it however long that takes

the code owner has updated it and it now works again can be used in HACS until it hopefully soon hits the main branch

Again this is only for those who cant wait

What’s the YAML needed to deploy it?

doesnt require any YAML can be all configured thru the ui install thru HACS then reload and add thru the normal integration

I can’t find it in Hacs. Is there a custom repo for it?

Hi there

I’ve been desperate to try this out on our Merlin garage door so I gave it a go, but there’s a couple of questions I have.

It shows up as a “sensor” instead of a “switch”. I don’t know if that’s important, but I can’t seem to make any Automations involving the Remootio “sensor”. I also have a light “switch” and can make Automations with that - I don’t know much about HA so I just mention it in case that’s important :slight_smile:

Secondly. Our garage door is one of those “toggle” ones, so I use the Remootio external magnet sensors to enable the system to “know” what’s “open” and what’s “closed”. The problem is that if you hit “open” and then hit “close” while it’s still opening, HA (ie this custom_component) returns that it’s “closed” whereas it’s actually stopped half-open. The Remootio app on my Android seems to know the proper state: if you hit “open”, I guess it polls the WebSocket until it sees it return “closed” before declaring that within HA? I guess the current code instead is assuming that if you hit “open/closed” then it must become “closed/open”? Shouldn’t there be extra polling until the Remootio device declares the state has changed properly?

Anyway, fingers crossed this gets into HA properly soon. Looking good :slight_smile:

Hi! I just updated to Home Assistant 2022.5. This unfortunately breaks the Remootio-integration, which no longer seems to load. Do we need an update in the integration?

2022-05-06 11:25:45 ERROR (SyncWorker_7) [homeassistant.util.package] Unable to install package aioremootio==1.0.0a14: ERROR: Cannot install aioremootio==1.0.0a14 because these package versions have conflicting dependencies.

ERROR: ResolutionImpossible: for help visit

WARNING: You are using pip version 22.0.3; however, version 22.0.4 is available.

You should consider upgrading via the '/usr/local/bin/python3 -m pip install --upgrade pip' command.

2022-05-06 11:25:45 ERROR (MainThread) [homeassistant.setup] Setup failed for custom integration remootio: Requirements for remootio not found: ['aioremootio==1.0.0a14'].

If anyone is eager to get this working. It seems that the aioremootio has a dependency on an older version of voluptuous which seems to cause the problems.
I tested by forking that to my own version and just changing the version dependency. Now it seems to work.
If you really need it to work, until the maintainers get this fixed, you can do so by editing the file
Change the requirement to instead be
"requirements": ["aioremootio @ git+"],
and restart HA. Then it works (at least for me). I guess you have to trust me to not change the code to something evil, so it is on your risk :wink: Hopefully the official versions will be updated very soon!


nice one! did the job

This works perfectly for me :+1::slightly_smiling_face:


I’m trying to duplicate the logic in your flow. Would you be able to share the Node RED JSON export (presumably minus any sensitive info)?


Hi, I am trying to integrate my Remootio into HA and have it installed via HACS but when I configure the I-address, API and Auth Keys I get an “Unexpected error” message.

I am running:

Home Assistant Core 2022.6.5
Home Assistant Supervisor 2022.05.3
Home Assistant OS 8.1

Error log details are as follows:

Logger: custom_components.remootio.config_flow
Source: custom_components/remootio/
Integration: Remootio
First occurred: 2:43:46 PM (1 occurrences)
Last logged: 2:43:46 PM

Unexpected exception/error
Traceback (most recent call last):
File “/config/custom_components/remootio/”, line 117, in async_step_user
validation_result = await validate_input(self.hass, user_input)
File “/config/custom_components/remootio/”, line 86, in validate_input
device_serial_number: str = await get_serial_number(
File “/config/custom_components/remootio/”, line 66, in get_serial_number
result = await remootio_client.serial_number
TypeError: object str can’t be used in ‘await’ expression

Is anyone else getting this issue? First time I try it so not sure if its an issue with 22.6.5?

Any help appreciated


I’ve just installed it via HACS, made the modifications for the requirements as per the post on May 6 and got further than before, but the same errors as what you’re seeing.

I am not sure… It looks like both the HACS-remootio and the aioremootio-package has been updated. My quick-fix for the aioremootio should probably not be used anymore.
I guess you have tried without my “fix” and it still does not work? Otherwise, you should really do that first.
I have not updated the integration in my HA installation, since my remootio kind of works. Though, to me it looks like that the

result = await remootio_client.serial_number

is strange.
I hope that the maintainer updates this, if it is not working. At a glance, it should not have that await-statement there.
I will see if I can find time to look at this next week. Since I did not write the code, it will take some time to understand it.

Yes, that await-statement is wrong. I am a bit unused to the “correct” way of versioning and git and the development-containers for doing home assistant stuff. But I have read through some documentation, and tried to do this by the book…
I have tried to send the change by making a “pull request” to sam43434 so he can make an update to the package. Hopefully I did that correct…
If you are feeling bold, you could while waiting for the new version change the file


Change line number 66

result = await remootio_client.serial_number


result = remootio_client.serial_number

I.e. just remove the await. Make sure that you do not change the indentation of the file, since python depends on it.
If you have made my previous fix for the versioning problem, please change that back to the original. If you can not remember what it was, just search for the remootio integration in HACS and choose to download it again.
And do that before changing the Otherwise that change will be lost.

Awesome, thanks!
I saw the PR was accepted just after I saw this post updated, so it’s all working now. Happy days!

1 Like