Repository: Bestlibre Addons repository

hassio-repository
Tags: #<Tag:0x00007f47fde42838>

#1

Like danielperna84 before me, I have started an addons repository. It is full of very experimental stuff.

To add to your hass.io installation, follow these instructions and add the repository https://github.com/bestlibre/hassio-addons

Available working add-ons:

Work in progress, not tested


InfluxDB+Grafana vs Prometheus pros and cons
Hassio with official 3rd party dockerhub images
Add-on ideas
Caddy tutorial needed please
Automatic backup in hass.io
Caddy VHosts in Hassio iFrame panels
Curl > json command
Introducing Hass.io
Web-based editor
Curl > json command
#2

Greetings, I’ve tried certbot and got error, unfortunately

pkg_resources.DistributionNotFound: The 'future' distribution was not found and is required by parsedatetime

Seems that py-future package is missing. Should be easily fixed using something like

apk add -U --no-cache py-future

#3

I’m looking into it ASAP. It seems to be a new dependancy since it was working before (Or py-future was include in the resin os base image and not in the new one)


#4

Thank you! Confirmed fix with py-future apk in Dockerfile :slight_smile:
If you don’t mind I do have couple more suggestions.
I have very strange ISP and port 80 is closed for me, in such situations it’s very nice to have ability switching challenge. I have ended up adding

"challenge": "str" 

into config
and explicitly opening ports 443, 80. Final thing is to change certbot params to have something like

...
CHALLENGE=$(jq --raw-output ".challenge" $CONFIG_PATH) 
....

certbot certonly --non-interactive --email "$EMAIL" --standalone --preferred-challenges "$CHALLENGE" --agree-tos --config-dir "$CERT_DIR" --work-dir "$WORK_DIR" --cert-name $name -d ${domains}

P.S. nginx plugin works like charm, thanks again!


#5

I have just pushed a new version with py-future. As soon as the travis build kick in it should be available on docker-hub.

I’m not sure I follow the opening ports requirement for the challenge ? How will it work with the proxy (wich already use ports 80 and 443 on the host) ? Which challenge are you using ?


#6

With tls-sni-01 it’s possible to use 443 port rather than 80 which is used right now


#7

I could add the --standalone --preferred-challenges tls-sni option. I don’t see how I could open the 443 port without conflict with the nginx proxy. Is it acceptable for you if I open another port (ie 10443) and then you could use the nginx proxy to redirect 443 to 10443 ?


#8

Please ignore those ports. I think it didn’t work for me without explicit opening because I have some problems with host network: I’m not able to connect to any container without opening ports directly. So if you’ll just add options to specify challenge would be great.


#9

It will not work without the ports option because the standalone plugin need those ports to be opened and accessible. The current addon use the webroot plugin which rely on an external server (ie nginx in the nginx-proxy) to serve the challenge.

In fact, I’m not sure it can work with the nginx_proxy to redirect 443 to 10443, you will need to access the service you want to proxify on a sub directory since the root of the virtual host will redirect to certbot. Or you will need to change the configuration of the proxy each time you want to renew the certificats.

Since it is not possible to access the ports configuration from the ui (it is fixed at the addon generation) I don’t see how to solve this. Apart from a new addon based on the existing one with the ports exposed and using the standalone plugin. For now I will publish my modifications to allow the use of the standalone plugin with a redirection. It will need some extra action on your part to be used :

  • modify the nginx_proxy configuration to proxify 443 to 10443,
  • start the certbot addon,
  • wait for the certificats to be created/renewed,
  • stop the addon,
  • revert the nginx conf

Does this seem doable for you ? In the meantime I will look to propose a modification of hassio core to allow to dynamically modify the ports.


#10

Yeah, I understand this. I was planning to start/stop certbot and nginx anyway :slight_smile:
Thank you for your efforts!


#11

I have push the new version. It should work but I cannot test right now. Just wait 5 minutes for the new version to be uploaded (the badge will show version 0.1.6 on this page github). I have updated the documentation.


#12

hi @bestlibre

Thank you for the repo and plugins; the one thing stopping me from switching to hass.io was always grafana and i’m glad to see it here.

I’ve got the repository configured correctly and the plugins installed, but now i’m wondering what else is needed for configuration, and what are the IP address for grafana? This is the first time i’ve ever used Hass.io/resinos before so not sure at all where to go. I need to create a database in influx to store things, and i’m not sure how.

Thanks,


#13

For grafana access, the IP is the same one as hass.io. The port is 3000. To use influxdb you can also use the influxdb addon.


#14

hi

when installing influxdb how do you create the first DB?


#15

You can use the http api :

curl -i -XPOST http://hassio.local:8086/query --data-urlencode "q=CREATE DATABASE home_assistant"

#16

Thanks it worked :slight_smile:


#17

Has anyone gotten snapcast or snapserver to work? I know they hadn’t been tested, but I am having trouble setting them up. I get an error saying “Failed to create client: Daemon not running”. Any thoughts??


#18

I didn’t have the time to test and debug snapcast. I’m on holiday but will try to look at it in two weeks.


#19

How do you that?

SSH? or?


#20

Hi!
Every single time I try to play anything in Mopidy I get this error:

WARNING Could not find a MPEG-1 Layer 3 (MP3) decoder to handle media.
WARNING GStreamer warning: gst-stream-error-quark: No decoder available for type ‘audio/mpeg, mpegversion=(int)1, mpegaudioversion=(int)1, layer=(int)3, rate=(int)44100, channels=(int)2, parsed=(boolean)true’. (6)
ERROR GStreamer error: gst-core-error-quark: Your GStreamer installation is missing a plug-in. (12)

Any idea how to fix this?
Thanks!
B