RFLink over WiFi best options

After my first approach to get RFlink talking to HA with the espRFLinkMQTT over MQTT it was working fine but it not really intergrated in HA.
So, I have put RFlink on a Arduino Mega 2650 mini and a Wemos D1 mini with Esp-link on it to do the serial communication over wifi. With this combination the RFlink intergration is as simple as over USB. Just fill in the IP adress and port number and you good to go.
I added a few switches, temperature sensors an two window screens (covers).

This works, but HA only supports one RfLink this way. If you need a second, the only solution I know that works well is espRfLinkMQTT.

probably because in case of serial port somehow the port is ‘captured’ by one of the RFLinks when with MQTT anyone can post and listen :wink:

No. It’s ‘baked’ in the integration to only support one RFLink. There is a topic on it on the forum. Even if I copy all the Rflink files and put them in custom_components, and change all references in the python files from ‘Rflink’ to ‘Rflink2’, as soon as the files are there HA does not start any more.

hmm… any chance to have a link to that topic? :wink:

Here are some :

1 Like

I got it working also but I went the ‘lazy’ route. In node-red I’m sending the raw data received on the mqtt topic to a port which is then connected by rflink from HA.

just on a side note re usb dongles… my server is not in a good place for my usb zwave and zigbee dongles… so I’ve got them plugged into a raspberry pi in the middle of the house and I share the two usb dongles back to my ha server using usbip. Google it, the devices show up like any other locally connected usb device and thus far has worked flawlessly.

1 Like


I’d like to do it this way too, can you point me in the rifght direction please?

Many thanks in advance!

Yes sure.
I took the serial output from the rf link, and send that via mqtt. This is connected to a TCP out link in node red, and from there you can connect HA. but I guess only one is supported like written above.
In node red I don’t know if this limitation

Would you be able to share the node-red flow for this?

Also which program do you use to convert the rflink signal to mqtt?

For the program to convert the signal you can use for example this https://github.com/Phileep/rflink-to-mqtt
Or this https://github.com/SensorsIot/RFLink-MQTT-Gateway

The node-red flow is pretty simple, a mqtt in node connected to a TCP out node. I can share the flow next week if if you want.

Edit. I’m using the second program actually

Has anyone had any success in getting the Arduino Mega, ESPEasy working with Home Assistant for Somfy Blinds? I purchased the kit from Nodo’s website. I’ve flashed my Arduino Mega 2560 with RFLink and i’m able to control the blinds fine. My issue is connecting the NodeMCU. When I flash the ESP8266 NodeMCU with ESP Easy I can access it and it seems stable when I ping it. Once I connnect the NodeMCU to the Arduino it reboots/constantly. Here’s what i’m getting on the serial monitor:

@Glen_Stallworthy, the setup you describe is what I plan to do to control my RTS Somfy blinds. This topic of building an RFLink Gateway using a Nodo Arduino Mega + RFlink PCB 433.42Mhz + Nodo NodeMCU-Wifi-Module seems to be the best way to achieve a strong Wifi RF Gateway.

I can’t find any detailed configuration steps to build it and integrate it into Home Assistant. If anyone can confirm this setup is working and provide a way to integrate properly into Home Assistant wirelessly, that would really help. I don’t mind interacting with the RF Gateway with MQTT as long as the entities can be discovered and appear correctly in Home Assistant.

1 Like

Which port are you using with Esp-Link?

I am desperately trying to configure esp-link with Rflink but I cannot succeed with it. My esp-link is running, rflink integration is done in configuration.yaml, but it seems there is no communication between HA and RFlink…

How did you set this up with esp-link?

If you have the RFLink + ESPLink working then you need to configure it on HA.
There’s a short reference in HA documentation:

Basically you have to configure the ESP connection in HA:

  port: 8989
  wait_for_ack: true

#RFlink covers
  - platform: rflink
        name: cover 1
        name: cover 2

The RFLink docs also explain how to get the device_id for your covers:

Hello @javicalle,

I managed to find a solution. The problem was on the ESP8266 side. The solution was:

  1. Install ESP-Easy R147_RC8 (which is the firmware recommended by Nodo for the NodeMCU)
  2. Set protocol as Standalone (I use this RFLink with covers, I don’t need bi-directional communication)
  3. Create a Device / Serial Server, Define port (1234: same as RFLink integration for HA), Baud Rate 57600, Data Bits: 8, No Parity, Stop bits: 1, no Reset target after boot, Event processing: RFLink.

So the recommended esp-link V2.2.3 firmware in HA integration documentation didn’t work for me. I don’t see how to set a Serial Server in ESP-Link that could do the same as ESP-Easy R147_RC8. If you have more explanation on the subject, I’d be curious to know, but at least, I got this working and I’ll be more than happy not to rely on Somfy servers to control my blinds and covers.

1 Like

I’m not familiar with all the ESP part (and anything related to communications protocol) but maybe that socat command is the piece that you were looking for:

Can you point us to the Nodo’s recommendation? Maybe it can be added to the HA documentation.

Hi @donparlor,

I’ve just revisited this for the first time in a while as I also desperately need it to work. I feel it’s an issue with the ESP8266 for me also. I noticed you got it working using an old firmware version. I’m getting mixed results with different ESP-Easy versions. I tried to find a copy of R147_RC8 but for the life of me I can’t find it. Can you point me in the right direction to obtain a copy of this firmware? If it worked for you, then surely it should be me.

Hopefully going back to R147 will fix it.

Thanks in advance.