Dual Rflinks


I have two Rflinks, one for 433MHz and one for receiving 868MHz. I thought it would not work to connect both to the same Pi, but it does. It shows the sensor values as expected, but at the same time logs an error due to “duplicate key port”. And thats true, I’ve entered both ports in configuration.yaml.
Anybody else tried this setup?

I am considering adding another rflink to my setup, wondering if you could share some knowledge on this. Did it work in the end? Currently I have one 433mhz rflink attached, considering adding another 868mhz.

It worked for receiving, but got messy when sending. I could not control which rflink that should transmitt. I have one Rflink with 433MHz that sends and receives that are connected to HA as usual. The other one just receives at 868mhz, I made a little python script that reads that Rflink and puts out the data via Mqtt for Home Assistant to receive.

thanks for sharing - I am considering changing the code of RFLink to make this work out of the box (i.e. more than one rflink connected for sending and receiving). It should not be that hard. In the mean time, could you share the python script you mentioned?

hi Jeroen, all,

I try to connect also two rflink devices on a Arduino to the Rasp with hass-io.
One is the 433,92 mhz (for KAKU) and the other 433,42 mhz for the somfy covers.

In the configuration.yaml I tried:
#RFlink gateway
port: /dev/ttyACM0
rflink 1:
port: /dev/ttyUSB1

The RTS for the covers is working fine, but the other on ttyUSB1 not.
The home-assisent.log shows nothing when I use some KaKu stuff.

When I connect only one device with the proper usb it works great.

So, how must I put this in the configuration.yaml?


I started working on this, I’ll keep you posted.

Thanks Jeroen :slightly_smiling_face:


I don’t have the config now, but I think I did something like this:

#RFlink gateway
port: /dev/ttyACM0
port: /dev/ttyUSB1

thanks, I have tried it but it didn’t work.
Hopefully Jeroen will figuring something out.
My python is zero and just started with HA.

Did you get an error message, did it not receive anything or what happend?

I have been in touch with the original developer, it seems doable.

I get a lot of python messages. My friend Google could not help me :thinking: Also the database got corrupt.

hi Jeroen,
Thanks for doing this.

Hi Guys

Hs anyone figured this out yet?

I have 433Mhz for most of my sesnor etc but need 868Mhz for some new heaters

I have both a RFlink 443 and 868 devices

My only thought is to do this via a MQTT gateway of sorts rather than direct into Hassio

I’m using a Mqtt gateway for my 868 MHz Rflink, works good. It’s just a rather simple python script that reads the USB serial port, creates a json message and sends it to a Mqtt broker.

All, I am having trouble completing the code for dual RFLink support. Is anyone willing and able to help? Here is the latest version that I made with help of the original dev (who is no longer active in the HA community). https://github.com/jeroenterheerdt/home-assistant/tree/rflink

Hello, anyone got this to work. I just bought a 868 rflink and thought it would work out of the box. just add and go! but that is not the way. google doesn’t help me in any way. I know i’m a noob.

well use RFlink with MQTT https://github.com/dmartinpro/RFLinkGateway
Even better use a esp8266 controll it :slight_smile: https://github.com/seb821/espRFLinkMQTT

1 Like

Did someone got this working with rflink.py?

I did duplicate it and made a custom rflink but it can only receive data.
I’m not able to put the lights out, at least not with second rflink device :slight_smile:

I have tried the esp8266 solution but it seemd to be unstable.

I found a similar python script to that of dmartinpro. This has been stable for several weeks without problems. Only switching multiple RFLink devices at the same time causes problems, but these can be solved with a short timeout.