Rpi 4 installation

what steps have you taken? Are you using Raspbian or Hassos? The easiest way is to go with hassos,
3 steps

  1. go here: https://github.com/home-assistant/hassos/releases/tag/3.5
    pick the version for pi4: direct link
  2. Download belena etcher flash that image to your sd card. You dont need to extract anything. Make sure sd is at least 10gb
  3. Connect cat5 ethernet cable to you pi, plug in sd card. Turn it on. If it’s booting ok the green light should be blinking and red should be solid. Check your router for the last ip it assigned, it will probably will be your pi4. Go to that ip:8123

You should be up and running

I had it running great until I tried to restore from my old pi-3b. Eventually broke home assistant. I forgot how to get into samba, and couldn’t find basic URL info while searching:
My old config was like this:
smb://HASS:DF;[email protected]/workgroup

I also tried to change my new pi-4 IP to the same as my old pi-3. I have tons of MQTT devices and don’t want to change the MQTT server IP’s in 50 devices. Purged old Pi-3 IP from my pihole’s static table, and assigned static to Pi-4. No joy!
Tried to force Static in the Pi. No joy!
Finally I dug up a MQTT device out of my box of stuffs, and assigned it to the Pi-4’s IP. Booted The Pi-4, finally moved over to the IP That I had set static in the pihole DHCP server.

Finally got back to default by deleting hassio from Docker:
“uninstall hassio in docker” (swiped from here)

sudo systemctl stop hassio-supervisor.service
sudo systemctl disable hassio-supervisor.service
sudo systemctl disable hassio-apparmor.service
sudo systemctl daemon-reload

Then execute the following commands to remove all traces:

sudo su
cd /etc/systemd/system
rm hassio-*

After that I purged the Docker containers again.

# Stop all running containers
docker stop $(docker ps -q)

# Remove all containers
docker rm $(docker ps -qa)

# Remove all Docker images
docker rmi -f $(docker images -q)

# A final clean
docker system prune

Noticed that after sending stop several would restart before being deleted. Did a few “rinse, repeats” of the three commands above until “docker stop $(docker ps -q)” came up blank

remove config. This will delete all in share folder, including snapshots. Make sure snapshots are saved externally

sudo rm -rf /usr/share/hassio/

That’s exactly what I did (since it seemed the easiest and most foolproof way to go).
But: nothing!

When turning it on indeed solid red light, and green blinking for some time. But after a while the green light stops blinking. I get nothing. Not on a screen connected to the pi, nor through the <Ip-address>:8123

Only I used the link provided here https://www.home-assistant.io/hassio/installation/
Seems to be version 3.4… So I’ll give 3.5 another shot.

edit: S same result for 3.5… Been trying for hours and hours now. My first experience with Home Assistant, so I must say: so far it’s rather dissapointing… But not giving up yet! (even though I’m not sure what else I should do… Any suggestions??)

Are you sure you are hitting it with the right ip? If you check your router you should be able to find it. Also is the network light on eth port blinking green? You can also try to flash Rasspbian Lite and see if you can ssh into it, then just run the installation script manually

Yes, it’s the right IP. In my router the machine is called Hassio… So, it’s impossible to miss :wink:
The Eth port is blinking.

I finally managed to get something on the screen by uncommenting dtoverlay=vc4-fkms-v3d in config.txt now! Everything seems to start up fine…
I logged in succesfully using root, have the IP address confrimed by using ip addr show

Bingo!! My router gave the device guest access only… No clue why. Connected it to another port and it seems to work

Dear sir,

pi@pi:~/Hassio $ sudo bash hassio_install.sh
[Info] Install supervisor Docker container
[Info] Install supervisor startup scripts
[Info] Install AppArmor scripts
[Info] Run Hass.io
pi@pi:~/Hassio $

i try to modify but not work

arch	armv7l
dev	false
docker	false
hassio	false
os_name	Linux
python_version	3.7.3
timezone	Asia/Bangkok
version	0.98.5
virtualenv	true

This means you are still running a version in python virtual environment…STOP the old instance first.

1 Like

Out of interest does anyone know of a decent case that can also incorporate the SSD ? Surprised that there does not to be anything on the market for this.

Dear sir,

I get error

19-09-17 16:32:28 ERROR (MainThread) [hassio.homeassistant] Home Assistant has crashed!

more information


Do I really need the USB HUB? Is that because of only two USB 2 Ports or is there an additional reason? I intend to rebuild your setup but use the Cyrus USB Z-Wave Plus instead of the Aeotec. I currently have a Pi3 with the Razberry Z-Wave board and less then 10 Z-Wave devices and would like to switch to an USB Z-Wave with the new setup.

you only need the hub if you have Aeotec Zwave stick. The issue is described here. If you have any other zwave stick you don’t need a hub.

1 Like

looks like it’s running ok, can you see the homeassistant docker container running when you do sudo docker ps, try loging into it and running hassio ha start

30e381bcdd26        homeassistant/armv7-hassio-dns:1                  "coredns -conf /conf…"   30 hours ago        Up 30 hours                             hassio_dns
029c51b419c0        homeassistant/home-assistant                      "/bin/entry.sh pytho…"   30 hours ago        Up 30 hours                             home-assistant-homeassistant
59acb273274e        homeassistant/raspberrypi4-homeassistant:0.98.5   "/bin/entry.sh pytho…"   31 hours ago        Up 30 hours                             homeassistant
87103fd0abdc        homeassistant/armv7-hassio-supervisor             "/bin/entry.sh pytho…"   31 hours ago        Up 30 hours                             hassio_supervisor

i try login and type hassio ha start

(homeassistant) homeassistant@pi:/root $ hassio ha start
bash: hassio: command not found

Thank you very much. Thanks to your guide I’ve successfully transferred from rpi3 to rpi4 with all my zwave devices. Works like a charm :wink:

1 Like

I was on pi3 with HassOS + HAssIO and I move to pi4 with SSD and decide to use Rasberian as OS and install HassIO

How is the best way to manage Hass os configs?

here is how I did it from HassOS + HASSIO + SSH Add-on.

When SSD add-on is configured you put your SSH key and you can access your /config.

But for pi4 Hassio command is not working.

Any bits of advice about where to look ?
I want to be able to check and restart config from a console like that:
hassio ha check && hassio ha restart

UPDATE: It seems network-manager package is required for network between containers.

MAC address change fix ( NetworkManager): networking - Ubuntu GNOME 17.04: wi-fi not working -- mac address keeps changing? - Ask Ubuntu

sudo tee /etc/NetworkManager/conf.d/wifi.scan-rand-mac-address.conf > /dev/null <<EOF
sudo service network-manager restart

Now everything is working:

 » ssh [email protected] -p 2424                                                                                      
  _    _                 _
 | |  | |               (_)
 | |__| | __ _ ___ ___   _  ___
 |  __  |/ _` / __/ __| | |/ _ \
 | |  | | (_| \__ \__ \_| | (_) |
 |_|  |_|\__,_|___/___(_)_|\___/

Our Cli:
$ hassio help

core-ssh:~# has
hash    hassio
core-ssh:~# hassio info
arch: armv7
channel: stable
hassos: null
homeassistant: 0.99.3
hostname: pi4
logging: info
machine: raspberrypi4
supervisor: "189"
- armv7
- armhf
timezone: Europe/Sofia

I’m having issues doing a fresh install of hass.io on an existing rapsberry pi.
When running the supervisor docker I’m seeing:

Fails install landingpage, retry after 30sec
Pull image homeassistant/rapsberrypi4-homeassistant tag landingpage.

And indeed, when pulling manually this tag doesn’t exist.

Maybe some error in the script?

Any clues?

PS: just tried with rasperrypi3 as the -m option for the installer script → same result

I got close… but when i went to do the bash hassio_install.sh i come up with this error

[Warning] No NetworkManager support on host.
[Warning] No AppArmor support on host.
[ERROR] Please set machine for armv7l

any tips on setting machine for armv71 ?


To answer my own question, i used

sudo curl -sL https://raw.githubusercontent.com/home-assistant/hassio-installer/master/hassio_install.sh |sudo  bash -s -- -m raspberrypi3

and i now have it running nicely on a Pi4 :slight_smile:

Hello, i’m looking for an installation-method hassio or normale home-assistant to rpi4.
Have some problems and want some advise what is the best manner to do.

  • I have a shim-fan who needs drivers and service-script to install. Can’t get this done on HASSOS image for RPI4. Is/how is this possible?
  • What is the best procedure to install home assistant into docker (portainer-based) on an rpi4?

Read some messages that RAM will not fully used on v4. Is that only on HASSOS image?

Thank for your reply.

I would like also a step by step guide to install hassio on a rpi4 raspbian. The guide https://www.home-assistant.io/docs/installation/docker/ is outdated and for HA, not hassio.