Rpi 4 installation

How can you verify that it is using the SSD in Home Assistant? When I go to Hass.io --> System --> Hardware, it lists disk as


  • /dev/mmcblk0p2
  • /dev/mmcblk0p1
  • /dev/mmcblk0

I posted a guide in this thread if you scroll up, here is a link: Rpi 4 installation

Run findmnt -n -o SOURCE / (you must be sshd into rasbian and not hassio or HA)
it should say /dev/sda1 or sda2 if you are running of SSD.

I posted a link to Rpi4 + SSD guide above, if you followed it, it should work

For the fan to work you probably will need to run Rasspbian Lite + Hassio instead of HassOS+Hassio. If you install Rasspbian Lite you can just install docker then run Hassio script and it will do the rest.

So flash Raspbian Lite using BalenaEtcher

then (taken from my guide above)
Install docker (instructions taken from this thread on docker ) :
$ sudo curl -sL get.docker.com | sed 's/9)/10)/' | sh

Install hassio dependencies (instructions taken from here )
$ sudo apt-get install apparmor-utils apt-transport-https avahi-daemon ca-certificates curl dbus jq network-manager socat software-properties-common

Install hassio borrowed from here

  1. Save hassio installer to file: $ curl -sL "https://raw.githubusercontent.com/home-assistant/hassio-installer/master/hassio_install.sh" >> hassio_install.sh
  2. Run install script: `$ sudo bash hassio_install.sh -m raspberrypi4’
    or you can do raspberrypi4-64 if you are feeling adventures.

… and you are done, HA should be up and running
You can then install portrainer to manage it all if you want.
The 4GB issue only effected HassOS (Not Raspbian) but it’s already fixed so you are good to go

But that shows that Raspbian is using the SSD. Is there anyway to check is Hassio is using the SSD or is it just assumed that since Raspbian is using it, then Hassio must be? Thanks for this guide!

Not that i know off, but hassio is running from docker that’s installed on ssd, I would say you are pretty safe that it’s running on SSD as well. You can run a benchmark to see if you get high numbers to confirm

I found a way to verify it. I have the Glances addon for Hassio. For disk I/O it shows 0 read/write for mmcblk0/p1/p2 and it shows values for sda/sda1.

I’m running Home Assistant in a Python virtual environment (venv) on my Raspberry Pi 4. I’ve also installed an mSata SSD in a USB enclosure, and have migrated the /var and /home folders onto the SSD, so that most of the reading and writing is on the SSD rather than the microSD card. I’ve tried to record what I did here: https://newadventuresinwi-fi.blogspot.com/2019/11/using-usb-msata-ssd-with-raspberry-pi-4.html

I ended up doing a very similar thing to you, but I’m running Raspbian from SSD, I’m only using a 1GB Sd card as a small boot partition.

It does seem quite a bit faster than an SD card, rebooting takes less than 10 seconds.

1 Like

Hi Here are my strange problems related to Buster distribution i think but i am unable to workarround it.
When i am about to make

 curl  -v "https://raw.githubusercontent.com/home-assistant/hassio-installer/master/hassio_install.sh"
 * Expire in 0 ms for 6 (transfer 0xb6f880)
 * Expire in 1 ms for 1 (transfer 0xb6f880)
 * Expire in 4 ms for 1 (transfer 0xb6f880)
 *   Trying
 * Expire in 200 ms for 4 (transfer 0xb6f880)
 * Connected to raw.githubusercontent.com ( port 443 (#0)
 * ALPN, offering h2
 * ALPN, offering http/1.1
 * successfully set certificate verify locations:
 *   CAfile: /etc/ssl/certs/ca-certificates.crt
   CApath: /etc/ssl/certs
 * TLSv1.3 (OUT), TLS handshake, Client hello (1):
 * TLSv1.3 (IN), TLS handshake, Server hello (2):
 * TLSv1.2 (IN), TLS handshake, Certificate (11):
 * TLSv1.2 (OUT), TLS alert, unknown CA (560):
 * SSL certificate problem: self signed certificate
 * Closing connection 0
 curl: (60) SSL certificate problem: self signed certificate
 More details here: https://curl.haxx.se/docs/sslcerts.html
 curl failed to verify the legitimacy of the server and therefore could not
 establish a secure connection to it. To learn more about this situation and
 how to fix it, please visit the web page mentioned above.

If i bypass the verification with -k the file hassio_install.sh obtained contains the web page instead of the the script.
This can be workarounded easily by copying the script in a file but successive curls would mess the installation and driving me mad.
Any ideas, has someone similar issues with rpi4 and buster raspbian??
Something strange is that installing docker worked ok, after installing dependencies like network manager apparmor etc things started to go bad… could be that installation that could have mess the system??

Thanks in advance.

Something doesn’t seem right, it says that the certificate is self-signed. This shouldn’t be the case with a domain like that and if you manually look at their certificate it’s not self-signed. I say you do try to just copy and paste the script and see if it works.

Thanks Skynet01. This is what i did, but then the curls that are in the scripts start failing again…
I have tried to reinstall certs and played with paths, extracting certificates from curls, but it keeps failing.
If i try to remove purge curls and ca-certificates fro reinstalling errors with dependencies and java come and it cannot e done…
What is strange is that i haven’t seen others reporting such issues, and i haven’t done anything different or that may cause that behavior…
Edit: Just after this message i tried again and magic!! all is working, may be a unattended update anyway hassio is preparing right now.

Hey, i followed the steps from the instructions here: https://www.home-assistant.io/getting-started/

When i try to run “hass” the procedure is always freezing at this step:

2019-11-16 01:27:07 INFO (SyncWorker_12) [homeassistant.components.zeroconf] Starting Zero conf broadcast

Will this also be possible using a USB stick like the Sandisk Cruzer Ultra 64GB? Guess the performance won’t be much better than using a SD card, but then at least I won’t have any r/w issues…

So will it boot using a USB stick?

Yeah it should be fine. The pages where i got tutorials from had people do it with USB stick

1 Like

Worked perfectly fine. Thanks a lot!

Followed the above guidelines…but After a reboot my RPI4 connects to Home Assistant ‘without hassio’.

My setup: RPI4 with SSD

-Boot from SSD with this guide: https://jamesachambers.com/raspberry-pi-4-usb-boot-config-guide-for-ssd-flash-drives/

-Install docker curl -sL get.docker.com|sh

-After several attempts, cleaned up old hassio and docker stuff:

sudo systemctl stop hassio-supervisor.service
sudo systemctl disable hassio-supervisor.service
sudo systemctl disable hassio-apparmor.service
sudo systemctl daemon-reload
sudo su
cd /etc/systemd/system
rm hassio-*
docker stop $(docker ps -q)
docker rm $(docker ps -qa)
docker rmi -f $(docker images -q)
docker system prune

Had to a few “rinse, repeats” of the three commands above until “docker stop $(docker ps -q)” came up blank.

sudo rm -rf /usr/share/hassio/
sudo apt-get install apparmor-utils apt-transport-https avahi-daemon ca-certificates curl dbus jq network-manager socat software-properties-common 
curl -sL "https://raw.githubusercontent.com/home-assistant/hassio-installer/master/hassio_install.sh" >> hassio_install.sh
sudo bash hassio_install.sh -m raspberrypi4’ 

Then HA starts and is functioning with all the nice Hassio stuff… but after a sudo reboot, HA starts without the Hassio extra’s

Any suggestions?


pi@hass:~ $ docker ps --all
CONTAINER ID        IMAGE                                              COMMAND                  CREATED              STATUS              PORTS               NAMES
b6f44dcf6c53        homeassistant/armv7-hassio-dns:1                   "coredns -conf /conf…"   50 seconds ago       Up 48 seconds                           hassio_dns
1c91a17024e7        homeassistant/home-assistant                       "/bin/entry.sh pytho…"   About a minute ago   Up About a minute                       home-assistant-YOUR_USER
e3b926d80c8f        homeassistant/home-assistant:stable                "/bin/entry.sh pytho…"   5 minutes ago        Created                                 home-assistant
3b341d745579        homeassistant/raspberrypi4-homeassistant:0.103.4   "/bin/entry.sh pytho…"   14 hours ago         Up 41 seconds                           homeassistant
45184b87ed4e        homeassistant/armv7-hassio-supervisor              "/bin/entry.sh pytho…"   14 hours ago         Up About a minute                       hassio_supervisor

This is the log:

lines 1-19/19 (END)
● home-assistant@YOUR_USER.service - Home Assistant
   Loaded: loaded (/etc/systemd/system/home-assistant@YOUR_USER.service; enabled; vendor preset: enabled)
   Active: active (running) since Wed 2019-12-25 09:29:36 GMT; 6min ago
 Main PID: 909 (docker)
    Tasks: 11 (limit: 4154)
   Memory: 51.9M
   CGroup: /system.slice/system-home\x2dassistant.slice/home-assistant@YOUR_USER.service
           └─909 /usr/bin/docker run --name=home-assistant-YOUR_USER -v /home/YOUR_USER/.homeassistant/:/config -v /etc/localtime:/etc/localtime:ro --net=host homeassistant/home-assistant

Dec 25 09:30:14 hass docker[909]: 2019-12-25 09:30:14 INFO (SyncWorker_19) [homeassistant.loader] Loaded point from homeassistant.components.point
Dec 25 09:30:14 hass docker[909]: 2019-12-25 09:30:14 INFO (SyncWorker_5) [homeassistant.loader] Loaded logi_circle from homeassistant.components.logi_circle
Dec 25 09:30:14 hass docker[909]: 2019-12-25 09:30:14 INFO (SyncWorker_14) [homeassistant.loader] Loaded opentherm_gw from homeassistant.components.opentherm_gw
Dec 25 09:30:14 hass docker[909]: 2019-12-25 09:30:14 INFO (SyncWorker_17) [homeassistant.loader] Loaded neato from homeassistant.components.neato
Dec 25 09:30:14 hass docker[909]: 2019-12-25 09:30:14 INFO (SyncWorker_0) [homeassistant.loader] Loaded huawei_lte from homeassistant.components.huawei_lte
Dec 25 09:30:14 hass docker[909]: 2019-12-25 09:30:14 INFO (SyncWorker_6) [homeassistant.loader] Loaded tplink from homeassistant.components.tplink
Dec 25 09:30:14 hass docker[909]: 2019-12-25 09:30:14 INFO (SyncWorker_18) [homeassistant.loader] Loaded zha from homeassistant.components.zha
Dec 25 09:30:14 hass docker[909]: 2019-12-25 09:30:14 INFO (SyncWorker_9) [homeassistant.loader] Loaded rainmachine from homeassistant.components.rainmachine
Dec 25 09:30:14 hass docker[909]: 2019-12-25 09:30:14 INFO (SyncWorker_11) [homeassistant.loader] Loaded esphome from homeassistant.components.esphome
Dec 25 09:35:59 hass docker[909]: 2019-12-25 09:35:59 INFO (MainThread) [homeassistant.components.websocket_api.http.connection.2992554224] Connection closed by client

Found it! Apparently I had installed https://www.home-assistant.io/docs/autostart/systemd/ … removed /etc/systemd/system/home-assistant@YOUR_USER.service and reloaded systemd. Now the HA is starting up with Hassio each time after a reboot :grinning:

1 Like

I got it installed on a Rpi4 with SSD so easy the other day I used this Re: Running Raspbian on USB Devices : Made Easy burned both images at the same time using BalenaEtcher booted it up then run the usb-boot rebooted then expanded the SSD, did the updates then installed docker/hassio using skynet01 post here.

I used Raspbian with desktop so I could use it with a monitor as I had just HA on it before with a monitor connected and got sick of seeing the console output that didn’t tell me much apart from when restarting HA or shutting it down/booting it up so now I can load HA in a web browser and use conky to monitor the Raspbian side of it but for some reason, conky closes after some time and not sure on why but I am happy with it so far.

Thanks for the guide but I get in HA (dev / info) hassio: false, so no hassio panel nor addons.
Any clue about that?