Set or customize NTP source

I see you’re not getting an answer. I didn’t get any as well. It seems this is a fringe thing, which is weird to me as my HA Core install just basically doesn’t work without internet, and almost all of my stuff is local, not cloud.

i had a older copy of hassos which i booted with ethcer, that works fine booting offline
and i just checked one of my installation is working from last year without any problem with same hassos as mentioned in the picture attached

any idea why ?

Screen Shot 2020-09-21 at 11.07.08 PM

hi, any idea how to do this on a virtual machine? I am running HA on VirtualBox

If you have access to /etc/systemd/timesyncd.conf, it should work the same way. I don’t have experience with an HA virtual machine.

If you upgrade to HassOs 6.1 , there is a check now at boot, so it gets synched correctly… My time was also incorrect before on cold boot when running esxi… Now that’s been corrected

I’m running a datalogger running HassOs 6.2 within a company network. Only struggling with time running out of sync as soon as the logger is rebooted. The company offers their own NTP servers.

Tried the USB method for uploading ‘timesyncd.conf’ but with no avail yet. Together with IT-support I’ll try to go for the method of forcing NTP via an firewall rule that G.G.B.Spender posted.

Maybe anyone is aware of another option to change NTP servers within HassOS that I have missed?

2 post above


there you can change it in HassOS

Thanks for pointing that out, I tried to find ‘systemd’, but I can’t find it using using the SSH & Web Terminal addon in HassOS. I think I’m having some trouble logging in as root, so I will try to figure that out first…

you need to enter in the host itself not with ssh addon, thats not possible…
you are running virtual, right? then you need to go to the console

or use this addon

I have standard HA install, but there is no /etc/systemd folder:

I’m running Hass OS, using the community addon to SSH into the system: Home Assistant Community Add-on: SSH & Web Terminal

Basically seeing the same as @jds, the list is not showing /systemd.

Maybe there is another way to get to that timesyncd.conf file?

Like I said before ,ssh addon doesnt give you access to the HassOs … You need to access the host on port 22222 , not 22 , install the other addon, or access it with the console directly if you attach a monitor

Thanks for pointing towards that port 22222. I am indeed running virtual, an will check out that addon to get into the host system on HassOS.

Last weekend I succeeded uploading an adjusted timesyncd.conf using the USB method. The problem I had earlier lied in the fact that I boot and run HassOS on an SSD. As soon as another USB device is plugged in, it won’t boot from the SSD anymore, but probably attempted to boot from the inserted USB and hanged.

  • Solution for me was to first initiate boot by powering on, and after a few seconds and blinking lights on the Raspberry Pi, insert the USB.
1 Like

it helped me too , thanks

I have an Add-on called chrony which is in Configuration and under Add-ons, Backups & Supervisor. Clicking on the chrony Add-on go to the Configuration tab. You’ll be able to add ntp servers in that list.

Now to see if the ntp is working, I added 2 sensors to the Lovelace UI. They are:-
sensor.last_clock_synchronization which tells you when your machine last did a ntp synch and secondly sensor.date_time which shows the current date time on your system. I noticed on my Raspberry Pi it does an ntp action updating the time +/- every 10 min. When you reboot your device, the 1st time it does this, it thinks the time was set in 1970…which was 50 odd years back. The second time it does an NTP action, you’ll see it says it was done +/- 10 min back…


cant believe it. get rest of th0se commands, this addon save my OS.

Was it January 1, 1970?

Immensely helpful thank you. I’m in a situation where only the organizations NTP server will work. Finally have my ha clock sync’d properly - boot time is drastically reduced as well.

How did you add those sensors? I can’t get my rpi to sync time, even tho the timesyncd.conf has been set correctly, and the servers are pingable from the rpi. Chrony tells me my host time is off by a few minutes, but still no sync.

Hi I was running some shelly devices OK for a while and decided to firewall them from the internet and only allow connection to my HA instance. All was working well until they lost time synchronisation and the local weekly schedules were not triggered anymore.

I installed the Chrony addon and changed my sntp configuration in each Shelly device to point to the HA server for time sync. It initially did not work, and I subsequently found out that this was because the “time zone and geolocation” part of the Shelly settings was on “automatic detection” and it failed (despite having pointed to the local NTP server).

I deactivated the “automatically detect…” box, had the timezone set manually, but left the daylight saving time on “auto”. I also set the longitude and latitude manually.

After reboot the time synced again and it is the right time (winter time). I don’t know if it will work in the longer run or if some cache will expire at some point, but I hope that this will work permanently if it could sync after reboot.

Hope this helps

1 Like