Setup failed for tado


#42

The file has been modified and saved in the original position but without result


#43

Did you restart the docker container?


#44

Yeah don’t seem to have access to the docker container using Hassio on a RPi. Have access SSH via port 22222 using the dev options but still docker command is not recognised, will have to wait for an update I guess.


#45

If you are running HASSIO on a RpI, you won’t be running docker. Just SSH to your RPi, and run:

find / -name "interface.py"

Once you have located the file, simply edit it as above - no nead to worry about docker.


#46

yes with “sudo docker restart f73ed9dce14e”


#47

Can you try copying the file across again using:

docker cp f73ed9dce14e:/config/deps/Python36/site-packages/PyTado/interface.py /media/interface.py

And open the file to see if your changes have saved and transferred properly?


#48

Have tried that, doesn’t seem to find that file, have checked that I am doing it right by searching for a known file and it gets a hit on that but nothing on interface.py. Maybe Hass.io works differently on a Pi?


#49


#50

Hi, I’ve read your solution but no way to find interface.py on RASP Hass.io. any ideas to solve?


#51

Interesting - the changes seem OK. Have you tried restarting HASSIO from the web interface?


#52

Yes, in log:

Setup failed for tado: Component failed to initialize.
14:11 setup.py (ERROR)

Unable to connect to mytado with username and password
14:11 components/tado/init.py (ERROR)


#53

Afraid not - I don’t have a RPi. Others above have found the file on their SD card and edited on another machine - might work? Not sure why you would be able to do that but not see the file through SSH…?


#54

And when you run the docker find command, you only see one instance of the file? Mine was in python 3.7, not python 3.6…


#55

I think the one that was able to find it on the SD was running ResinOS rather than HassOS?


#56

I use Hassio on Ubuntu Server


#57

Hassio 0.89.1, now update tu last version


#58

And there is definitely no file at:

/config/deps/Python37/site-packages/PyTado/interface.py


#59

Same problem with Tado here.
Running hassio on hassos and a rpi.

find / -name "interface.py"

Doesn’t find anything, and in

/config/deps

there is only a lib folder.

in

/config/deps/lib/python3.6/site-packages

there is only
hass_frontend
hass_frontend_es5
home_assistant_frontend-20190203.0.dist-info

any help?


#60

Same here.


#62

I changed the file, but as soon I restart home assistant, the files reverts back to the old and wrong url. So I think we need to save the fix some below:
/config/deps/lib/python3.7/site-packages
but not sure. Can some1 confirm where exactly to place it?