Shelly Plus H&T no Entities since Update to 2022.11.0

Having gone through all settings, documentation and tests I can think of I am pretty desperate.

Before Update to 2022.11.0 I had my Shelly Plus H&T show up as Shelly Integration with the help of MQTT. That worked well, besides the device dropping out of Home Assistant occasionaly, which easily got fixed by putting it into Setup Mode.

With the Udate to 2022.11.0 I could not get Home Assistant to reconnect the device. So eventually I removed the integration and recreated it. That worked without any error message but now it shows no devices or entities:

I realized, that with the new Version Shelly Plus H&Ts are now natively supported by the Shelly Integration using Outbound WebSockets: Shelly - Home Assistant

However despite configuring this, I could not get the Device to show up:
Picture in next post, as Forum allows new users only one Picture.

As you can see, MQTT shows connected, while the outbound WebSocket does not.
However I fail to understand why.
I took a Network Trace on the router sitting between the Shelly Plus H&T and my Home Assistant (running as VM on a Windows 2012 R2 Hyper-V).
I see the TCP Connection establish succesfully but when the Shelly sends its GET Request Home Assistant is ACKing the GET Request on the TCP Layer, but I do not see a HTTP Response. Why??
Instead I see the Home Assistant gracefully closing the TCP Connection !? HomeAssistant Shelly Plus H&T
Trace was taken on the Interface towards the HomeAssitant.
Picture in next post, as Forum allows new users only one Picture.

My HomeAssistant is using https for the WebInterface, but as the Websocket starts with ws:// my guess is, this is an independant protocoll and https Settings do not apply to it. Am I wrong there?

Can anyone provide any clue why the HomeAssistant is closing the Connection instead of responding to the GET Request? Any way how I can get some more verbose logging out of my Home Assistant? (Log files obviously show nothing :-/ )
Does anyone else have these Issues since Update to 2022.11?
Any clue why mqtt stopped working?


Shelly Settings:

Network Trace:


I’ve got the same problem - I’ve got 3 x Shelly Plus H&T and they all do not work with 2022.11.0.


Thanks for Sharing @2tee

@2tee Check this: Shelly Plus H&T not working since Update to 2022.11 · Issue #81798 · home-assistant/core · GitHub

I hope that solves it for you as well.

1 Like

Same problem, no entities were detected first with discovery2 but adding the ws method without TLS made it work. 0.12-beta3 FW on H&T

May I ask how you got the beta update? Thanks!

Did you solve your problem, because i have the same.

Yes, see above.

Pardon, yet I’m missing some basic configurations.

I got out of the box a new Shelly Plus H&T sensor.
Popped in the batteries, and immediately saw it on the Shelly app (android phone).
I connected it to my wifi, and confirmed it is connected.

I added the integration into Home Assistant, yet my HA is showing me “No devices or entitites”.

What basic thing am I missing?
Do I have to configure the device on the Shelly app to use websockets?
I have a “vanilla” HA install… and I don’t have any MQTT.
So I’m unsure if the correct way is via MQTT or RPC over UDP… or another way around?

All help is greatly appreciated!

Since I installed homeassistant version 2024.1.2, the same problem appears with Shelly Plus H&T:
Firmware: 20240105-142929/1.1.1-g68a461a
No devices or entities

The problem seems to be known at shelly,
I found the following explanation on their website: Support : URGENT NOTIFICATION: Gen3 Device Connectivity Issue with Google Home/HomeAssistant. We urgently need to inform you of connectivity issues between Gen3 devices and Google Home/HomeAssistant. Our team is working tirelessly on a solution. We apologize for the inconvenience and appreciate your patience. Home Assistant support - Already Fixed, waiting for January release from HomeAssistant Side Google Home fix - pending the problem:
The connection to shelly-cloud works without errors.

I hope shelly will soon release a new firmware that fixes the problem

1 Like

This worked for me, thanks!