Shopping list

Nothing happens when I tap the microphone icon in the front end. It opens the dialog and writes “Home assistant did not hear anything” and it does not react when speaking. Are some language settings necessary?

1 Like

Do you have the conversation component enabled and configured?

Chrome 60? Set up SSL and access with correct domain name

Yes, I have the following in my configuration.yaml

      - Add {item} to my shopping list


Yes Chrome 60. What must be set?

Set up SSL

Where must I set it up. HA or chrome? Can I see an example somewhere?

Here’s how you can set it up with Let’s Encrypt:

If you want to use a self-signed cert:

or if you have a domain cert:

In order of preference, BTW

Is this necesary for the shopping list to work?

Not the shopping list directly, but the microphone input, I think so. Chrome is less and less permissive over time about websites without an SSL certificate. You can’t share your location, for example, on a website without an SSL certificate. I wouldn’t be surprised if you weren’t allowed to use your microphone either.

100% correct, solved this on GH issues the other day for someone and this was the rationale I used to test it, SSL isn’t enough, valid SSL is required (so not by IP, only by domain name) I think it’s actually to do with the service worker as they require valid SSL…

which of the 3 solutions by rpitera is the one to use for this?

LetsEncrypt is the most popular, I don’t think self signed will work and domain ownership isn’t likely to be an option if you’re using freeDNS services

okay thanks… I will try it out :slight_smile:

Instead of using voice, I plan to add stuffs to the shopping list using service call. I know I can turn on/off lights using this…

    - service: conversation.process
        text: "Turn office light on"

it works. But when I change the text to “Add milk to my shopping list”. I don’t see milk in the shopping list. Yes, I did add this to my config…

      - Add {item} to my shopping list

1 Like

Having the same problems here. I am running SSL and I can trigger actions via voice. But I don’t see anything when trying to add to my shopping list.
Any updates on your end @masterkenobi

I managed to make it work, and now from my android phone I can add items to the shopping list!.

But… but now I can’t mark them as completed (If I click the check box it reset to blank immediately). So there is no way to clear the list. Is there a command to mark complete and item? or to remove it from the list?. I’m running HASS version 0.53.1.

1 Like

I’ve the same issue after upgrading to version 0.55.
Everything worked very well in version 0.50.2

It’s something related to the version of Chrome.
Solved with a double tap on the item :slight_smile:

Just wondering - what are the supported languages? Tried to use russian intent and get an error in the log like below
Is there a way to integrate it with to use it’s multilanguage support?

Traceback (most recent call last):
  File "/srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages/aiohttp/", line 422, in start
    resp = yield from self._request_handler(request)
  File "/srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages/aiohttp/", line 306, in _handle
    resp = yield from handler(request)
  File "/usr/lib/python3.4/asyncio/", line 143, in coro
    res = yield from res
  File "/usr/lib/python3.4/asyncio/", line 143, in coro
    res = yield from res
  File "/srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages/homeassistant/components/http/", line 58, in ban_middleware_handler
    return (yield from handler(request))
  File "/srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages/homeassistant/components/http/", line 430, in handle
    result = yield from result
  File "/srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages/homeassistant/components/", line 197, in post
    intent_result = yield from _process(hass, text)
  File "/srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages/homeassistant/components/", line 134, in _process
    in match.groupdict().items()}, text)
  File "/srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages/homeassistant/helpers/", line 44, in async_handle
    raise UnknownIntent()