SkyConnect plugged... no response. Help needed


I just plugged the SkyConnect to my MiniPC running a fresh HA. Nothing happens. If I look at the Hardware-page, I have no entry “SkyConnect”. If I try to activate ZHA, I can choose a “/dev/serial/by-id/usb-Silicon_Labs_CP2102N_USB_to_UART_Bridge_Controller_ae51a71b619ced11a5ed7dfaa7669f5d-if00-port0”. This works, so I think this is the Stick. If I open the “show all Hardware” I see this one, additional infos after this text. So what can I do to have the entry in the Hardware section? Without this I can not activate the Thread Support, but this is the reason I bought it. I set up a new HA installation with this, to try this out. So I’m free to do a refresh or whatever may help. An yes, I tried all 4 USB-ports, I restartet HA and the whole PC.

Thank you!


Here the complete hardware infos I got:

DEVNAME: /dev/ttyUSB0
DEVPATH: /devices/pci0000:00/0000:00:14.0/usb1/1-1/1-1:1.0/ttyUSB0/tty/ttyUSB0
ID_BUS: usb
ID_MODEL: CP2102N_USB_to_UART_Bridge_Controller
ID_MODEL_ENC: CP2102N\x20USB\x20to\x20UART\x20Bridge\x20Controller
ID_PATH: pci-0000:00:14.0-usb-0:1:1.0
ID_PATH_TAG: pci-0000_00_14_0-usb-0_1_1_0
ID_SERIAL_SHORT: ae51a71b619ced11a5ed7dfaa7669f5d
ID_TYPE: generic
ID_USB_MODEL: CP2102N_USB_to_UART_Bridge_Controller
ID_USB_MODEL_ENC: CP2102N\x20USB\x20to\x20UART\x20Bridge\x20Controller
ID_USB_SERIAL_SHORT: ae51a71b619ced11a5ed7dfaa7669f5d
ID_USB_TYPE: generic
ID_USB_VENDOR: Silicon_Labs
ID_USB_VENDOR_ENC: Silicon\x20Labs
ID_VENDOR: Silicon_Labs
ID_VENDOR_ENC: Silicon\x20Labs
MAJOR: '188'
MINOR: '0'
TAGS: ':systemd:'

My Skyconnect was part of the mid November batch from ameriDroid with the same issue you are describing. They should be reporting themselves as ID_SERIAL: Nabu_Casa_SkyConnect…

I just reached out to ameriDroid and will post the results.

I also had one of the bad Nov batch devices. The box was labeled “S/N 242303”; apparently some other devices with a similar serial number were affected. Someone from Nabu Casa told me how to assign the correct device name.

  1. Install Advanced SSH add-on, disable Protected mode in the add-on settings.
  2. Connect to SSH terminal and run:
# Enter the OS container (make sure "Protection mode" is disabled in the addon)
docker exec -it homeassistant /bin/bash

# Build `cp2102x-cfg`
apk add alpine-sdk libusb-dev
git clone
cd cp210x-cfg

# This command should list only a single device
./cp210x-cfg -l

# Finally, program it.
./cp210x-cfg -N 'SkyConnect v1.0' -C 'Nabu Casa'

# Unplug the SkyConnect and plug it back in. You should see a SkyConnect entry here when using the below command
ls -l /dev/serial/by-id/

I received the same instruction from Nabu Casa and can also confirm this updates the device so it is recognized in the hardware section to enable multiprotocol.

I have the same Serial on my box. I followed the instruction, but I got some warnings while make (installing and clonig repo without problems). So I tried to continue, the config says “unplug to take changes have effect”, but after replugging I still see the “old” silicon labs entry.

Any chance to this is solved in one next HA updates? So I would wait…


Here the console

homeassistant:/config/cp210x-cfg# ./cp210x-cfg -l
ID 10c4:ea60 @ bus 001, dev 003: CP2102N USB to UART Bridge Controller
homeassistant:/config/cp210x-cfg# ./cp210x-cfg -N 'SkyConnect v1.0' -C 'Nabu Casa'
ID 10c4:ea60 @ bus 001, dev 003: CP2102N USB to UART Bridge Controller
Model: CP2102N QFN24
Vendor ID: 10c4
Product ID: ea60
Name: CP2102N USB to UART Bridge Controller
Manufacturer: Silicon Labs
Serial: ae51a71b619ced11a5ed7dfaa7669f5d
Use internal serial: 1
ret: 678
IMPORTANT: Device needs to be replugged for some changes to take effect!
homeassistant:/config/cp210x-cfg# ls -l /dev/serial/by-id/
total 0
lrwxrwxrwx    1 root     root            13 Dec  3 20:36 usb-Silicon_Labs_CP2102N_USB_to_UART_Bridge_Controller_ae51a71b619ced11a5ed7dfaa7669f5d-if00-port0 -> ../../ttyUSB0

After replugging... the same

homeassistant:/config/cp210x-cfg# ls -l /dev/serial/by-id/
total 0
lrwxrwxrwx    1 root     root            13 Dec  3 20:38 usb-Silicon_Labs_CP2102N_USB_to_UART_Bridge_Controller_ae51a71b619ced11a5ed7dfaa7669f5d-if00-port0 -> ../../ttyUSB1

just did this but still not automatically detecting any help?

edit: and still no multi thread option in the hardware menu?

How is HA installed ?

Thank you for responding! HA OS on Green.

Sky connect is a ZigBee stick. It’s not going to recognise Zwave devices.

Very sorry, I’m already aware that Skyconnect supports ZigBee, not Z-wave, I see that I have made a mistake in my post relating to Z-wave, I should not have posted a Z-wave related issue here but I do have the same serial number (S/N 242303) Skyconnect as others here (for some reason?), that also cannot discover ZigBee device(s), I just returned my “only” ZigBee bulb for now and turn focus on what has been more of the same type of issues, I cannot add Z-wave devices, I do have a Aeotec 7 Plus.

Doesn’t Skyconnect also support Thread (Beta)?