Smappee sensors no longer working

Since I installed the new Smappee integration I no longer have a solar sensor and new sensors like:
sensor.XXX_line_voltages_a and b and c.
sensor.XXX_phase_voltagees_a and b and c

all show as state “unknown”

In my config I have the two required client_id and client_secret and deleted username and password.
Does anyone have the same issues and possibly a solution?

@Trouble-51, I have, I think, the same problem.
From your question I can’t deduct if you have still some other smappee sensors working?
In my case all my smappee sensors don’t work anymore, all have the message:
Entity not available: sensor.smappee_myhouse_power_today

Before the update to 0.112, I had a working smappee screen.
After the update and after the instructions to add the new smappee integration, logging to the smappee website, I have now in the log file following error:

Logger: homeassistant.config_entries
Source: components/smappee/
First occurred: 7:27:48 PM (1 occurrences)
Last logged: 7:27:48 PM

Error setting up entry Configuration.yaml for smappee

Traceback (most recent call last):
  File "/srv/homeassistant/lib/python3.7/site-packages/homeassistant/", line 220, in async_setup
    hass, self
  File "/srv/homeassistant/lib/python3.7/site-packages/homeassistant/components/smappee/", line 67, in async_setup_entry
    await hass.async_add_executor_job(smappee.load_service_locations)
  File "/usr/lib/python3.7/concurrent/futures/", line 57, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/srv/homeassistant/lib/python3.7/site-packages/pysmappee/", line 40, in load_service_locations
  File "/srv/homeassistant/lib/python3.7/site-packages/pysmappee/", line 73, in __init__
  File "/srv/homeassistant/lib/python3.7/site-packages/pysmappee/", line 137, in load_configuration
    self.mqtt_connection_local = self.load_mqtt_connection(kind='local')
  File "/srv/homeassistant/lib/python3.7/site-packages/pysmappee/", line 414, in load_mqtt_connection
  File "/srv/homeassistant/lib/python3.7/site-packages/pysmappee/", line 245, in start
  File "/srv/homeassistant/lib/python3.7/site-packages/paho/mqtt/", line 937, in connect
    return self.reconnect()
  File "/srv/homeassistant/lib/python3.7/site-packages/paho/mqtt/", line 1071, in reconnect
    sock = self._create_socket_connection()
  File "/srv/homeassistant/lib/python3.7/site-packages/paho/mqtt/", line 3522, in _create_socket_connection
    return socket.create_connection(addr, source_address=source, timeout=self._keepalive)
  File "/usr/lib/python3.7/", line 727, in create_connection
    raise err
  File "/usr/lib/python3.7/", line 716, in create_connection
OSError: [Errno 101] Network is unreachable

Do you have in your logs also errors?
And what means the error? Is the smappee cloud webapi unreachable?
I did read that there is a monthly fee to pay to use this cloud webapi, so that could be the problem…

Some more documentation could help :frowning:

An update.
After installing the 0.112.2 version, the logerror is gone and I have 35 new smappee sensors.
Smappee - Home Assistant

Now I have the situation like you are describing.
In my case a little step forward.

I installed 112 and the new smappee integration. Everything worked until the 112.1 and 112.2, now all are unavailable. Is this a bug?

All my sensors are now giving unavailable


Log Details (ERROR)
Logger: homeassistant.config_entries
Source: components/smappee/
First occurred: 4 July 2020, 18:22:07 (1 occurrences)
Last logged: 4 July 2020, 18:22:07

Error setting up entry Configuration.yaml for smappee
Traceback (most recent call last):
File “/usr/src/homeassistant/homeassistant/”, line 220, in async_setup
hass, self
File “/usr/src/homeassistant/homeassistant/components/smappee/”, line 67, in async_setup_entry
await hass.async_add_executor_job(smappee.load_service_locations)
File “/usr/local/lib/python3.7/concurrent/futures/”, line 57, in run
result = self.fn(*self.args, **self.kwargs)
File “/usr/local/lib/python3.7/site-packages/pysmappee/”, line 19, in load_service_locations
locations = self.smappee_api.get_service_locations()
File “/usr/local/lib/python3.7/site-packages/pysmappee/”, line 18, in wrapper
return func(*args, **kwargs)
File “/usr/local/lib/python3.7/site-packages/pysmappee/”, line 62, in get_service_locations
File “/usr/local/lib/python3.7/site-packages/requests/”, line 941, in raise_for_status
raise HTTPError(http_error_msg, response=self)
requests.exceptions.HTTPError: 401 Client Error: Unauthorized for url:

These are the states

sensor.casa_girassol_always_on_active_power unavailable
sensor.casa_girassol_always_on_today unavailable
sensor.casa_girassol_line_voltages_a unavailable
sensor.casa_girassol_line_voltages_b unavailable
sensor.casa_girassol_line_voltages_c unavailable
sensor.casa_girassol_phase_voltages_a unavailable
sensor.casa_girassol_phase_voltages_b unavailable
sensor.casa_girassol_phase_voltages_c unavailable
sensor.casa_girassol_total_consumption_active_power unavailable
sensor.casa_girassol_total_consumption_current_hour unavailable
sensor.casa_girassol_total_consumption_last_5_minutes unavailable
sensor.casa_girassol_total_consumption_reactive_power unavailable
sensor.casa_girassol_total_consumption_today unavailable

same problem here… :frowning:


Does @bsmappee have an idea?

The Smappee integration has changed from local polling to cloud based. Using the API requires you to pay a monthly fee now…

And they do this without any notice and no mention in the notes to the 0.112 upgrade?? Very customer unfriendly business model!

1 Like

@Trouble-51, today I have the same error :frowning:

It is indeed a very customer unfriendly business model. I’ve been a smappee customer for a long time, I own one of their first models, the time where you had to do the installation yourself…
I don’t like being put in front of a ‘fait accompli’.

What do you think about this @frenck ?
The previous integration did use the local webapi and without any documentation or warning it is changed to a paid cloud version?
Or am I wrong and it is just a temporary ‘network’ problem?

Any way to go back? Why is this implemented in home assistant without notice. I had fait in an improvement when upgrading. It was mentioned in the blog like that. :sob:

1 Like

You can download HA source code for release 0.111.4 here:

Unzip it, and in the component folder, copy the Smappee folder and paste it in your config/custom_component folder. It should work until something broke.

I agree with @evb, it should have been a breaking change and mentioned in the release note. And the HA core team should tell us why they let a manufacturer change a working local integration by a paid cloud one. That’s no more “local control and privacy first”.

You can always use MQTT for the local readings of your smappee

@gieljnssns, I will give it a try. It should be easy, I already use MQTT for my MySensors. I will report back. Thank you for mentioning!

I emailed Smappee and they asked me to report it as an core issue which I did. They said that the integration only works with Infinity and conceded that they should also have an option for the other Smappee products. So let’s see what happens

1 Like

@gieljnssns, mqtt will only work with the Infinity. Previous models has no mqtt possibilities. :frowning:

I think that’s not true.
I have this model
The smappee solar and i have mqtt.

Configure in http://“smappee_ip”/smappee.html
Advanced settings

Since the troubles with the new Smappee component, I decided to remove the whole component.
As I said earlier, I use Smappee with MQTT.

This are my MQTT sensors (Voltage, Power: total, L1, L2, L3, Solar: total, L1, L2, L3, Standby Consumption and Cosinus Phi)

The only values ​​that I do not get via mqtt are the totals in kWh, so I have to calculate these via Riemann sum integral
You can find them here

I have a few template sensors to check whether I am using or generating more energy
The most important is eigen_verbruik, this is the energy that I suddenly consume while it is being generated

Then I have some utility_meter over here

As last, I use MQTT switches to track the state of my smart plugs and template switches to change the state

1 Like