Smappee sensors no longer working

@gieljnssns, ok, but I was one of the early adopters, so I have a model MonitorE1 or SmappeeT


Mqtt is not supported for my model :frowning:

Oh, wait, there was an advanced checkbox, not checked. I checked it and now I see the entries for a mqtt local broker :slight_smile:
I will try this.

:+1:t2:
Then you need something like MQTT Explorer to find your service_location

The integration still supports all kinds of Smappee monitors. The idea behind the renewed integration is to also support the newer models and have an additional number of entities in HA. However some issues have been opened about the older series and are being fixed.

1 Like

The issue regarding Homekit and voltage sensors has been located and fixed, the PR awaits approval. With the in house implementation of the renewed integration we aim to get the most out of all the monitors and are definitely open for suggestions.

@bsmappee, maybe it is a good idea to clarify the whole smappee integration in home assistant?

  • explaining why the configured local smappee sensors are not working anymore after the update to the new smappee integration. If I understand correctly your answer, the integration can/will poll still the local smappee possibilities and not work completely only on the cloud api or am I wrong?
  • clarify the fog around the web cloud apis and the mentioned paid cloud apis?
  • besides the correction for the voltages sensor problems, the integration did work in my case for one day, but now I see the mentioned error : HTTPError: 401 Client Error: Unauthorized for url: https://app1pub.smappee.net/dev/v3/servicelocation

About your question that you are open for suggestions, I can only respond that I had a working smappee integration before the update and after the update, I have only not available sensors :frowning:

Just to let everyone know, this is the email i got from the help desk of Smappee, hence my reference to infinity:

Hi Jos,

I’ve discussed it with the developpers.
The best (and fastest way) would be to log an Issue regarding this on “https://github.com/home-assistant/core/issues”.
By pressing " New Issue " and selecting " Report a bug with Home Assistant Core " you can report the issue to the developpers.

“sensor.casa_girassol_line_voltages_a unavailable
sensor.casa_girassol_line_voltages_b unavailable
sensor.casa_girassol_line_voltages_c unavailable
sensor.casa_girassol_phase_voltages_a unavailable
sensor.casa_girassol_phase_voltages_b unavailable
sensor.casa_girassol_phase_voltages_c unavailable”

For the sensors above it is however normal to be unavailable, because you have a Smappee Solar.
These sensors were designed and can only work with Smappee Infinity.
Our devs are working on a version thats skips these when you have a Smappee Solar. (because it is indeed not very clean that these are shown as well)

"
sensor.casa_girassol_always_on_active_power unavailable
sensor.casa_girassol_always_on_today unavailable
"

These should work however.

Best regards,

Mathias
Smappee Support Team

@gieljnssns, can I first congratulate you on your clear configuration setup in your home assistant installation?
Many people can learn from it, including me!

With this method of working, using the build-in MQTT client, I can recreate mostly of my existing smappee configuration. Like said, luckily, I already had an MQTT broker running for MySensors, otherwise it is some supplementary work to get one running.

Only the water and gas sensors are not directly possible. I see them as configuration in the mqtt, I can see the temperature, the humidity and the battery level of the sensor.
Probably I must work with the params index0Delta and index1Delta and do the sum per day myself…

Knowing that everything worked before the update, this is a bit unfortunate. But of course better than nothing at all.
Thanks very much.

@Trouble-51, are your other sensors working again?

Mine are still giving the message unavailable and still the error about HTTPError: 401 Client Error: Unauthorized for url, in the logfile.

Thanks
If you have some questions, just ask…

For the water and gas sensors, you can compare the data in MQTT-Explorer and your smappee app

So are mine. My understanding is that the development team is working on an updated version. see:

there will be a fix in update 0.112.4, lets see whether that solves the problems

Does anyone know if you can control the Smappee plugs via mqtt? My understanding of mqtt is limited, but if I understand correctly the monitor only mqtt information to a server. It doesn’t receive commands. Correct me if I’m wrong.

I’m still rather disappointed that the devs chose to support an integration built by the manufacturer that forces you to pay for access to the api, or settle for a lesser integration with more complications to set up. Especially with it being so nonchalantly glossed over in the release, no prior mention of it anywhere in the blog or forum, and nothing being wrong with the previous integration (from what I can tell from reviewing prior logs). It’s also in poor taste (though I’m not surprised) at smappee somewhat sneaking in their written integration and pretty much all but abandoning older hardware. The monitor was not cheap and to abandoning it in less than 2 years is crap.

@jamieboy05
Smappee sensors no longer working

1 Like

@gieljnssns thank you! I hadn’t had time to completely read through the posts yet.

Currently the API credentials are needed to complete the Smappee integration setup. We use a combination of local and cloud API/MQTT to have the best of both worlds without the need to browse for IP addresses, activating MQTT hosts, etc. Our latest Smappee series are cloud only, so this is mainly the reason why we decided to have a cloud only HA integration and still keep support for the first series.

The errors mentioned in this thread should be resolved with the latest patch release 0.112.4. Only the 401-errors will be resolved upon 0.112.5.

We are looking into the possibilities to implement a local only based integration (without the need to have or enter API credentials) that will discover all Smappee monitors on the network. Of course this will limit the number of entities.Smappee sensors no longer working

@bsmappee, thank you for your answer.
Let’s update then and see :slight_smile:

I’m leaving now on holiday, so let’s hope that the new version is there when I return.

It is being pulled. We have changes standing by for 0.113, which aren’t compatible with the builds for 0.112.5. We have decided the risk for fixing this now is to high for a patch release. As a result 0.112.5 will only be available for people using the Home Assistant Core installation method.

but i have home assistant and not home assistant core.
how can I solve the smappee token problem that expires in the meantime of the release of 0.113?

I still don’t think that @bsmappee answered all of these questions? More specifically

  • clarify the fog around the web cloud apis and the mentioned paid cloud apis?

Is it required to purchase access to the cloud api? And if it is NOT required, how do you setup access to the api without using MQTT.

Is it required to purchase access to the cloud api?

Smappee cloud API credentials are subscription based. With the renewed Smappee integration (HA 0.112) those cloud api credentials are required to complete the setup. However, to give back support for the legacy devices we immediately started implementing a local discovery feature (either by network scanning or manually entering the IP address of the device) without the need to enter cloud API credentials (see https://github.com/home-assistant/core/pull/37812). We hope to get this feature released with HA 0.113 and afterwards keep extending the integration by all needs, requirements and feedback provided.

And if it is NOT required, how do you setup access to the api without using MQTT.

Currently (0.112) this is not possible, but the local only option (API on the device itself) will be re-added.

1 Like