[solved by removing spaces in code] Double press on IKEA E1524 (5-button remote) is now single press!?

I’m using 2 of these remotes to primarily control LMS (but also lights).
A single press is used to toggle mute/unmute whereas a double press is used to toggle play/pause LMS, this has worked without any problems.

Since a few days however, a double press responds as a single press (in the history as well) on both remotes.
I’m using @epmatt his blueprint for this remote and the ‘(Optional) Expose center button double press event’ is still activated + the action to run on double press still works when executed manually.

Has something changed in the recent HA version which could cause this?
BTW: I’m using z2m

There were significant changes to firmware and the Z2M ‘quirks’ file in 2023-03, but I don’t know about recently:

My 5-button remotes are showing Firmware: 0x24040005, which is unchanged since February.

After a look at the Github notes for the ‘quirks’ file, the definitions are still there for LONG_PRESS, but no signs of double press?:

If this helps, :heart: this post!

1 Like

Hi James, thanks for picking this up!

Regardinng FW:

  • HA shows: Installed version - 587286065 | Latest version - 604241925
  • z2m shows: Firmware build date - 20190401 | Firmware version - 2.3.014

It’s not that long that I’m running z2m (was running deCONZ before and OTA was off) and this info about FW and updates is revealed so obviously.
I was already wondering if updating FW is advisable if there are no issues and most of all: where can I find information about these FW updates

I just thought of checking the z2m log to see what is reported with a double press: surprisingly it’s logged as a toggle action.
How is this possible when I’m still using the same version of z2m? :roll_eyes:

In case anyone bumps on this with the same problem: the explanation & solution is in this post.