Home Assistant Community

[Solved] Cannot login after 0.88.1 upgrade

#1

Recently upgraded to Home Assistant 0.88.1 and can no longer login to the webui. All other services seem to be working fine (automation, integration, etc).

This error is displayed in the UI:
image

Logging in with Home Assistant Local.
Error: Message format incorrect: required key not provided @ data['redirect_uri']

Error from log:

ERROR (MainThread) [homeassistant.components.http.data_validator] Data does not match schema: required key not provided @ data['redirect_uri']

Anyone have suggestion on how to fix this. Nothing turned up the change log about authentication changes in 88.x.

1 Like

0.89: Nissan Leaf, PlayStation 4, Point alarm control, Owlet baby monitor
#2

I’m having the same problems. It seems to login fine from newer Chrome installs, but Firefox and an version of Chrome on an old Android device fail with the same error.

0 Likes

#3

I have the same issue. Trying it with Firefox.

0 Likes

#4

Same issue here, it is driving me nuts :stuck_out_tongue: my old ipad 3 can no longer display TileBoard. Occassionally it will accept the login but will get logged out eventually after a few hours/minutes (but that is the normal behaviour). I don’t know what to do here, it works fine on newer browsers (safari on ios and firefox for example) but it won’t work (anymore) on older ios versions. The log doesn’t show more than what the OP has said already. The Home Assistant app for ios works fine though, but I use TileBoard as older ios versions can not display custom lovelace cards.

Edit: auth has changed in HA 0.89 and the http way of adding trusted networks has been deprecated. I have installed HA 0.89 (warning is in beta) and it looks like the problem has been fixed, at least it seems to work fine now in my case.

0 Likes

#5

It is interesting that when I try it home, I have this error. When I tried to connect when I am outside of my house, it works.

0 Likes

#6

Any dev around here can chime in on a potential cause of the login failure? Or does this warrant a bug request on git?

0 Likes

#7

I have answered on this topic here Anyone using an Apple device with success?

0 Likes

#8

Odd that the screenshot does not show your HA address…
image
That must have something to do with the error.

Does this explain why he is having an error with 0.88.1 though?

0 Likes

#9

You are right, doesn’t explain the problem. I actually don’t know what the problem is, I had the same problem as OP but only on older devices where it needs to serve the ES5 frontend. The logs show nothing strange until you try to login where it will give this error, it does this for trusted networks and for standard logins (I have tried API as well but gives the same error) only standard login passes occasionally if you try long enough. I had updated to the beta version of HA and that fixed the problem for me, but indeed I do not know why he (and others) have this problem, but I am guessing it has something to do with the auth config.

0 Likes

#10

Maybe browser version. I know current versions of Firefox don’t play nice with some custom cards. Perhaps javascript: latest?
I keep all my stuff up-to-date and no problems.
Perhaps also a hard-reload and delete cache… Seems to be a fairly frequent thing to do to clear problems although for me, now I’m not using /local/ for custom cards anymore but switched to /customcards/ I haven’t had so many cache issues.

You know sometimes with my iPad, chrome or iOs App (maybe both) sometimes I get the logon screen but if I refresh or close the app and re-open, it loads al auth’ed again using the old token… I can’t explain why it tries to make me log in again but then will login by refreshing.

This is actually a reason I never bothered with trusted networks because I can stay logged in for weeks without having to re-authenticate all the time so using trusted networks seemed unnecessary to me.

0 Likes

#11

I only had this problem in 0.88.x, therefor I think it is version related (as more have this problem since this version). But I don’t know, sometimes indeed my ipad stays logged in for a day or so and sometimes it gets logged out the moment the page refreshes. Though I tried hard resetting the cache on my ipad (for as far that is possible) and it didn’t seem to fix it, it kept throwing errors. I tried multiple browsers and even ones like puffin which usually would render the page on their servers before serving it back to you all the same problem, the ios app however is working fine.

It is working flawlessly now though on the beta, but the changelog doesn’t show much information on what has changed exactly (or I haven’t found it yet), I just tried it and it seems to work now. Local and Trusted Networks are both working on my ipad now. Honestly I would just need to upgrade my ipad to one that can run ios 12 (which can display my lovelace interface).

0 Likes

#12

Check out my token creation and expiry dates…


Sometimes I log out and make it so the google token and ios ones are down the bottom… I was mucking around with the beta app last weekend otherwise the token would be weeks old.

0 Likes

#13

Adding link to git issue #17528.

0 Likes

#14

Hello I’m new and I’m getting same issue, however I’ve only recently installed the DuckDNS addon for Hassio and enabled HTTPS.

I’m able to log fine on newer devices and newer browsers, but on my older iPad I get the following error:

This also stops be using Tileboard on my ipad, but even the normal HA page won’t let me login.

Here’s my url of the page with the error with my domain redacted:

https://xxxxxxxxxxxxx.duckdns.org:8123/frontend_es5/authorize.html?

After going over to HTTPS from HTTP is it recommended to clear all Auth tokens on all devices and log in again and create new tokens?

I read thru all of the DuckDNS addon docs and it made no mention of it.

EDIT just to clarify, I was able to login OK without SSL over HTTP, but since going over to HTTP I’m unable to login on older devices.

0 Likes