SOLVED Tuya: Can't Link Devices By App Account: Data Center Error

I have been previously unsuccessful with the pre-2021.11.0 Tuya integration but thought I’d give it another try with the core-2021.11.0 update. I’m still having trouble.

I am using the Smart Life mobile app (iOS). I can see and operate the dimmer for my patio lights in the app. I have entered my home address into the app (I’m in the Eastern US), so it knows my location.

When configuring on the the Tuya IoT Platform site, I have tried indicating that my Project is in the (a) Eastern America Data Center, (b) Western America Data Center, and (c) both data centers.

I follow the instructions to configure the new Tuya integration and get to the steps for Link Devices by App Account. At step 3, I use the Tuya app to scan the QR code that appears. And that’s where I always see the error “You cannot scan the QR code to add a device deployed in another data center.”

My three Project attempts are listed on the Tuya site. I’d delete them and start over, but there doesn’t seem to be a way to delete.

Suggestions most appreciated.

1 Like

Same issue here, but with Europe data center.
Actually selecting all 6 data centers doesn’t help.
Tuya used to work, but doesn’t anymore (login error 1106), that’s why I tried to relink my app.

My tuya integration is not available either, same error when I try to re-add it, error 1106

Error 1106 is an error with Tuya, not HA. They are working on it.

Right, I assumed as much. But it is an HA “bug” insofar that an old, working integration is being replaced in HA with one that does not work.

It worked well yesterday, my guess is Tuya made some kind off change today and that needs to be fixed.
Certainly not the fault of the HA folks, so I appreciate them working on it !

1 Like

So, basically, I have discovered 2 things.

  1. I used to work with the HACS “tuya v2”, that one doesn’t connect anymore, I switched back to the ‘official’ Tuya integration which connects;
  2. Some data centers changed and the logic is akward: f.i. France, Belgium, Netherlands are considered “Central Europe” and not “Western Europe”
    Mappings Between OEM App Accounts and Data Centers-Documentation-Tuya Developer

THIS was the answer I needed. I thought I had tried Western America Data Center by itself, but evidently I had not. When I removed Eastern and just used Western, I was able to complete the Add App Account steps.

Thank you very much.


I tried each data center one by one until one worked. You can’t put all in at the same time. This new Tuya integration seems to be fare more complicated to get working than the old one.


Yeah, This is kind of ridiculous on a couple of points! Mainly have an api that links with the app and get rid of this developer account shit that changes daily ( I know that’s Tuya). Honestly this shouldn’t be accepted as an official integration. This just bad for the home assistant platform. If it’s official then it should be air tight this is clumsy AF to say the least.

1 Like

Thanks that did work for me! Appreciate you taking the time to post.

I have read through all this and I just cannot get it to work. I have tried every data center with no luck. Now when I try to add my Tuya App account, it gives me a message that I already have two linked devices, when in fact the IoT platform says I have 0 linked accounts and 0 linked devices. It just seems to me that the IoT platform is the problem. Is using their platform the only way to link Tuya to HA? So sad if it is.


I have moved to Local Tuya, works pretty ok

I am having the same issue, did you ever get it working?

Same issue here

ive tried everything on here and mpore and nothing says:

Failed to bind App Account to the project, possibly due to the following reasons.

  1. This App account has already been bound to the project

  2. You have not selected a data center that matches your account. If you don’t know the data center of your account, please check App account data center distribution.


I dont believe i just worked it out, you have to add a user under the user section of the project and put the tuya email and password in then once a user is created the app logged in under central europe.

1 Like


I also want to switch from Tuya to LocalTuya, but I need to find out the local keys for all my devices. Apparently to find out the local keys, I need to do this whole linking account dance in the Tuyo IoT Dev platform which as with you doesn’t work, same error, the data center is correct however

So I’m stuck. I really want to move away but can’t get to the local keys. The Tuya integration is still working in my HA and I can see and interact with all my devices, so is there some way I can get to the local keys?

Are you using the latest Local Tuya?
The dancing around on Tuya IOT platform is unavoidable I am afraid

yes localTuya newest version, just installed it today from HACS