Somfy / Bali / Graber / Springs Window Fashions RSZ1 Stall Issue

Continuing the discussion from Bali RSZ1 Z Wave blinds (aka Somfy, Graber, Spring Window fashions) failure after opening:

Hello - I am new to the HA community - moving over from HomeSeer (HS4). I have a decent amount of experience in home automation in general, but only a few weeks with Home Assistant. I am loving it so far!

I ran into this fairly well known random “stalling” issue with the RSZ1 shades about 6-7 years ago when I originally set up my Bali / Graber / SWF RSZ1 shades. On the way up or down, the shades will randomly slow down and stop and a red light on the shade turns on. The shade is then unresponsive for a while or until you reverse the direction with the remote.

I was able to work around the issue by having HomeSeer send a Z-Wave value of 1000 to close the shades and 1001 to open the shades instead of the normal 0 and 99 values.

I can’t remember how I came up with that solution - maybe tracing what values the VCZ1 remotes were actually sending (?)…but using that workaround, the shades worked flawlessly for years. The issue would still occur randomly when trying to partially open the shades by sending a Z-Wave value between 0 and 99, but that’s not really part of our daily use case and we can live without it.

I can’t seem to replicate that workaround in Home Assistant. It appears that the Z-Wave JS integration only supports setting values between 0 and 99…and that lines up with the Z-Wave specs I have researched. So I’m not exactly sure how HomeSeer was able to set those 1000 / 1001 values - or perhaps it was doing something different behind the scenes. Maybe it’s as easy as defining a different command class when setting the Z-Wave value - my Z-Wave knowledge is somewhat surface level.

I also reached out to Bali Support and they couldn’t even spell firmware. They gave me an email address for motorization support. It was all a waste of time. My shades are all on the 11.2 firmware by the way. If anyone can send me a semi-current firmware update file for the RSZ1, I will kiss you. No questions asked.

Outside of that… Are there any HA / Z-Wave veterans that can help apply my workaround to Home Assistant? It would be greatly appreciated as the WAF scores in my house are fading quickly every time these silly shades stall. While I feel HA is a huge upgrade over HS4 in many ways, this could be a deal breaker for our home.

I myself, I don’t think I’ve ever had this happen (Bali cellular shades from 2016), and I don’t know of a way to do your workaround, but maybe some things to try:

  • use the switch entity (full open/close) instead of the cover entity (position/level setting).
  • Bring the blinds closer to the controller, do a heal and sometime later try it and see if that prevents the stall. (just wondering if it is network related).
  • If you are using an automation to open/close the blinds, then you could probably trigger another automation to check a little later to see if the current position is where it should be and if not, try to reposition it again

Anyway just some ideas.

Thank you @wmaker for the suggestions!

I tried your first suggestion to use the switch entities for the past week and haven’t seen any stalls since! I had been ignoring them because they don’t seem to stay in sync with the cover entity, but that doesn’t matter for just issuing open/close (on/off) commands.

In case it helps anyone else, I created a helper Group that contains the switch entities. Then I changed the “Show switch as” setting on the new helper Group to “Cover” so I can tell Google to Open/Close the group of shades.

Just out of curiosity - what firmware version are your shades running?

Thanks again!

Not sure, but ZWaveJSUI shows ["11.0","1.9"]

I assume the 11.0 is the relevant value. My shades are from 2017 and are on 11.2 firmware.

Thanks again.