Sonoff ZigBee devices always falling off the network - what can I do?

Hi all,

I have some devices falling from the ZigBee network again and again. They are a mix of Sonoff SNZB-03 PIR and SNZB-04 Door / Windows sensors. I yesterday gave them all new non expired batteries. I checked the voltage on some of the new ones, and they are fine.

I checked in the Z2M logs, they just disappear. No error message.
Repairing them, they are gone the next day again.

I have a Sonoff ZigBee 3.0 USB Dongle Plus on a USB extension cable. It’s in my office in the roof floor / 2nd floor.

The sensors are falling off the network are mostly in the basement, but some are in bath in the ground floor / 1st floor.
I add the screenshot of my map at the end of the post, where I have grouped the routers in groups for the floors and placed the lost devices close to the routers (mostly TuYa TS0002_switch_modules ) I would expect them to connect to in the lower right corner. The red lines are the concrete ceilings.

As there are some devices in the ground floor bathroom (also PIR and door sensor) which tend to fall off the network. Hence, I don’t expect the basements concrete ceiling to be the problem, as it also happens above it.

Any ideas what I could do to improve the situation?

The red lines are the concrete ceilings.
Lost devices without connection line are placed close to the routers they are located nearby.

I have a similar bad experience with the Sonoff Zbdongle-E using ZHA. I have one as the main controller and two flashed as routers on other floors. These are situated near the staircase in pretty much line of sight. They are supposed to uphold the mesh together with other routers.

Several Aqara door sensors and a Philips outdoor motion sensor keep dropping of when connected through the Sonoffs. They work well when connected through other routers. It happens with devices that should connect to the Sonoff with ease. Also replaced batteries, but no luck. RSSI and LQI report very good link quality.

I used to have the same Zigbee mesh but with a Conbee II and two Philips smart plugs as routers, same zigbee channel, same device locations, no problems. But with the Sonoffs the same mesh is stable no more :frowning:

I know the Aqara’s do not switch routes by themselves, but if they could hold their connection to the conbee, they should also be able to keep it with the Sonoffs i.m.o.

Strange stuff…

I have placed now two of the repeatedly disconnected devices in my office next the coordinator.
Let’s see what’s happening the next day(s)…

Are the devices actually going offline and becoming non-responsive or is it just that they don’t show a connection on the map?

If just the map, and they still seem responsive and are still checking in on a regular basis, I wouldn’t worry too much about it.

See FAQ | Zigbee2MQTT

Some are only missing in the map, some are becoming unresponsive.

I also had a discussion on the Z2M discord… the conclusion there was, my Routers are too weak. I will try to add some more and hope it helps.

Got a suggestion for INNR devices. The lights seem nice and I hope they do their job as router as well.

Hard to beat another Sonoff stick flashed with router firmware.


They are listed as unavailable and have no connection on the map. If I pair them again (with or without removing them first) they work again for a couple or hours. Then they go offline again and won’t come back, even if triggered. I’ve seen one or two go offline the first time I tested the door sensor, so it looks like they get a bad message and leave the network or stop transmitting. Reconfigure (when waking the device) does not help.

I’ll try that. Have one here as backup, in case the first fails for whatever reason.

Thanks for the tip.

I had replaced all my sonoff zbmini with Tuya, work fine until now. No more delay response…

1 Like

This sounds different to mine.

Mine always pair again, but lose the connection after some hours.

I’ll try the second Sonoff stick I have as router now. Will be interesting to find a good spot to place them now.

I also placed an additional Ikea repeater somewhere it might help. Let’s see…

@JasonToh Well that sucks! What had been your problem? didn’t they work at all, or just not well enough as routers?

@EspWhaleSong It not response to the trigger immediately, it response after few seconds. I reset it many times, it still happen on 2nd day. Replace it with other brand, no more issue, the rest 20+ of zbmini start to have the same issue.
Don’t think related the router, as itself will become a router, wifi and ZB also adjusted to different channel, still cannot resolve,
Replaced many of it as TUYA, no issue until now. Remain few, no problem till now…strange

I found when one of the device which link with the ZBmini was disconnected, the ZBmini either slow response or not response at all, although it shown still in the network. No this kind of issue to other device at the same situation.

Really strange behavior.

I don’t have any issues with my TuYa switch_modules, despite it doesn’t work to configre the two gangs as light. Don’t know, wether this is a Z2M or HA problem though.

I guess I will add some routers into the equation and hope for the best… The Ikea router and my Sonoff improved the situation somewhat, but didn’t fully resolve it.

Have a Sonoff USB Dongle Zigbee 3.0 (ZBDongle-E) and have the same problems with my sonoff switche (SNZB-1), dissapear from zigbee2mqtt window. Can reconnect (reset) and the work for some time. Also have Ikea/philips bulps who always work.
Any found a solution ??

Same here. I have two SONOFF ZigBee 3.0 USB Dongle Plus (EFR32MG21) configured with Zigbee2MQTT.

The SNZB-01 (button) seemed to have worked fine while testing it in the shop for a couple of weeks. Then I moved it to the house and it worked fine. The next day I noticed it disappeared. Re-added and then again the next day it was gone. Tried many new batteries, forced removed and restarted Zigbee2MQTT, re-add and still the same thing. LQI is over 190.

Now the same thing happens when added back to the shop’s Zigbee2MQTT. Odd that it worked out of the box but no longer after adding to a different network.

I also have 1 of 5 SNZB-03 (Motion) that started to do the same :frowning:

Anyway, I just thought I would share my experience so far.

1 Like

Mine buttons havent worked over two days only one or less, they always dissapear from zigbe2mqtt.
How long is the length og the usb extender? Have been informed that it should be between 50-100 cm.
I will try to buy a shorter usb kable , else i have thought to buy the sonoff bridge insteed.

Anyone figured out the issue?
I have the same experience with Sonoff Zbdongle-E.
All switches go offline after a couple of hours.

Earlier today I noticed in one of the guides that with dongle E you are supposed to add an additional property in the yaml:
adapter: ezsp

It actually seems to help.
Half day passed and all seems to be working, but… jury is still out.
I’ll leave it till tomorrow and update.

Over the last few days, I have lost 4 of 5 motions sensors (SNZB-03) and 3 of 5 contact sensors (SNZB-04). And still no love for the button.

Setting the adpater to ezsp was certainly something that help me originally when I started a month ago. I also read that these adapters are experimental (

My cable in the shop is about 10 feet and at the house it is 3 feet. Both on Raspberry Pis also running zwave2mqtt.

I also updated zigbee2mqtt to the latest release from a few days ago.

For me, I have:

But, like you I have disconnections, and for SONOFF battery sensors (SNZB-04 and SNZB-01), disconnections are daily. Sometimes, but more rarely, the other types of elements also disconnect.
it’s quite annoying I must say.
Everything is new and the batteries are at 100% and good connections of > 190 LQI.

For a beginning of home automation and investment, I am rather disappointed for the moment not being able to trust the system.
I hope that the cause and an explanation of its disconnection will be found soon and especially a solution found!

Notes :
The “ZBDongle-E” is with the original firmware (not flashed).

  • how to control the firmware version ? OK, I find here:

  • Currently the version proposed online by SONOFF is: ncp-uart-sw_EZNet6.10.3_V1.0.1.gbl
    So I have a version build297 installed and a version 6.10.3_V1.0.1 online…

In view of the versions … is it necessary to flash the Dongle?


  • Zigbee2MQTT version : 1.28.4-1

My button has been ok the last couple days. I changed the “max rep interval” from 62000 to 7200. This was from a solution on GitHub ( ). There are many other logged issues about devices disappearing. It’s worth doing a search on the open issues.

I just changed one of my motion sensors and will see if it stays online.


Since a few days now, I have no more disconnection on the following elements:
On the other hand the “SNZB-01” buttons always disconnect during the day or night, even using the modification method that iAutom8 has found.