Support for more SMA Devices (e.g. Tripower X)

The SMA integration currently available in Home Assistant only supports devices that use the Webconnect standard.

I therefore working on upgrading the existing SMA integration in Home Assistant so that it also supports the Tripower X series and Energy Meters

Since the integration into the main branch of Home Assistant is difficult and requires a lot of coordination, I decided to provide a custom integration for testing first.

The current version of my integration is for people who are familiar with Home Assistant and HACS.

The version may contain errors. At the latest when my changes are hopefully merged in pysma, you will probably have to recreate the devices in HA and thus also lose the history.

Supported Devices

  • (as before) Webconnect devices
  • EnnexOS-based devices (currently only Tripower X)
  • Energy Meter (EMETER-10 + 20) and Sunny Home Manager 2

A list of devices that have been successfully tested can be found here

User of the SMA EVCharger or the SMA Data Manager please read the section below.

Installation

  • HACS must be installed
  • You have to add my repository in HACS.
    GitHub - littleyoda/ha-pysmaplus: home assistant custom integration for pysma-plus
  • Then add the following integration via HACS
    SMA Devices Plus (not for production use)
  • Restart HA
  • Add your SMA devices based on the SMA Device Plus integration.
    (Settings / Devices & Services / Integrations)
  • Not all entities are activated automatically. You may have to do this manually.
    (I have initially used the default values of the original SMA integration, which are not optimal for the new devices)

Users of SMA EVCharger or the SMA Data Manager

Since both devices are enneOS-based devices, support for the devices should be quite simple. But I need more information for this. Please add the device as a EnnexOS-based one and then send me the diagnostic information.

Diagnostic

In case of problems, please send me the available log files and diagnostic information.

To access the diagnostic:

Other solution

In addition to my solution, there are also other approaches:

For the german readers:

1 Like

I will try it out when the sun is up. :wink:

OK, I couldnt wait.

Installing worked without any issues. Inverter was found and I could log into it.
Currently almost all values are unavailable / unknown except total yield and PV Gen Meter.

I think this might be due to the fact that it is dark outside?

Does this integration on its own give me the information about current overall consumption, greed feed in or grid supplied power? Or do i have to get this information from another integration? Smart meter?

Yes, most values are only available during the day.
The Tripower X series does not provide any values from a smart meter.

If you have an Sunny Home Manager 2, you can also add these via this integration.

Works like a charm. Tried it during the day. All sensors reported the correct value, i checked with the values in the inverter.

Awesome work!

Being a beginner with HA and HACS and not very experianced with coding I’m sorry if I ask stupid questions. :blush:
I have a Sunny Tripower X STP 15-50 and it’s cable-connected to my home network. I’ve followed your steps above and managed to integrate the “SMA Device Plus (not for production use)” in my HA and it shows up as a HACS Service. But here I’m stuck. I’m not able to add or find any enteties from my Tripower. What am I missing or doing wrong? Care to try to help a newbe? If not I will not be grumpy! :grinning:

If I have understood you correctly, you have added the integration via HACS.
Have you also added the Tripower X as a device?

Settings / Devices & Services / Integrations

I don’t understand how to add the Tripower X as a device. It looks like this.


go to settings => integrations
press on “+ Add new Integration”
Select “SMA Devices Plus …”
and you should see selection menu

Thank you so much. Had tried that but it didn’t show when i searched only on “SMA”, but when I tried “SMA dev” it showed up. :smiley:

Chose “(eg Tripower X)” alternative but can’t get in. Used the ip-adress on my local network. Used the user password for the Tripower X given to me by the installer. It shouldn’t be my login to the SMA account and app right?

The second last field is incorrectly named. Instead of “group”, the user name should be entered there.

The credentials are independent of the app or Sunny Portal
Can you tests your credentials on the inverter?
https://192.168.1.31

I realise I tried that yesterday and it didn’t work. I think I miss the user name information from my installer. I will contact them. Thank you for the support. I will update when I’ve tried with the right user name.

I’ve now got the username from the installer and after some different tests I finally made it through the integration to HA. :grinning: Thank you for the support! I’ll probably come back with more stupid qustions when the sun is up and I can check data.

1 Like

Have you also tested http://192.168.1.31

What model do you have? Some old models does not support webconnect.

I guess you read my post before I succeded and edited the post. I needed to use https://192.168.1.31 to get it to answer and then I could test my credentials succesfully. Then the addition was straight forward. :slight_smile:

First of all: Thank you for your work!!!

This integration is the only one (partly) working for my new SMA PV-System.
With ha-pysmaplus I successful got access to SMA Sunny Homemanager 2.0 and Sunny Tripower X 25.
Only my Sunny Island 8.0H cannot be integrated (timeout).
Connection over a Browser is working, connection with Sunny Explorer via Speedwire is also successful established and communication is not encrypted.
TCP and UDP Server on Port 502 are ON…

What can I do/how can I help to solve this problem and improve your solution?!

What Version of my integration are you using?
I released 0.2.6 half an hour ago. Please test it with this version.

Please send me the diagnostic information (see first post) and add a link to your post for reference.

E-Mail can be found here: https://littleyoda.github.io/

BTW: For Speedwire Port 9522/UDP is used.

It seems that HACS on my Home-assistant is not finding the pysmaplus repository.
Am i doing something wrong?

You have to use the url:
https://github.com/littleyoda/ha-pysmaplus

Found it. Thank you!