Switched from Sonoff to Skyconnect, burt still limited to 20 devices?

Only been doing this a few weeks. I was using the Sonoff 3.0 Dongle to control Zigbee devices. I did finally learn that device was limited to 20 devices without the firmware upgrade. Before I could figure that out, my SkyConnect came. I used the transfer software and it seems to be working perfectly. However, it still won’t recognize any devices over 20. It just sits there and never finds anything new, unless I delete a few devices to make room. Was there a firmware upgrade I was supposed to do with SkyConnect maybe? I was and am still using ZHA. I didn’t think the Skyconnect was limited to 20?

Hi, welcome to the forum!

AFAIK: 20 is not a limit for devices, not for the E nor the P version of the Sonoff dongle.

Do you know that zigbee is a mesh system where you pair devices that are closer to other powered zigbee devices instead of the coordinator?
Also, have a look at Guide for Zigbee interference avoidance and network range/coverage optimization

There is a limit on how many direct connected children devices Zigbee Coordinator can have, you need to add Zigbee Router devices to expand, and Zigbee Router devices also have a limit on how many devices they can have connected via them. Quick answer is simply to add mains-power devices that act as Zigbee Router devices, and you should really do that before adding other devices…

@Jefoid Also read through the whole ZHA integration documentation → https://www.home-assistant.io/integrations/zha as it among other things explain about using Zigbee Router devices to add more devices → https://www.home-assistant.io/integrations/zha#using-router-devices-to-add-more-devices

1 Like

Now that you have a SkyConnect, you can update the firmware of the Sonoff Zigbee 3.0 Plus to a router to expand your zigbee mesh.

1 Like

Hi Hedda, thanks for your comment: I was aware of limitations and searched again when I wrote this but couldn’t find any numbers.
In the past, I remember seeing numbers for Sonoff P or E controller.

Is 20 a hard limit for zigbee because it’s strange that he has to delete 1 to be able to add another one.

Ooh. I like the sound of that. Thanks for the link.

I did not, but it sounds like that is where I am going wrong. Thanks for the link and the help.

Ok. So I think this I am learning here. My Raspberry Pi is the Coordinator. My lights and stuff are obviously the end devices. So what I need to do is add additional routers that are not coordinators in order to create the mesh. (My WiFi is a mesh system, so I get that part) Am I on the right track?

My mains devices are all Sengled light bulbs. Do they not act as routers? Sorry to pepper you with questions but when I saw you wrote the tutorial I got excited.

Sengled bulbs are the notable exception and do NOT act as routers.

Most other bulbs do act as routers, but beware using router bulbs anywhere mains power may be cut off at a switch. The zigbee net doesn’t like it when a router device drops off the net.

No, Zigbee does not really have any hard limits as it instead will depend on the practical performance of the Zigbee SoC chips, so each generation of newer chips has some models/variants that are faster and have more RAM-memory so they can handle routing for more devices than older Zigbee SoC chips that are slower and have less RAM-memory. So the reason for the set limits will depend on a combination of the Zigbee SoC chips used in the devices and the limit that the firmware developer configures for that build image (hence different firmware developers can set different limits in their images).

Thus this is a soft-limit that the firmware developer decides to set in the firmware configuration in order to keep good performance, and they set it based on exactly what the hardware SoC can manage. I believe the current soft-limit for CC2652P/CC1352P (like Sonoff ZBDongle-P) based Zigbee Coordinator for " direct children" is set to 50 by those firmware developers in the later version, and the current practical soft-limit for EFR32MG21 (like Sonoff ZBDongle-E and SkyConnect) based Zigbee Coordinator adapter for " direct children" is set to 50 by those firmware developers in later version.

Child devices for commercial Zigbee Router devices are normally set much lower, so usually around 5 or 10, but custom firmware for DIY Zigbee Router devices (e.g. reflashed ZBDongle-P and ZBDongle-E with Zigbee Router firmware) is commonly set to 20 child devices or even higher.


Yes, again read and try to follow this → Zigbee networks: how to guide for avoiding interference and optimize for getting better range + coverage

Note there that you may need to re-pair some old devices if you have Zigbee devices with bad firmware, otherwise, all Zigbee devices with properly written firmware should automatically move to a better route after around 24 hours or so. You can sometimes force battery-powered devices to connect to a better route by power cycling them (again if they have good firmware).

Indeed. My recommend is to only use a Zigbee lightbulbs in locations where you have removed the physical switch to it so that no one can/will accidentally turn it off and on, (because Zigbee Router devices are expected to always have power so other devices connected to them will take time to move and thus become unavailable for a while). Or alternativly only buy Zigbee lightbulb models that are purposly designed to not act as Zigbee Router devices (i.e. they only act as a Zigbee End Device, also known as ZED in the Zigbee network).

Personally, I suggest instead using dumb lightbulbs using smart Zigbee switches where you replace the whole switch or use a switch module to convert an existing switch into a smart switch. Zigbee lightbulbs that do act as Zigbee Router devices can still have their place in example loose/movable window lights and floor lights with cables where you can more easily remove the switch from their cable.

Also, before buying any new Zigbee products, note that not all mains-powered devices are Zigbee Router devices, and note that some Zigbee Router devices are much better at acting as a Zigbee Router device than others. It is a good idea to research that specific Zigbee product before buying so know if it will also be a good Zigbee Router or not if want more routers, otherwise best is to just buy a few dedicated Zigbee Router devices.

1 Like

Thanks for all your help. My Sonoff outlets arrived earlier. I connected them and that appears to have done the trick. As far as I can tell the Sengled bulbs do not serve as repeaters? Anyway, they clearly weren’t for me. Much appreciated.

Thanks for your help. My Sonoff plugs just arrived and that seems to have been the issue - no mesh. As near as I can tell, now that I have four of them working, the light bulbs were not acting as repeaters or trying to. Maybe Sengled bulbs just don’t do that? If so, I’m glad I chose them because I can now control all of them individually. (Yes, I know, until I get too many, then I’ll make groups) In any event, I am back moving for now on expanding the network!

Correct. Sengled bulbs are designed NOT to be repeaters.


Hi Hedda. Appears I spoke too quickly. The new Sonoff outlets worked fine. Three of the four connected, and I can see that some devices are connecting to those routers (using the network map) so that seems to be fine as well.

Unfortunately, none of that has allowed me to increase the total number of functioning devices. The Three routers added, so it now says I have 24 devices, yay, but all that did is kick three lights off the system that were previously working pretty well. Still at 19-20 working devices max. I can find no one anywhere who shares this issue, so I am certain I am missing something very obvious here., but for the life of me I cannot figure out what it is.

I am reading all the material I can get my hands on, but this just doesn’t seem to be a problem for anyone until they get to 50+ devices. If you have any suggestions or directions I might look I would be appreciative.

ETA: More info. When I try to add additional devices that previously worked, and I try to add devices, it finds them and then sits there at “configuring” until it times out. The “NWK” Number switches and switches but it never makes the connection and turns to green.

Updgrade the firmware on the Zigee Coordinator of you have not already.

Also try re-pairing (without removing) far away Zigbee End devices that did not connect via a Zigbee Router device.

If you done all that and still have issue the. might have remove some Zigbee End Devices and add Zigbee Router devices first before adding other devices.

In addition recommend get some ”known good” Zigbee Router devices, again read and follow this → Guide for Zigbee interference avoidance and network range/coverage optimization

It’s very frustrating. Any combination of routers, and devices works fine until I get to about 12-ish devices, then it just kicks others off. Most of them can communicate with the server just, fine, even now. I try to add devices and it just sits on “configuring.” I can find 10 other people with a similar problem at other steps, but zero responses for hanging up at configuring. It just doesn’t happen.

Before I quit, I would like to try updating the zigbee firmware. I can find nothing on the sonoff website. I can find some information online, along with video tutorials, but they are all two years old and don’t cover ZHA, just the other one. That’s why I bought the new fancy dongle in the first place. I couldn’t figure out how to update the firmware if I’m using ZHA. I figured the new device would just solve that problem.

Do you happen to know where I might find a tutorial for updating a brand new Sonoff Zigbee coordinator? I couldn’t find files or anything.

Suggest that you open a new issue with debug logs to Home Assistant’s core repository, but I suspect that the root cause will probably end up being interference (as wierd Zigbee problems are almost always interference with a rouge device being less common but still a possibility), again read and folllow tips here first → Zigbee networks: how to guide for avoiding interference and optimize for getting better range + coverage

Do not be suprised if the problem is simple EMF interference, I can not highlight enough how many serious problems EMF interference will cause for Zigbee!

If you are talking about the Sonoff dongles and not the SkyConnect dongle then there are steps in my threads about them with seperate threads for ZBDongle-P and ZBDongle-E, (but you must disable/stop ZHA to update firmware), see respectivly:

For SkyConnect there are instructions on Home Assistant’s webpage for SkyConnect documentation