Switching from Zwave 1.4 (Deprecated) to ZWave JS UI (formerly ZwaveJS2MQTT)

What does the healthcheck in docker-compose look like? Is it something like this?

      test: curl -H "Accept: text/plain" || exit 1
      interval: 60s
      timeout: 5s
      retries: 3

I am running dockers images of HA (2021.2.2) and ZwaveJS2MQTT (1.1.1) on a Synology NAS. Both are working and I can see all my Zwave devices in the ZwaveJS2MQTT control panel.

I have configured ZwaveJS2MQTT to the recommendations above, ie. Disable MQTT Gateway and enable WS Server on port 3000.

When I try to add the Z-Wave JS integration from HA, I have to submit the URL, which defaults to ws://localhost:3000. When I hit the submit button, I get Failed to connect. I’ve tried the actual IP address as well, as various different ports. I cannot get it to work.

Any thoughts anyone? Thanks in advance.

Try the docker container label listed in the official docs. https://www.home-assistant.io/integrations/zwave_js/#installing-and-configuring-the-z-wave-js-integration-in-home-assistant

I had same issue. It got connected when I added “network_mode: host” in docker file.

Thanks petro and aghbar. I figured out what I did wrong. I forgot to turn on ‘Use same network as Docker Host’ when launching the docker image. Everything seems to be working now.

A post was split to a new topic: Zwave 1.4 missing after update to 2021.2.3

Any way to tweak the settings for particular devices, as one could do fairly easily by editing the Open Z-wave files on the old integration? In my particular case, ZwaveJS2MQTT does not expose the configuration parameters for my Zooz ZSE29 motion detector, even though the device otherwise seems to function well.

hi all. after installing the integration I can see the devices, but no entities. any ideas?

Hi all. I have a similar issue as already mentioned here. I have the devices in the integration, but the battery-powered ones, do not have entities. Despite in the Control Panel, they have some values. They are not perfect, but more or less OK. What I have recognized these battery powered devices, do not have device ID.

Hi there, I’ve some trouble to get up started Zwave JS, though ZWaveJS2MQTT seems to be working properly…
Error in Zwave JS log is:
DRIVER serial port errored: Error Resource temporarily unavailable Cannot lock port
Unable to start driver [Error: Error Resource temporarily unavailable Cannot lock port]
In the configuration I added same path and network key as in ZWaveJS2MQTT.
(I also allready tried reinstallation aso…)

Any ideas, where could be the problem?

Why are you installing the zwave Js addon? Take a look at the zwave overview guide, it’ll show you how each zwave connection method works.

I installed zwave JS Addon following the instruction above.
Which zwave overview guide do you mean? The integration-sides?

The one named overview

Is it possible you have ZwaveJSMQTT still running? If it is running, it is likely locking the port that the other add-on needs. Make sure the ZwaveJSMQTT add-on is stopped.

To clarify, where in this guide does it say to install the Zwave JS Addon? Spoiler, no where. It tells you to install ZwaveJS2MQTT Addon and the Zwave JS Integration.

1 Like

I was stuck here too, just so others understand:

Install ZwaveJS2MQTT Addon via Supervisor > Add-on store
Then Zwave JS Integration via Configuration > Integrations


Thanks, that was the point!

  • or at least one point:
    I’m able to see my entities in Zwave JS integration now, but now I have the problem that (some) sensor-values are not transmitted (I have some Philio PST02A Door/Motion/temperature sensors):
    Temperature is updated correctly, but for motion or door status I can only verifiy in ZwaveJS2MQTT AddOn that sensor itself is working correctly, but status is not transmitted to entities…
    (wakeUp of sensors, re-installation of all componentes allready tried without success)

Thanks for any hints or ideas…

What point? You said

which is not in the instructions…

Some entities aren’t available yet and are coming in later releases.

On the latest update I seem to have lost control over my thermostats. Inside of of the zwavejs2mqtt control panel my thermostats look better than before (more values and settings are present), however, Home Assistant no longer has any climate entities, any ideas? Is there a way to refresh updated zwavejs devices in Home Assistant?

Over in the Discord chat, it was mentioned that an update to HA will be required for the thermostats. Before I read that, I excluded my thermostat and then re-added it to no avail. I’ll just sit here and wait patiently as the people working on this are doing a great job and have a ton on their plates!

1 Like