Switching from Zwave 1.4 (Deprecated) to ZWave JS UI (formerly ZwaveJS2MQTT)

Hi there, I’ve some trouble to get up started Zwave JS, though ZWaveJS2MQTT seems to be working properly…
Error in Zwave JS log is:
DRIVER serial port errored: Error Resource temporarily unavailable Cannot lock port
Unable to start driver [Error: Error Resource temporarily unavailable Cannot lock port]
In the configuration I added same path and network key as in ZWaveJS2MQTT.
(I also allready tried reinstallation aso…)

Any ideas, where could be the problem?

Why are you installing the zwave Js addon? Take a look at the zwave overview guide, it’ll show you how each zwave connection method works.

I installed zwave JS Addon following the instruction above.
Which zwave overview guide do you mean? The integration-sides?

The one named overview

Is it possible you have ZwaveJSMQTT still running? If it is running, it is likely locking the port that the other add-on needs. Make sure the ZwaveJSMQTT add-on is stopped.

To clarify, where in this guide does it say to install the Zwave JS Addon? Spoiler, no where. It tells you to install ZwaveJS2MQTT Addon and the Zwave JS Integration.

1 Like

I was stuck here too, just so others understand:

Install ZwaveJS2MQTT Addon via Supervisor > Add-on store
Then Zwave JS Integration via Configuration > Integrations


Thanks, that was the point!

  • or at least one point:
    I’m able to see my entities in Zwave JS integration now, but now I have the problem that (some) sensor-values are not transmitted (I have some Philio PST02A Door/Motion/temperature sensors):
    Temperature is updated correctly, but for motion or door status I can only verifiy in ZwaveJS2MQTT AddOn that sensor itself is working correctly, but status is not transmitted to entities…
    (wakeUp of sensors, re-installation of all componentes allready tried without success)

Thanks for any hints or ideas…

What point? You said

which is not in the instructions…

Some entities aren’t available yet and are coming in later releases.

On the latest update I seem to have lost control over my thermostats. Inside of of the zwavejs2mqtt control panel my thermostats look better than before (more values and settings are present), however, Home Assistant no longer has any climate entities, any ideas? Is there a way to refresh updated zwavejs devices in Home Assistant?

Over in the Discord chat, it was mentioned that an update to HA will be required for the thermostats. Before I read that, I excluded my thermostat and then re-added it to no avail. I’ll just sit here and wait patiently as the people working on this are doing a great job and have a ton on their plates!

1 Like

Good to hear! I see they fixed my Zooz ZSE40 4-in-1 sensor on this last update. Once my thermostats are in there I will make the move :slight_smile:

1 Like

I am having some issues updating my Docker ZwaveJS2MQTT container being run on a remote Raspberry Pi.

I followed Flemming’s blog post and have a container successfully running version 1.1.1.

I used docker pull zwavejs/zwavejs2mqtt to download version 1.2.2, ran docker-compose stop, then docker-compose start. It errored out with:

Starting zwavejs2mqtt ... failed
ERROR: No containers to start

Then I tried docker-compose down followed by sudo docker-compose up -d. This responded with:

Building with native build. Learn about native build in Compose here: https://docs.docker.com/go/compose-native-build/
Creating network "pi_zwave" with the default driver
Creating zwavejs2mqtt ... error
ERROR: for zwavejs2mqtt  Cannot create container for service zwavejs2mqtt: Conflict. The container name "/zwavejs2mqtt" is already in use by container "370e1fdb6bc0fb7a11f012009475fc7d0969a6d2ac7a7045d14cd5c899f32203". You have to remove (or rename) that container to be able to reuse that name.
ERROR: for zwavejs2mqtt  Cannot create container for service zwavejs2mqtt: Conflict. The container name "/zwavejs2mqtt" is already in use by container "370e1fdb6bc0fb7a11f012009475fc7d0969a6d2ac7a7045d14cd5c899f32203". You have to remove (or rename) that container to be able to reuse that name.
ERROR: Encountered errors while bringing up the project.

I thought docker-compose down was supposed to close and remove all the running containers.

This is my first foray into Docker, so how should I go about updating the Zwave2JSMQTT container?

Hi, did you try to update the image via docker-compose command, e.g. docker-compose pull? If you use docker-compose, you should normally update images using docker-compose commands. Or you can also try to update it using portainer web interface.

2 of my z wave device will not interview they are both sending awake signals i can see in debug and also sending values like lux temp and humidity but zwave js just shows then as unknown.

my yale smart lock interviews but shows as unknown anyway.

I did use docker pull zwavejs/zwavejs2mqtt, but that did not recreate the container with the updates. In the end, I used:

cd ~
mkdir zwavejs2mqtt
cd zwavejs2mqtt
curl -fsSL https://raw.githubusercontent.com/zwave-js/zwavejs2mqtt/master/docker/docker-compose.yml -o docker-compose.yml

from Flemming’s blog post, double checked the docker-compose.yml file for content, then ran sudo docker-compose up -d.

Now I’m successfully running v1.2.2/6.4 and have updated a few Inovelli devices with new firmware OTA. Zwave2JSMQTT for the win!

What exactly is the purpose of the “Name” and “Location” columns?

I see where these can be set:

…what does this do? Does it push anything to the controller/USB stick or is it only to show a “Friendly” name in the UI?

a heads up for anybody having trouble connecting to the zwavejs integration to the supervisor integration

  1. make sure the url ws://a0d7b954-zwavejs2mqtt:3000 does not start with a space at the beginning.
  2. If you’re using the assistant relay addon, make sure to change the websocket port in either assistant relay or in zwavejs-mqtt from 3000 to something. Both addons are using port 3000

Do you know where I can check if support for my device is added in there? I think there should really be a bigger disclaimer that one should check whether ones devices are already supported. A thermostat with the function of you know, changing the heat settings, is rather pointless. Good thing I checked this first.

Time to roll back for now.

EDIT: Found it. It is in the changelog on the github release page for zwavejs

EDIT: Here is the announcement thread for zwave devices that are being migrated from the zwave alliance database

1 Like

Would be really useful if the ZwaveJS2MQTT addon mounted the device config folder in the docker to the exposed addon share folder (or, probably, the other way around). That way, it would be easy to add new configuration files or alter/improve existing ones.

1 Like