Sylvania Smart+ Bluetooth devices working in Home Assistant! Yes!

I wound up with two Sylvania Smart+ Bluetooth devices recently. I had just had them sitting around, because I had no use for them and I was convinced they would be useless in Home Assistant. I did a bit of research on the compatibility and was discouraged. It looked pretty hopeless so I let them sit.
Until today. Anyway the great news is:
They work on Home Assistant!
I have one rgbw a19 bluetooth bulb from walmart and 1 bluetooth wall plug.
I used the Sylvania Ledvance bluetooth app to get these ready to pair with Alexa.
Then I used the alexa app to discover the devices and a little while later they showed up as entities in the Alexa Media Player integration!! They just showed up automatically it seems? I am very pleased. I have full RGBW control of the bulb also!
I’m not really sure why these came across, but they did. I’ve never had alexa sync any other devices to my home assistant. I thought it only synced one way?
I just wanted to post this up in case somebody else is looking to find out if these devices work here.
They do.

I have two bulbs set up but they do not show up on the Alex Media Player. Did you have to do anything special?

@breakleanfix the app is only needed to update the firmware on the bulbs (likely not necessary at all - I upgraded 1 bulb just to test, but even the non-upgraded bulbs appeared in HA anyway… - but I think the echo can also do BLE firmware updates by itself).

the important bit to integrate the bulbs in HA is 1) make sure bulb, echo, HA & AMP are all updated, 2) check the “include devices connected via echo” in the AMP integration config page, then 3) reload AMP - they’ll appear under entities.

oh, and you must have at least 1 of the supported echo devices on your network (anything w/bluetooth except echo puck gen 1 - I use echo flex & spot for mine)

when you go to the config page for the bulb in alexa, you should see which echo device it’s connected to.

set up the bulb closest to the echo first, then work outward.

I was able to get two a19 Sylvania Smart+ Bluetooth light bulbs paired using the new Bluetooth support in HomeKit Controller on 2022.8.3, but unfortunately any calls for off, on, brightness, or identify seem to fail.

I flashed them back to Google Assistant firmware and I can get one or two of the three bulbs to respond intermittently with Google Home. Sadly, they’re not integrated with Home Assistant. Overall the product remains a disappointing experience. I may need to try your Alexa idea.

Hoping the HomeKit bluetooth integration is fixed soon.

1 Like

I just tried the same thing - and got the same result. I have a whole drawer of these bulbs, it’d be great if they could be supported. They are correctly identified/etc (serial number, etc), but no entities are created after you add them in HomeKit controller.

1 Like

I tried the Op’s technique, but the Sylvania bluetooth bulbs aren’t picked up. Also saw these errors in the log:

Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/helpers/entity_platform.py", line 281, in _async_setup_platform
    await asyncio.shield(task)
  File "/config/custom_components/alexa_media/switch.py", line 44, in async_setup_platform
    account = config[CONF_EMAIL] if config else discovery_info["config"][CONF_EMAIL]
KeyError: 'email'
2022-08-20 15:11:07.115 ERROR (MainThread) [homeassistant.components.sensor] Error while setting up alexa_media platform for sensor
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/helpers/entity_platform.py", line 281, in _async_setup_platform
    await asyncio.shield(task)
  File "/config/custom_components/alexa_media/sensor.py", line 59, in async_setup_platform
    account = config[CONF_EMAIL] if config else discovery_info["config"][CONF_EMAIL]
KeyError: 'email'
2022-08-20 15:11:07.120 ERROR (MainThread) [homeassistant.components.alarm_control_panel] Error while setting up alexa_media platform for alarm_control_panel
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/helpers/entity_platform.py", line 281, in _async_setup_platform
    await asyncio.shield(task)
  File "/config/custom_components/alexa_media/alarm_control_panel.py", line 53, in async_setup_platform
    account = config[CONF_EMAIL] if config else discovery_info["config"][CONF_EMAIL]
KeyError: 'email'
2022-08-20 15:11:07.122 ERROR (MainThread) [homeassistant.components.light] Error while setting up alexa_media platform for light
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/helpers/entity_platform.py", line 281, in _async_setup_platform
    await asyncio.shield(task)
  File "/config/custom_components/alexa_media/light.py", line 78, in async_setup_platform
    account = config[CONF_EMAIL] if config else discovery_info["config"][CONF_EMAIL]
KeyError: 'email'

Update: with Home Assistant 2022.11.0, I was able to get all 3 bulbs paired via HomeKit and have proper functioning of on/off and the brightness slider! Two recommendations, (1) pair the device impossibly close to the receiver to maximize signal reception and (2) write an automation script triggering with an input boolean to properly sync lights without excessive frustration (see below).

alias: Dining Room Lights Homekit
description: ""
trigger:
  - platform: state
    entity_id:
      - input_boolean.dining_room_lights
    from: "off"
    to: "on"
    id: "on"
  - platform: state
    entity_id:
      - input_boolean.dining_room_lights
    from: "on"
    to: "off"
    id: "off"
condition: []
action:
  - choose:
      - conditions:
          - condition: trigger
            id: "on"
        sequence:
          - parallel:
              - repeat:
                  until:
                    - condition: state
                      entity_id: light.sylvania_smart_a19filament
                      state: "on"
                  sequence:
                    - service: light.turn_on
                      data: {}
                      target:
                        entity_id: light.sylvania_smart_a19filament
                    - delay:
                        hours: 0
                        minutes: 0
                        seconds: 1
                        milliseconds: 500
              - repeat:
                  until:
                    - condition: state
                      entity_id: light.sylvania_smart_a19filament_3
                      state: "on"
                  sequence:
                    - service: light.turn_on
                      data: {}
                      target:
                        entity_id:
                          - light.sylvania_smart_a19filament_3
                    - delay:
                        hours: 0
                        minutes: 0
                        seconds: 1
                        milliseconds: 500
              - repeat:
                  until:
                    - condition: state
                      entity_id: light.sylvania_smart_a19filament_2
                      state: "on"
                  sequence:
                    - service: light.turn_on
                      data: {}
                      target:
                        entity_id: light.sylvania_smart_a19filament_2
                    - delay:
                        hours: 0
                        minutes: 0
                        seconds: 1
                        milliseconds: 500
      - conditions:
          - condition: trigger
            id: "off"
        sequence:
          - parallel:
              - repeat:
                  until:
                    - condition: state
                      entity_id: light.sylvania_smart_a19filament
                      state: "off"
                  sequence:
                    - service: light.turn_off
                      data: {}
                      target:
                        entity_id: light.sylvania_smart_a19filament
                    - delay:
                        hours: 0
                        minutes: 0
                        seconds: 1
                        milliseconds: 500
              - repeat:
                  until:
                    - condition: state
                      entity_id: light.sylvania_smart_a19filament_3
                      state: "off"
                  sequence:
                    - service: light.turn_off
                      data: {}
                      target:
                        entity_id: light.sylvania_smart_a19filament_3
                    - delay:
                        hours: 0
                        minutes: 0
                        seconds: 1
                        milliseconds: 500
              - repeat:
                  until:
                    - condition: state
                      entity_id: light.sylvania_smart_a19filament_2
                      state: "off"
                  sequence:
                    - service: light.turn_off
                      data: {}
                      target:
                        entity_id: light.sylvania_smart_a19filament_2
                    - delay:
                        hours: 0
                        minutes: 0
                        seconds: 1
                        milliseconds: 500
mode: restart

The OP’s post is correct. The Sylvania Bluetooth bulbs paired to Alexa do show up in in the Alexa media player in Home Assistant. Just select Smarthome as the device category, and they’ll be in the list of possible devices, along with any groups or scenes containing them. You do need to refresh the Alexa device list though before you’ll see them listed, by forcing a new sign-on to Alexa. Under Action you can turn them on/off, and change color and brightness, but I don’t think there’s a way to check the status.

“Just select Smarthome as the device category” - Where do you see this?

“You do need to refresh the Alexa device list though before you’ll see them listed, by forcing a new sign-on to Alexa” - Can you elaborate? How do you force a new sign-on?

I just tried again and it’s only picking up one 1 of 6 bulbs. I’m testing voice control RIGHT before adding them and all 6 bulbs change color as expected.

See screenshot for what my Alexa media player node looks like in Node Red.

HAAlexa

I refresh my connection to Alexa by re-logging in to my AMU account. One quirk - the bulbs are not named the way I named them in Alexa - they are labeled “First light”, “Second light” etc., the initial default names they appeared with in Alexa when I first added them as new devices.

It also works as a group. If two bulbs are in the “Bedroom” group, and I select “Bedroom” as the device in the above node instead of a specific light, all lights in the group are affected, including the Sylvania Bluetooth bulbs.

There’s no mention of Node Red in the OP, that’s what was throwing me. It’s supposed to be able to work with JUST the Alexa Media Player integration.

In my case it does, but for only 1 or 2 bulbs out of 6.

How were you able to pair these bulbs without a HomeKit code? I recently found a pair of these bulbs and tried to connect them. I used the Sylvania app to update them with the ‘HomeKit’ firmware, but when I try to connect them in HA it asks for a HomeKit pairing code which these don’t have.

I was able to get mine paired and the HomeKit code should be on the base of the bulb.

1 Like

From my understanding, only the earlier produced bulbs have the code. The newer ones, like when Amazon was blowing them out for $2 a piece (when I purchased) don’t have it.

2 Likes

Damn, I must have gotten the newer ones then. There’s no mention of HomeKit anywhere, no codes on the bulbs or anything. That was the first thing I checked.

I found them at my local dollar store of all places, I knew there was a reason they’re there. Figured i’d give them a shot at 5 bucks for a pair. Maybe i’ll pair them to my Echo speakers and use them that way.

probably that one here? :point_down:

:arrow_lower_right:

These are the ones I grabbed on the cheap:

https://www.amazon.com/gp/product/B08VBYDKHQ/

Messed with these bulbs again today. Figured out that there’s a COMPLETELY separate firmware version to enable Homekit. Turns out my bulbs DO have the code on them. You have to log OUT of the Sylvania app completely, then when it asks what kind of “speaker” you’re using you click on Homekit. It will prompt to replace the firmware with the Homekit compatible one.

Now to get them into Home Assistant, I have to figure out how I’m adding Bluetooth to my HA setup. (running on Unraid via Docker)

Can you show us a picture on where to look for that code? On mine I can’t seem to find it, yet, was able to install the HomeKit fimware. Home-Assistant found it but require the Home-Kit code.