TADO valves without using TADO server?

Hi, just wondering if anybody has a way to use the TADO radiator valves without having to use the TADO servers or is this even being worked on.

I’m using Hassio and the valves but would like to be sure there won’t be a problem with my set up if they ever start charging a subscription for normal use.

Thanks for any info

1 Like

Perhaps there is help in this thread.

It should soon be possible to control tado devices locally through the HomeKit controller component (https://www.home-assistant.io/components/homekit_controller/), provided that your bridge is HomeKit compatible (which I think all V3 devices are). See https://github.com/home-assistant/home-assistant/issues/16971.

I got it to work and it allows control without the tado cloud servers. Of course all the “smart” stuff like scheduling, geofencing, open window detection etc. will not work as all those things are provided by the cloud. But this can be replicated with Home Assistant automations and scripts. I think only setup and changing of the configuration (room assignments etc.) would still need the cloud.

I would assume this should work also in the future irrespective of whatever great ideas for subscription models tado comes up with in the future as long as they maintain compatibility with HomeKit (which I guess they need to do if they want to stay relevant).

4 Likes

Thanks for the suggestion bosborne however while interesting it doesn’t quite give the info I need. I’m really trying to find out if anyone is working on or has already gotten the TADO valves usable by hassio without using the TADO cloud servers

Thanks very much for that cf0. Exactly the info I was looking for. Now I have somewhere to start getting my TADO valves away from the cloud

Hi Mark,

did you managed to use tado without cloud connection?

I’m struggling with the same problem.
I’m not able to connect my Tado AC V3 to Home Assistant without using the cloud.
"HomeKit Accessory: Smart AC Control " is discovered in HA, but after typing the pairing code I get the following error:
“Device refused to add pairing as it is already pairing with another controller.”

I have reset the Tado-device several times, but no joy.

I recall that the pairing functionality (with code XXX-XX-XXX) of the Tado bridge, directly as a HomeKit Accesory under Home Assistant Integrations was not working for me until a few months ago, but this got fixed.

In order to do this you have to reset the Tado Bridge (and unpair it with your Apple HomeKit hub), and Home Assistant will discover the bridge like so:

After confirming everything all entities should enumerate like so:

Are you on the latest version of HASSIO? Hope this helps.

1 Like

Thank you flyingpenguin,
but I still have the same problem.

I have tried to reset the device and I don’t have a HomeKit-hub, but I still get the same message:
“Device refused to add pairing as it is already pairing with another controller.”

I assume “reset” means using the “trash can” in settings on the Tado-unit, right?

May I suggest you completely remove all tado references in configuration.yaml and in the entities registry in HASS.

You will no longer need these once you get the tado bridge to register with HASS as a Homekit controller.

After resetting the tado bridge (hold pairing for a good while) and restarting HASS, the new entity should show up under notifications asking for the XXX-XXX-XX code.

Once that is complete all your tado entities should populate under the tado bridge integration.

Good luck!

"“I assume “reset” means using the “trash can” in settings on the Tado-unit, right?”

I think the factory reset will also delete all configured thermostats. that is not necessary, I think. Not sure though.

I managed it to setup my Tado Internet Bridge in my Hass.io instance without internet, but i can’t get my valves showing up. I tried seaching them as homekit device, also tried to use the pair button inside them, restarting Hass.io etc etc…
Any idea how i get them to show up?
Unbenannt

You still need to tell the bridge about your thermostats by adding them via the Tado app on your phone or via https://my.tado.com/webapp/#/installation/add-device (using each thermostat’s unique ID ( eg.RU1636765184, VA0459280128 etc.).

Not sure if HASS auto detects once thermostats are added or whether you have to restart.

Once they appear under entities you can add them to lovelace with the thermostat card

Can i then also disable the internet for the bridge and it still works?

I have disabled de Tado component in configuration.yaml like so:

#tado:
#  username: "TADO_USER_NAME"
#  password: "TADO_PW"

This will disable your cloud-based control of all tado equipment.

You may have to remove the “old” cloud-based entities from your Entity Registry after restarting HASS.

Let me know how it goes…

I didn’t use the tado before (tried to set it up without creating account - didn’t work), so now i set all my valves up in the app and have them working.
Hass.IO shows them now, too (after restart).
But can i now disable internet for the Tado Bridge in my Router and still control the devices with Hass?

I’m pretty sure that’s what he just told you and how

Works now perfectly (beside there is no humidity shown in hass).

If you want to completely shield your TADO from any cloud interference, you can block the tado bridge’s internal IP address from the internet in your router (likely via parental control or something).

Because the warm water (on/off) cannot be controlled via the homekit controller (don’ ask me why), I am using an IFTTT webhook to turn on/off my hot water boiler. You need your tado bridge to remain connected to the internet to get this working…

You can pull the humidity (or any other defined attribute) into a HASS sensor like so:

- platform: template
    sensors:
      humidity_thermostat_1:
        friendly_name: 'RH Thermostat 1'
        unit_of_measurement: '%'
        icon_template: 'mdi:humidity'
        entity_id: "climate.tado_smart_radiator_thermostat_va0143396352"
        value_template: '{{  states.climate.tado_smart_radiator_thermostat_va0143396352.attributes.current_humidity  }}'
1 Like