Tapo: Cameras Control Camera requires your cloud password for control

Hi, i’m getting this message in the tapo cameras integration and the correct password is not working, i have same password in both, device and cloud. Anyone with same problem?

thanks

2 Likes

Try resetting your cloud password.

Done. same problem :frowning: . ip correct, user and password correct but cluod password wrong…
I login to tapo cloud via website without problem

Is this the Tapo core integration or a custom integration?

Custom from hacs, is there a core integration?

Maybe this is the problem:

Firmware 1.3.8 (or build 230921) and newer might cause integration not to work

Edit: Found the core integration but do not find my camera…

1 Like

Ahhhh, that’s why I was asking. I don’t think the core integration supports cameras (I’ve not looked).

I’d agree. :frowning: Might be worth bringing up in the integration’s github issues, but it seems it’s already knowing about it.

No, not suported… thanks for your help :slight_smile:

1 Like

Just tried setting up a couple of camera today and receive the same error message when entering the cloud password.

According the developer of the integration there’s a solution but waiting for tapo approval and permission

1 Like

Where did you hear this information?

I did see threads back in Nov 2023 with similar issues, which seemed to have been fixed. Am assuming with newer firmware the problem has occurred again.

If a solution is being worked on, I may hold back the factory reset fix (hopefully taking the device back to a working firmware version).

In the official GitHub. They are posting updates of the issue and a fix is ready but waiting for permission

https://github.com/JurajNyiri/HomeAssistant-Tapo-Control/issues/551

1 Like

FYI:

I performed a factory reset of my C210 cams (retaining the latest firmware) and re-added them via the app. Then re-tried the HACS integration and it accepted the cloud password.

i will try, thanks :slight_smile:

I’m having the same issue, so eager to get this resolved

C110 camera
1.3.11 firmware (I only picked up the cameras this week, so they came with this firmware version already)
5.4.18 T:CC installed via HACS
2024.4.3 Core
20240404.2 Frontend

I have tried a password reset and camera reset with no joy

It worked initially, but after an hour the integration told me I needed to reconfigure and this is when the problem started

It’s a really nice integration though, fingers crossed it gets fixed soon

1 Like

I just bought a Tapo C120 and ran into the same issue today. Started googling and found this thread. All I have to say is that this sucks, but at least it sounds like this will get resolved.

I like the camera so far and the features are good enough for me. Being able to mount it on a magnetic base is also a big plus since my wife is anti drilling holes. So I’ll hold out and hope the fix comes eventually.

1 Like

So I checked out that Github thread and saw someone mention using ONVIF for the time being. So I tried that and was able to add my Tapo C120 to Home Assistant that way.

I assume it’s no where as feature rich as the HACS integration would be but the stream is great with almost no lag and I even get a basic motion sensor that cools down nearly instantly.

This set up is perfectly fine for my needs while we wait for the HACS integration to be fixed.

1 Like