Tapo P110M Energy Monitoring

I’ve updated to HA 2024.6, which includes the Matter 1.3 specs.
My first and single Matter device, the Tapo P110M plug with energy monitoring still only shows 1 entity: the switch to turn it on and off.

What needs to be updated or done to get energy monitoring in HA working for this device? A firmware update from TP-Link? Or specific matter change in HA? Re-add it to HA?

While we udpated the SDK to what should be capable of supporting all Matter v1.3, we have not added all the new device types just yet. So you need a bit more patients to get those.

Most likely it will be available with the next release of Home Assistant Core though.

2 Likes

Also, I am assuming that now the matter specification has been updated, TP-Link is going to need to create a firmware update for it? I can’t seem to find any public tp-link documentation on their firmware update changes.

If they released before 1.3 spec, then yes, they’ll need to provide a firmware upgrade.

Matter has a mechanism to distribute firmware update, and update information through their DCL. When you know the device vendor and product id you can look up if a firmware update is available there. You can find this information in the diagnostics (under 0/40/2 and 0/40/4).

Great information, thanks for that. I’ve found the device in the DCL

    "0/40/0": 1,
    "0/40/1": "Tapo",
    "0/40/2": 5010,
    "0/40/3": "Smart Wi-Fi Plug",
    "0/40/4": 262,
    "0/40/5": "",

In here, the firmware is listed as 1.0.0 while the actual device is currently already running firmware version 1.1.0 Build 231009 Rel. 155719 (I updated this months ago using the Tapo app)
I now also understand why the HA Matter server reports 1.0.0 as FW version (using DCL)

So I guess we’ll have to wait for a TP-Link/Tapo update, preferably published through the DCL.

Hi @TexTown ,

Might I ask how could you add the Tapo P110M to Home Assistant? Via Matter?

I tried to commission the Tapo to Home Assistant but the Matter Server Addon keep rebooting after giving an error ( Verify or Die…)

I use the same stuff like yours( HA 2024.6 and the Tapo P110M version 1.1.0 Build 231009 Rel. 155719).

Yes, I used HA (mobile app) to add the device. But that was long ago, many versions before the current version. It worked without issues