Telldus Tellstick Znet Lite v2

Hi,

I’m new to Home Assistant (this week) but already well on my way (I feel).

I got myself a Telldus Znet Lite v2 as a quick way of starting automation as I have a few Nexa controllable sockets (433 MHz). Works well via Telldus Live, but I was hoping that I could control the Telldus Znet thing via a local API instead of over the internet. I have not been able to achieve this so far.

I see that many people have raised the issue earlier, but I don’t seem to find any reference to anyone actually being able to control the Telldus Znet via local API. Has this not been implemented?

I tried installing the Tellstick-server (https://github.com/telldus/tellstick-server), but the setup script fails on some npm stuff. It seems to fail on building ‘webpack’ and I get a lot of deprecation warnings.

I’m running Home Assistant on Raspian on a Raspberry Pi3 B+. Works well, but with so far with disappointing results with respect to local API control of the Telldus Znet.

Any pointers are appreciated.

1 Like

In case someone else should wonder at some later date: Here’s how it ended.

The documentation https://www.home-assistant.io/components/tellduslive/ says that

When discovery and the key exchange with Telldus Live have been completed, you will be presented with an option to integrate with the cloud or local API for direct communication with your hardware in your LAN,

This didn’t happen for me when I first set it up. I was only given the option to configure the Telldus using live.telldus.com for API. It’s been working well, but I would like local API rather that API via the internet.

I today removed the tellduslive.conf file from the configuration folder and specified the local IP address of the Telldus box in configuration.yaml:

tellduslive:
  host: <local IP address of Telldus box>

Upon restarting Home assistant, the discovery found the Telldus again and this time presented me with two options: Configure using live.telldus.com or local API. I went ahead with the local API and there I was. It now seems that I control the Telldus Tellstick Znet Lite v2 via local API.

4 Likes

I did have the same problem and this solved it! Thanks…

1 Like

Hi,

Sharing the procedure I used on HA 0.86.2 to change from Cloud- to Local API for telldus.

  1. In HA, go to Configuration/Integrations and select Telldus Live and delete it using the trash bin icon. This removes the old telldus configuration files.
  2. Go to Configuration/General and select Restart Server.
  3. After the restart, go to Configuration/Integrations. On top of the page you should now see a new heading, Discovered, and Telldus Live with a Configure option. Now you can choose your end-point. In our case the IP address of the local Tellstick client. Choose Submit.
  4. New windows pop-up Authenticate against TelldusLive. Follow the instructions and press Submit when done.
  5. If everything went fine you will see a Success window.

B R

//Jimmy

Mine didn’t show up as expected - with the option of connecting to the local device directly (and skip the Cloud API). I had to add the host to my configuration.yaml, restart then i got the option to choose the local device directly. Proposed a little clarification to the component page for Telldus Live. Hopefully that will help the next person.

Hi, im struggling getting the local API going. Ive added 10.0.0.2 in configuration.yaml and that made telldus appear as @ThePapaMaan says above. I then get a menu to choose btw “Cloud API” and “10.0.0.2” (my local Telldus net)
(one with a RJ45, not usb, white and fancy colored light, not sure of the exact name or version of the telldus unit)
But then i get an error saying Aborted and “timeout generate authorize url”
If i restart home assistant using “ha restart” command, Telldus re-appears and the same thing happes again. Very unsure what to try next (to get the local API working)

Any input very much appreciated.
(Im running lates VDI image on Vbox in a W10 laptop, for testing, will move it to proxmox if i can figure this out) (i have it working via cloud API, and i did remember to delete that one before trying local API.)

Ahh, at last I found how to do. I gave up a few weeks ago!

A lot of questions raises…
I have one new Tellstick zNet v2 and an old Tellstick Net.
The later running firmware v17. There was earlier an integration for the old one, not complete but i did work for codeswitch devices.
Now I am running via telldus live, it works, but dead slow. The delays are unacceptable!

Can I run both local and via telldus live? I suspect not…
Or can I run the both integrations one for the old one and one for the new?

I am still new to HA due to lack of time, but I got a motionsensor and a timer to work yesterday!:slightly_smiling_face:

@wacgyver: did you get this working? I have the exact same problem with “aborted, timeout generating authorize url”.

@f00dagi
No i did not, but i figured out that my TellStick Net has no local API.

See response from Telldus in swedish below (translate as needed in google)

TellStick Net har inget lokalt API utan är helt beroende av våra servrar.
Vill du ha en TellStick med lokalt API så är det TellStick Net v2, ZNet lite v1 eller v2 som gäller.

Walter

1 Like

This is the offical truth!
But the old Tellstick Net do have a local API, IF has firmware 17 (I think this is the correct number). I don’t think this is an official release.

With that it shoulld be possible to have push messages, instead of pull.

This solution is not working anymore.
After selecting local IP as Host and connect to Telldus Live I get this error message:
You tried to log in as .@. but this TellStick ZNet is not activated.

I think you have to register the device at telldus live first ( not sure but I think so, that’s how I do it…). It is free.
Your add devices there and then they show up in HA.

In first step I registered at Telldus Live but when adding the Telldus integration I could just select Telldus Live not local IP. Therefore I added the local Host IP to my configuration and removed and added the integration and after that I got the earlier mentioned error message.