Testers needed for Netatmo climate (multiple thermostats or valves)


Try the following script (to modify accordingly, of course):

  alias: Turn on bedroom valve heating
    service: climate.set_temperature
    entity_id: climate.netatmo_bedroom
      temperature: '{{ states.climate.netatmo_bedroom.attributes.current_temperature|float + 1 }}'


Unfortunately this doesn‘t work either.


This works:
temperature: ‘22’

filling in {} doesn‘t work:
temperature: ‘{{ 22 }}’

So maybe does sign are not allowed?


This is kind of weird, because the script works for me (I set to “Comfort priority” operating mode in Netatmo Energy app).


I also have “comfort pririty” but I don’t think it has something to do with that.

This my automation:

- alias: Cube - shake
  initial_state: 'on'
    platform: mqtt
    topic: 'zigbee2mqtt/Zigbee Cube'
    condition: template
    value_template: "{{ 'shake' == trigger.payload_json.action }}"
    - service: climate.set_temperature
        entity_id: climate.netatmo_schlafzimmer
        temperature: '{{ states.climate.netatmo_schlafzimmer.attributes.current_temperature|float + 1 }}' #'22' works 
    - delay: 00:15:00  
    - service: climate.set_operation_mode
        entity_id: climate.netatmo_schlafzimmer
        operation_mode: Schedule    

As I said the weird thing is that '22' works and adding brackets will disable it ‘{22}’. Don’t know why the brackets work for your data input


I think you should use data_template instead of data.


I missed that, thanks a lot. Works now!


Hi guys, it works for me too, thanks to the people who allowed this. Very good job

But I noticed that the history does not work. Is it the same for you?

And I noticed that since the installation, I no longer have the global history.



Hi, this is a screenshot of the history of one of my valves. So my history works. It evens shows the heating periods. Or do you mean something else?

I don’t know whoch global history you mean. Do you mean the history of the thermostat?


In your configuration.yaml, make sure you have:



Yes Baosong_Shan, i have.


I never saw this. You may want to dig into the log file to see if there is anything abnormal logged.


If you have a more elaborate history configuration with excludes/includes you might have to adjust that to fit the new entities.



Thx for the job done it s really great.

Did anyone try to export those entities to homekit ? because it works for me (1thermostat and 3 valves) except for the status which doesn’t sound to be updated. Let’s say the thermostat is heating on hass i see it as inactive on homekit. It s not big deal but still weird


try to delete the home-assistant_v2.db from the config folder and restart home assistant.


Hi, thanks for this awesome custom component. I’ve 2 netatmo thermostat in the same home but with this component I just see one of this, and the other is called correctly but shows the same parameter of the first one… Could you give me an help to solve this problem? Thanks in advance.


Use this https://gist.github.com/shanbs/526b6cd424e7f1f872cbd320887a2f4a
From @Baosong_Shan


About the naming of the operation modes, I would like to listen to your opinions. The operation modes in Netatmo most have not been localised in HA as a STATE of climate device: schedule, max, hg. So I have two options to resolve this:

  1. Map the modes to what HA has, like:
    schedule -> auto
    max -> high_demand
    hg -> eco
    The good point of this option is that the localisations have been done for the above words.

  2. Used Netatmo own as display:
    schedule -> Schedule
    max -> Max
    hg -> Frost guard
    The good point is this is more accurate, but it can only be displayed as above for the moment, as no localisations for them.

Which one sounds better for you guys? Thanks!

BTW, I’ve submitted a PR for the pyatmo library (codes in fact written by gieljnssns), but not yet merged.


Hi, the second one will be better for me!


thanks a lot! It works flawless!!!