The 'official' way

Not so much of a rush now that the deprecation of the supervised install has been suspended, but I’m still curious and have been playing around with the concept of ‘migrating’ to hassos.

Something that bugs me in this project sometimes is when things get changed and the userbase says “OK, what’s the official way to do it?” and the question falls on deaf ears.

Now I’d say I’m a ‘power-user’, so the fact that I’m struggling with the following basic question doesn’t bode well for the new target audience, but…

What’s the official way to restrore from a snapshot when you migrate??

I ask this because there’s no option I can see in the UI to import a backup, so I can only assume I have to put it on the machine myself in the backups folder. Now, it took me a really long time to even find the backup folder on the machine, only then to find that ssh is disabled by default. So then I install the ssh addon, which I actually can’t get to work. I can’t even get as fas as login, I just get connection refused (the addon says it’s listening on port 22 so :man_shrugging: ) And even then if I can get that far, what user name do I use? root? homeassitant? Homeassistant user?

So effectively I have a blank canvas of hassos - I have a snapshot, and I have no way of putting the two together and there are no official instructions how to do this.

I’m sure eventually I’ll stumble through and work out a way of getting it across, but the point I’m making is it is not a very welcoming situation to be in and has eaten up most of my day.

However if I was using the (soon-to-be) unsupported method I would have actual access to the file system and would have ‘normal’ ssh access. I would have had the whole thing transferred to the new machine and been up and running in under an hour.

So in the broader sense, if a power-user is struggling how to see how people are supposed to do this easily, how are the new target audience supposed to work it out - and when is more thought going to be put in to “This is the way we expect you to do it”?

I would have thought the ability to import a snapshot from the ui would have been the best :slightly_smiling_face:


I was only thinking this today as I thought through in my head how I was going to do my (now delayed) migration back to Proxmox.

The onboarding screen really should have a ‘Restore From Snapshot’ option from which you can navigate to a snapshot file which resides anywhere.


Indeed - I actually just tried the official “file manager” addon hoping to be able to drag and drop, but the files that are in there are just the ones in the ‘homeassistant’ folder, I cannot access the parent folder (presumably because the homeassistant folder is the only one mapped to the container).

This is troublesome if I’m honest. Fortunately for me this is just another proxmox VM, my actual instance is still running, but if I’d hosed it expecting to just install hassos and restore from a snapshot I’d be really annoyed.

Oooh, there’s an option to view the parent folders in the addon config - standby…

Nope - trying to upload my snapshot in to the backups folder via the file manager addon fails with “Failed, insufficient permissions”


I’ll be eager to hear how this works out in the end. I’d toyed with the same idea myself, but as I know just about enough to be dangerous and I don’t have an existing Proxmox setup, I’d have been up a creek sans paddle.

1 Like

You may use the samba add-on. Activate it after fresh install and drop in the backup.

Ah yes, the samba addon - that didn’t work either. The logs showed it picking up my laptop on the network, but my laptop couldn’t see homeassistant and trying to add it manually as a shared drive was ‘not found’

Bearing in mind that when I did the test I could see and interact with all 3 of my kids laptops under the network tab of file explorer, I think we can reasonably assume that the samba addon is not as reliable as you suggest :man_shrugging:

Yes. I was on a similar journey this afternoon:

  • vdi download didn’t produce a system that responded on the web port.
  • beta qcow did after quite a wait.
  • no way to get the snapshot imported.
  • SSH add-on doesn’t seem to talk to the outside network.

Like you I’m no newbie. A regular, even minimal, OS with SSH access and this would have been a piece of cake. Is it was I spent all afternoon and half the evening and made no progress.

1 Like

The easiest way is via Samba addon and drop the backup in the backup folder.
If your PC can’t see it, there can be some tricks but it’s to do with the PC and Windows not HA as such. I generally type \\ip-address in explorer and then you can enter the credentials.
Once the backup is in the backup folder, you need to reload in the snapshots tab (wheel in top right corner) then you can restore the snapshot. It can take 20+ minutes to restore too so be patient.
You don’t need ssh for this.
With ssh, if you are running a supervised install, change the ssh port in the addon as 22 is reserved for the host system.

I’m now wondering if the ‘beta’ part of the qcow2 image is causing issues with network connectivity :man_shrugging:

I’m kind of being a bit deliberately non-investigative too. I’m trying to see this whole experience through the eyes of a target audience newbie, but in all honesty even being fairly experienced I was pretty stumped earlier and quit for the day quite some time ago.

OK, first thing is that the point of this experiment is to see this through the eyes of a newbie that wouldn’t have understood a word you just said, but that aside…

I tried this, and got an error (maybe ‘server not found’?, I forget). As I say, I have samba working well here so the kids can move homework around so I’m fairly proficient, and the logs in the samba addon were showing it discovering the laptops, but whenever the laptops tried to connect to it it wouldn’t work.

I didn’t see anywhere to change the port in the ssh addon tbh. If I remember correctly the addon instructions don’t mention this either. It just had port 22 and a text box next to it that you either enabled or disabled. I enabled it. I tried to connect various ways. All I got was ‘connection refused’.

As per the point of the thread, its not very inviting for the target audience when even us ‘old sweats’ are struggling. As @klogg said, restoring from a snapshot should be something you come to straight away, with an option to upload it right there and then. I guess that’s probably ‘in the pipeline’ but features like that need introducing before things that would otherwise make it easy get deprecated.

Use the IP address with Samba… not the host name.
I dont use core ssh addon - i use the community one. Is there a network section in the core addon you can add the port? Or just use the community addon.

I don’t know how I can say it any differently so you can understand it - I tried that and it didn’t work :roll_eyes:

You’re also demonstrating my point really well…

“Try this, oh try that, do it this way” is all good but what’s the ‘official’ way to do it?

1 Like

A newbie wouldn’t be migrating or they wouldn’t be a newbie so not seeing your point there. Either way, what @DavidFW1960 suggested works fine, I’ve done it myself migrating between platforms twice without issue and I’m a long way from an expert on that side of things.

Your issues certainly sound self made, not anything to do with HA.

1 Like

So the target audience would never move to new hardware?

I’ve also done it myself multiple times, I’ve been here for a long time. The point is that it doesn’t work, because if it did I wouldn’t be needing to ask the questions.

How can the issues be ‘self made’ in this scenario? I’ve downloaded a pre-made official image that I have absolutely no control over, so in fact there is not one thing here that is ‘self-made’, it’s all made by homeassistant.

1 Like

The issue is on your PC/network not HA.

1 Like

No, it isn’t. But thanks for your input.

I also note from your bio and your contributions to other recent threads you’re not running on hassos, so all the advice you’re trying to give is relevant to a docker based install. I have one of those here working fine with ssh and all the trimmings.

This thread is about the official way to set up on hassos, as per the future depreciation of our preferred installation method.

I do have a HassOS install on Proxmox but yes… I prefer and use the Generic Linux install… HA Supervised on Debian.

Yeah, that’s exactly what I use and it works fine. The point I’m making is that for you and Bobby to say “it definitely works, must be a problem your end” when neither of you have tried it is a bit daft, (especially when another user in this thread had identical issues with the same ‘official image’) and it also still doesn’t answer the question of what is the official way to do it now.