The Raspberry Pi 4 has been announced!

You can boot about any is except HassOs from ssd . Just not HassOs you can boot Rasbian Buster ( or Jessie on a pi 3) from ssd and then run HASS Io in a docker. All from ssd. I run Jessie from ssd on a pi 3B+ now , not even a ssd in the slot.!!

No it will not. You need Rasbian Buster image for firmware.

I’m looking forward to getting hass.io on a more powerfull raspberry like the 4gb version, I really like this little beast doing so much of my stuff.
As soon as it’s available, I’m going to convert the current 3b+ used for hass.io to a PBX instead :slight_smile:

I’m not picking on you, ptmy, I just grabbed the first comment I saw.

There seems to be a bit of mixing up of terms in this thread (along with pretty much every other thread) about what HassIO, HassOS, and Home-Assistant actually are.

HassIO is ONLY the docker stack (specifically the supervisor container) for running Home Assistant. This gives you all the add-ons, etc.
HassIO runs on pretty much any system you can install docker on, including nearly every linux system including Ubuntu and Rasbian. If you install HassIO on Rasbian and boot Rasbian from a SSD, then you can run all of HassIO from a boot SSD.

However HassIO is not an operating system. You can’t flash HassIO to a SD card, and it wont run at all without an operating system under it.

HassOS is an entire (minimal) operating system and this is what you can flash to an SD card or disk. HassOS comes pre-built with Docker and HassIO installed.

It’s not any better that on the blog post even the dev seems to have mixed them up by talking about bringing HassIO support to the Pi4. If the Pi4 can run docker, I don’t see why they would need to do anything at all to run HassIO. They are likely talking about building support for running HassOS on it.

For a more indepth look at the different install options, this thread outlines them pretty well I think.

6 Likes

:+1:
THANKYOU for clearing it up, it’s like hearing about the different parts flying around, and everybody is talking about differnet things :smiley:

I just stumbled across my first issue, my zwave USB stick, ie this one doesnt work:

I don’t see this device appearing when i connect it:

/dev/ttyACM0

I checked lsusb and dont see any difference before / after it being connected. I posted a note over on the Pi forums too:

https://www.raspberrypi.org/forums/viewtopic.php?f=66&t=243717&p=1487216#p1487216

I tried USB 2 and USB 3 ports. and i am using one of the new original power supplies.

I opened a bug report for the Pi4:

Anyone any ideas?

1 Like

I can’t help you with the problem you’re experiencing (seems like a Raspbian driver issue) but just want to say that you can cut down that long-winded URL to just this:
https://www.amazon.co.uk/Aeotec-Z-Stick-Z-Wave-create-gateway/dp/B00YETCNOE
The rest of that URL isn’t needed (except for Amazon’s own analytics).

1 Like

I have already tested Boot configuration
I have ResinOS + HDD(usb) and everything works fine on RPI 3+ https://www.raspberrypi.org/documentation/hardware/raspberrypi/bootmodes/msd.md

But on RPI4 only possible boot now i see SD Card with Raspian Buster.
USB is not booting correctly.

Anyone resolved this problem ?

USB boot is not currently available for rpi4. We have to wait for an updated firmware.

https://www.raspberrypi.org/documentation/hardware/raspberrypi/booteeprom.md

PXE and USB Boot
Support for these additional bootmodes will be added in the future via optional bootloader updates. The current schedule is to release PXE boot first, then USB boot.

1 Like

Maybe any workaround use Bootloader on SD card to boot system on USB HardDrive?

What does “dmesg” say when you insert the stick?

1 Like

I got my definition based on description here: https://www.home-assistant.io/hassio/installation/. The title says “Installing HassIO.” You download the image that contains both the OS and docker image, which they’re calling HASSIO based on the title, then you burn the image to an SD card, and you’re done. Based on description here: https://github.com/home-assistant/hassos, I’m under the impression that HASSOS is just the OS without the docker image.

In summary, my interpretation based on the above is: HASSIO = HASSOS + HA docker imager, HASSIO = just the OS part of it.

Not sure if he cleared it up, or make it more confusing. Read my reply above.

I see how that conclusion was reasoned, and it makes sense. But is incorrect. HassIO is the Dockerized HA specifically including the HA Supervisor container. HassIO doesn’t require HassOS in any way; I run it in Ubuntu myself.
HassOS isnt distributed without Docker and HA preinstalled on it, so they’re inseparable as far as I know.

Straightening out that documentation on github to better clarify what’s what has been on my todo list for a while, so it’s not anyone’s fault for reading the unclear documentation and drawing assumptions from it.

1 Like

Hello,
yes some instructable will be great @micque

Is there more information available somewhere?

Thanks

HA is a fantastic product. But as with most fast-moving open source projects, there’s a ton of information on the internet. Many tutorials, documentations, and suggested solutions to problems are completely outdated and at times misleading. This is why I believe at least the official documentations have to be updated religiously to reflect current state of the product. Thank you for your efforts with this; I really appreciate it.

1 Like

I have a couple page write up. What is the best way to provide it? Don’t want to insert it into this topic.
Update: I just added a topic to the Installation category describing the the process I used to install Hassio on a bootable ssd. Hassio booting off ssd on a Raspberry Pi 3b+

2 Likes

Thanks a lot!

Btw - as far as my issue with the Aeotec z wave USB dongle and getting that it work with the pi 4 I managed to get a workaround working by going via a four port hub (not powered):

hey, what image is everyone using on the rpi4 hass.io?
this one? Raspberry Pi 3 Model B and B+ 32bit

1 Like