Trying to setup adaptive light add-on


i installed the adaptive light plugin through HACS, and after that added the integration in the configuration. It created 4 switch, seem the default ones. But when i select some light in the configuration frontend, it doesn’t create specific switch, for those lights. In the documentation, how i understand it, is when i enable some lights in the configuration, it creates switch for those lights.

Maybe i’m missing something, i don’t know.

I can help with this. I have nearly 20 instances of AL set up. The best advice I can give you is separate your configurations for lights that may need different lighting scenarios.

When I first started, I had all my lights on 1 adaptive lighting
That didn’t work well because there were times I wouldn’t want it to affect everything
So then I split it by device types. OK, all my accent lights get one setting and all my house lights get another setting. This worked great but if I ever needed to turn off adaptive lighting in one area, it became a problem for the rest of the house. There IS a manual override feature that’s supposed to detect when you have the lights in manual control and not adapt them but I’ve had trouble with this feature working consistently and I’ve read the same thing in the forums.

So now I have an adaptive lights for accent lights and house lights for most rooms. This is overkill because I have a ton of lighting sequences and may not be necessary for you.

Another reason to separate them is because sometimes the settings are different. My house lights, I like at a max of 50% during the day whereas I have other lights where 50% would be blinding, so they’re separated onto their own instance of adaptive lighting that maxes out at 25%.

Bearing all that in mind, you have 4 switches for adaptive lighting:
Adaptive Brightness - This is the switch that enables brightness adjustment. Enable this if you want the brightness of lights to adjust
Adaptive Color - This is the switch that adjusts the color of the light. Sounds obvious like duh? that’s why I’m here, right? on my nanoleafs, I adapt brightness only and not color (because it would mess up my nanoleaf color). Enable this if you want to adapt the color of your lights
Sleep Mode - Switch to indicate when the lights should hit that 1% and 1000K mode. You don’t have to use this (I didn’t for months) but now I use it. It’s great for making sure lights don’t come on super bright at night. Enable this so set all your lights to night mode.
Adaptive Lighting Switch - This switch has to be on in order for adaptive lighting to take over. When toggled, it will also reset the lights to the current Adaptive lights. So if all your lights are read and you hit this, it will reset them all to the correct setting. If all other switches are on, they won’t do anything unless this switch is on.

You can still control your on/offs from HA or Alexa or wherever and the adaptive lighting will take over if you configured correctly.

Protip: Until you get the hang of how it works and get your automations to do the flipping of switches for you, create a little card with the switches that will easily help you see what’s on and let you play with it/override it.
2022-05-03 19_25_50-Greenshot


That was a detailed write up. One thing I am struggling to figure out is how to speed up the transition. Sunset today was at 7:30 and after an hour and a half the lights have still not gotten to the minimum level. I tried adjusting the transition time and internal all the way down to 5 seconds but it still doesn’t seem to change anything.

I know what you’re talking about. I can’t explain why it happens but I’ve definitely witnessed the same thing. This is how I deal with it:

I have the adaptive lighting running all day with the brightness and color switches on. I have AL set up to be on the default sunrise and sunset actions. At 945 pm, my house starts going into quiet mode. Even though 945 is well after sunset, the lights will never be at 1% (this is the part I don’t understand, like you). To trigger the actual sleep mode, keeping the adaptive lighting switch still on, flip the sleep mode switch. This will turn it to night mode. So at 945, whatever lights are on, an automation runs and turns on sleep mode and any lights that have sleep mode configured will go into sleep mode.

thanks for the explaining ! It’s working great now.

1 Like

Forgive me as I am about to ask a very dumb question ….

Do the lights identified in AL have to be switched on for the AL to kick in ?

So AL doesn’t turn the lights on and off ? I would set a normal timer for example for that or just switch on via switch ?

not really. Adaptive lighting “adapts” existing lights.
Aka. you turn a light on and it gets changed to the adapted color/brightness.

You can even change this behavior a little, so when you switch a light on, it’s adapted, but if you change it by sending another command (automation or button presses in frontend) - it gives the control back to you.

1 Like

Thankyou - have worked it out and seen at first hand throughout today

Same issue here, but other way around I noticed. Set up AL yesterday and works as expected mostly. However, I turned on a few lights before sunrise, and now they’re still at a very orange-y and dim state. While if I turn on another set of lights that’s on the same AL integration, it gets a lot brighter and more white. And the same happens with that light when I turn it off and on again. So for some reason it doesn’t seem to change, or just VERY slow.

I have only_once disabled, take_over_cotrol enabled. I had detect_non_ha_canges enabled as well because I suspect it’s a problem with my Friends of Hue switches that run through Deconz. I have disabled it for now, see if that works.

So I’ve set up adaptive lighting but for some reason, it will turn on lights that are not on. Once I turn them off, after about 2 minutes, it will turn them on again. Anyone else?

It does that if you use light groups, I overcame this by selecting each light individually.

For me, I had living room selected, but if I just have the lamps on and adaptive lighting adjusts brightness or colour temperature it also did that to the main light. By selecting them individually it prevents it from adapting a light which isn’t on.

facing this error for past three months, can’t find a solution for this issue.

I’ve got this working for ceiling lights and an office lamp in my home office. However, I’m finding that the color temperature is too high for the time of day. Meaning, it is too high of a kelvin, so closer to daylight, than I want. I didn’t see any way to add some type of offset, so wanted to post here to see if there was an easy way to do this. I see a shift in time of day for sunset and sunrise to account for when it kicks in, but not on temperature or brightness, offset without a delay.

1 Like

Have you found a solution? Cause I have the same strange behaviour. (not using a light group with adaptive lighting)

Not in this app but it looks like a few people have asked for this in the repo. I asked for an offset by light sensors but it looks like other people have asked to offsets for your use case.


I’ve been running AL on HassOS Rpi4 with Conbee2 / Zigbee2Mqtt and Philips hue lights successfully for over 2 years without issue but recent AL HACS updates in the last couple of months have started turning on lights similar to symptoms others have. I’ve removed all light groups from AL and selected individual lights, but it’s now become such a problem I’ve had to disable AL temporarily to troubleshoot (kids rooms lights coming on at night!!).

@Sergeantpup would you mind sharing your exact AL config and related switch automations? I have a fairly similar set up to you (15x AL integrations set by room / accent lights triggered by motion sensors). If you’re not having any issues then hopefully I can find a solution that works…

Thanks in advance

Sure, Here’s an example:

Before we get started, I’m not using groups in any of my AL configs. I had suspected an issue with it a long time ago and switched to singular entities signed up to the AL and you’ll see that here.

This is one AL for accent lights: I circled the ones that I know I altered at some point

(also, the icons are a cute touch that I just noticed)

Selected the bulbs > Change transitions to 1 second so they’re not a hard cutover > Change the duration of the change so it’s less noticeable > pick how often you want it to adapt > set your minimum and maximum brightness (my minimum is 1 on most devices that can handle it but on nanoleaf and cololight, the minimum has to be 2 or 3 respectively for it to work) > Adjust your Color temp preferences > set your sleep mode preferences (mine are red for accent lights so they don’t disrupt sleep) > add any sunrise/sunset offsets > check settings for how you want the AL to interact with multiple turn-ons and to stop if from adapting more than at turn on.

Here’s another AL config for the same room but different types of lights:

The biggest difference and why i have this in two instances is the max brightness and the sleep mode is not red (it’s super warm white and low). All the other settings are basically the same and this is the biggest thing that changes between my AL instances.

Now to the automations/switches:
As you can see, this creates a ton of AL switches:

How else does one control them in unison but to aggregate the control into a singular switch
Here’s one for the MAIN adaptive lighting control switch for all my AL instances. By main adaptive lighting switch, I mean the one that MUST be on for it to work

I have the same thing that aggregates all the sleep mode switches:

Here, you can see a front end aggregation of all that:

This is purely for informational and override control purposes. Everything is automated but these buttons do actually turn on/off the corresponding AL switches. The buttons at the top are the aggreate group buttons that turn all of them on/off.

Knowing that I basically have 2 giant switches that are controlling this, helps explain the next part and the simplicity.

First, there’s nothing to show you in my automations for the on/off control of the lights. They are all just raw on/off of the light or light group and sensors and time. Nothing fancy here and adaptive lighting doesn’t even play a role in this except that AL is listening for the turn on calls. To which I’m sure you’d inquire,“are you sending the command to individual lights or groups?” I knew my off commands were grouped but I specifically went back and looked and it looks like my turn on commands are grouped (which makes sense to reduce popcorning).

My assumption at this point if my automations are designed like this that AL is looking for the individual turn on commands for each bulb. I likely did this to reduce the risk of a bulb turning on and the AL missing the adapter. (I think I recall this being an issue at one time)

So now you understand the AL config, the switches, the basic automations, all that’s left is when the BIG switches are thrown and that’s quite easy. At 945 a script runs and does a bunch of stuff but it turns on the aggregated sleep mode switch so it turns all the lights into sleep mode. That switch stays on until all bedroom doors are open for one minute in the morning, the sleep switch is turned off, and the AL just works for the day. No further automation.

Then why do I have a giant button that says day mode?
when a rooms automations are turned off, the automation also turns off the AL switch for that room’s AL’s. When automations are turned back on, adaptive lighting will be re-enabled through that switch. There are times where I need to turn off AL for the entire house or with my voice assistant and this helps with that. Another cool thing this does is if you toggle it twice, it’ll sweep all the lights in your house which makes them all ‘normal’ according to the time. So if one were to have an LED disco party in the middle of the day (I definitely have never done this) and perhaps the lights are in an effect mode, by turning off all the adaptive light switches and then turning them back on, it will make all the lights as you’d expect them for that time of the day.

This script kinda shows that where it get’s turned off:

This script kinda shows how it’s turned on. There’s other scripts that run anytime an automation is turned on/off so the adaptive lights follow.

Hope this helps. Let me know if you have any questions.

That’s amazing - thanks very much for the detailed rundown. There are four key take aways for me here:

  1. You trigger turning on / off your lights via HA groups and those light groups match the light entities in your AL instances,
  2. You have all lights selected as single entities in AL,
  3. You turn off AL instances when you don’t need them (and reduce network traffic),
  4. You have ‘detect non-HA changes’ selected in your config.

I’m going to make a few changes my side to mirror this config and run it for a few days to see how I get on… I’ll report back then.

Thanks again!

1 Like

I’m new onnthe HA system and adaptive lights, but I already setup it and got a runing automation with a montion sensor.
My questions, if some one can help me. I got all Philips Hue, lights, switchs and sensors, but every time a light turns on it takes a second to change from default HUE color to AL color and brightness.
My current solution is to have all lights on philips hue app with a scene 1% and neutral white. Anyone have a better solution for this?

Second situation is, when the color adapts e first change brightness and then color, it’s possible to invert this? Make the light adapt first color and them the brightness?

I do this a combination of ways that aren’t pretty:

First, to prevent bulbs from coming on too bright, I have it natively set up in my bulbs so when they turn on they ALWAYS turn on a warm white and 1%. Because the native bulb action always happens first and adaptive lighting adapts it from there, it creates the illusion that the bulbs are always starting off at 1% and then always adjusting upwards with adaptive lighting. Adaptive lighting is on a 1 second ramp so its not a jarring switch. It looks like its delicately turning on and ramping up quickly.

There’s a ramp down feature in home assistant for turning off bulbs where you can basically tell it to always turn the bulb to 1% as its turning off and the human eye doesn’t notice. This helps the bulb always ramp up instead of possibly being too bright when it’s turned on.

Theres no way to pre-load the adaption but there’s been a lot of talk in the repo about it.

All my accent lights come on as red 1% after a certain time. But because you can’t pre-load the adaptor, if I were to come up stairs the lights would flash white, before they adapt down to red if I haven’t been upstairs in a while.

I combat this with a pre-charge. After 9:45 if there’s no motion upstairs, turn all the accents to 1% red, then turn them off. Now when they come on, when I come upstairs, they’ll all come on as red. I do this in my bedroom, bathroom toilet room, and pantry for the very reason you mentioned, a split second of blinding light before it adapts got really annoying (especially every time I opened the pantry after 945 for snacks).

I’ve not found a silver bullet. Just artfully laying the technologies you have until you get a non-noticeable outcome.